Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25317

WS cleanup is not able to delete workspace containing non-ascii characters

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      ERROR: Failed to clean the workspace
      09:05:02 java.io.IOException: java.lang.reflect.InvocationTargetException
      09:05:02 	at hudson.Util.isSymlinkJava7(Util.java:360)
      09:05:02 	at hudson.Util.isSymlink(Util.java:325)
      09:05:02 	at hudson.Util.deleteRecursive(Util.java:291)
      09:05:02 	at hudson.Util.deleteContentsRecursive(Util.java:203)
      09:05:02 	at hudson.Util.deleteRecursive(Util.java:292)
      09:05:02 	at hudson.Util.deleteContentsRecursive(Util.java:203)
      09:05:02 	at hudson.Util.deleteRecursive(Util.java:292)
      09:05:02 	at hudson.Util.deleteContentsRecursive(Util.java:203)
      09:05:02 	at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$2.execute(CliGitAPIImpl.java:393)
      09:05:02 	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:153)
      09:05:02 	at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:146)
      09:05:02 	at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      09:05:02 	at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      09:05:02 	at hudson.remoting.Request$2.run(Request.java:328)
      09:05:02 	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      09:05:02 	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      09:05:02 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      09:05:02 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      09:05:02 	at java.lang.Thread.run(Thread.java:745)
      09:05:02 Caused by: java.lang.reflect.InvocationTargetException
      09:05:02 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      09:05:02 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      09:05:02 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      09:05:02 	at java.lang.reflect.Method.invoke(Method.java:606)
      09:05:02 	at hudson.Util.isSymlinkJava7(Util.java:355)
      09:05:02 	... 18 more
      09:05:02 Caused by: java.nio.file.InvalidPathException: Malformed input or input contains unmappable chacraters: /var/lib/jenkins/workspace/My-project/sub-folder/prototype/icons/skylleanl??g.svg
      09:05:02 	at sun.nio.fs.UnixPath.encode(UnixPath.java:147)
      09:05:02 	at sun.nio.fs.UnixPath.<init>(UnixPath.java:71)
      09:05:02 	at sun.nio.fs.UnixFileSystem.getPath(UnixFileSystem.java:281)
      09:05:02 	at java.io.File.toPath(File.java:2186)
      09:05:02 	... 23 more
      

      see https://issues.jenkins-ci.org/browse/JENKINS-24824?focusedCommentId=214752&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-214752

        Attachments

          Issue Links

            Activity

            vjuranek vjuranek created issue -
            olivergondza Oliver Gondža made changes -
            Field Original Value New Value
            Description see https://issues.jenkins-ci.org/browse/JENKINS-24824?focusedCommentId=214752&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-214752 {noformat}
            ERROR: Failed to clean the workspace
            09:05:02 java.io.IOException: java.lang.reflect.InvocationTargetException
            09:05:02 at hudson.Util.isSymlinkJava7(Util.java:360)
            09:05:02 at hudson.Util.isSymlink(Util.java:325)
            09:05:02 at hudson.Util.deleteRecursive(Util.java:291)
            09:05:02 at hudson.Util.deleteContentsRecursive(Util.java:203)
            09:05:02 at hudson.Util.deleteRecursive(Util.java:292)
            09:05:02 at hudson.Util.deleteContentsRecursive(Util.java:203)
            09:05:02 at hudson.Util.deleteRecursive(Util.java:292)
            09:05:02 at hudson.Util.deleteContentsRecursive(Util.java:203)
            09:05:02 at org.jenkinsci.plugins.gitclient.CliGitAPIImpl$2.execute(CliGitAPIImpl.java:393)
            09:05:02 at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:153)
            09:05:02 at org.jenkinsci.plugins.gitclient.RemoteGitImpl$CommandInvocationHandler$1.call(RemoteGitImpl.java:146)
            09:05:02 at hudson.remoting.UserRequest.perform(UserRequest.java:118)
            09:05:02 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
            09:05:02 at hudson.remoting.Request$2.run(Request.java:328)
            09:05:02 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
            09:05:02 at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            09:05:02 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            09:05:02 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            09:05:02 at java.lang.Thread.run(Thread.java:745)
            09:05:02 Caused by: java.lang.reflect.InvocationTargetException
            09:05:02 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            09:05:02 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
            09:05:02 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            09:05:02 at java.lang.reflect.Method.invoke(Method.java:606)
            09:05:02 at hudson.Util.isSymlinkJava7(Util.java:355)
            09:05:02 ... 18 more
            09:05:02 Caused by: java.nio.file.InvalidPathException: Malformed input or input contains unmappable chacraters: /var/lib/jenkins/workspace/My-project/sub-folder/prototype/icons/skylleanl??g.svg
            09:05:02 at sun.nio.fs.UnixPath.encode(UnixPath.java:147)
            09:05:02 at sun.nio.fs.UnixPath.<init>(UnixPath.java:71)
            09:05:02 at sun.nio.fs.UnixFileSystem.getPath(UnixFileSystem.java:281)
            09:05:02 at java.io.File.toPath(File.java:2186)
            09:05:02 ... 23 more
            {noformat}

            see https://issues.jenkins-ci.org/browse/JENKINS-24824?focusedCommentId=214752&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-214752
            olivergondza Oliver Gondža added a comment -

            Katrine Skovbo, I speculate the JVM might be using different encoding that the filesystem does.

            • What Unix flavour is that?
            • What does your system locale says?
            • What is the value of following properties in given slave JVM: file.encoding, sun.jnu.encoding?
            markewaite Mark Waite made changes -
            Link This issue is related to JENKINS-27910 [ JENKINS-27910 ]
            olivergondza Oliver Gondža added a comment -

            No reply in 3 months, closing as it likely is a configuration error.

            olivergondza Oliver Gondža made changes -
            Assignee vjuranek [ vjuranek ] Oliver Gondža [ olivergondza ]
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 159234 ] JNJira + In-Review [ 196025 ]

              People

              Assignee:
              olivergondza Oliver Gondža
              Reporter:
              vjuranek vjuranek
              Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: