Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25372

No nodes under "Restrict nodes"

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After updating to latest Jenkins version, can't restrict nodes on any Inheritance Project task, either newly created or already existing. Autocompletion of nodes is not offered, and forcing a node name won't simply stay saved.
      It works fine on Freestyle projects.

        Attachments

          Issue Links

            Activity

            seb_p Sebastiano P created issue -
            danielbeck Daniel Beck added a comment -
            seb_p Sebastiano P added a comment -

            Is there a way I can help to work it out? As I said, this behaviour is reproducible even on a brand new Inheritance project (whether or not it's set as an abstract project).

            danielbeck Daniel Beck added a comment -

            If you're bored, verify that the issue does occur in 1.585 but does not occur in 1.584 (thereby either disproving or strengthening by assumption above).

            seb_p Sebastiano P added a comment -

            Definitely did not happen in 1.584. Cannot try .585 as it's a production server. Thanks

            jglick Jesse Glick made changes -
            Field Original Value New Value
            Assignee Matthew Moore [ mattmoor ]
            mattmoor Matthew Moore added a comment -

            I have submitted: https://github.com/jenkinsci/jenkins/pull/1447

            Which should fix this in future cores.

            mattmoor Matthew Moore added a comment -

            The fix has been merged, not sure what release it will make it into.

            oleg_nenashev Oleg Nenashev made changes -
            Link This issue is related to JENKINS-25533 [ JENKINS-25533 ]
            oleg_nenashev Oleg Nenashev made changes -
            Component/s core [ 15593 ]
            alghe Alexandru Gheorghe added a comment -

            Seems it went under: release v1.589

            oleg_nenashev Oleg Nenashev added a comment -

            Just a notification Jenkins users...
            Please be aware about JENKINS-25533

            mhschroe Martin Schröder added a comment - - edited

            Hi everyone.

            Maintainer of the "Inheritance Project Plugin" speaking here, which was the reason for this workaround.

            The root-cause has been fixed on our side, and the code from the plugin has been aligned with the code from LTS 1.596.x.

            We are currently preparing the full release of the updated plugin, which should arrive within a week (wk.26/27). It took longer than expected to move all of our internal plugins from 1.509.x to 1.596.x, which has significantly delayed upstreaming the complete set of fixes into the OSS community.

            We sincerely apologize for the delays and the resulting necessity for this ugly workaround in the Jenkins core.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 159338 ] JNJira + In-Review [ 179949 ]
            danielbeck Daniel Beck added a comment -

            Apparently long since fixed.

            danielbeck Daniel Beck made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]

              People

              Assignee:
              mattmoor Matthew Moore
              Reporter:
              seb_p Sebastiano P
              Votes:
              0 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: