Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25499

Warning on console about toNormalizedIconNameClass

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Have seen this on console when starting with cloudbees-workflow-aggregator installed. What does it mean?

      ... org.apache.commons.jexl.util.Introspector getMethod
      SEVERE: Introspection Error : Ambiguous method invocation toNormalizedIconNameClass( null) for class org.jenkins.ui.icon.IconSet
      

        Attachments

          Issue Links

            Activity

            Hide
            dogfood dogfood added a comment -

            Integrated in jenkins_main_trunk #3870
            [FIXED JENKINS-25499] Updated icon-set dependency to version 1.0.5 (Revision f87c72f15858edf5dd499349569497c3c2bf4449)

            Result = SUCCESS
            tom.fennelly : f87c72f15858edf5dd499349569497c3c2bf4449
            Files :

            • changelog.html
            • core/pom.xml
            Show
            dogfood dogfood added a comment - Integrated in jenkins_main_trunk #3870 [FIXED JENKINS-25499] Updated icon-set dependency to version 1.0.5 (Revision f87c72f15858edf5dd499349569497c3c2bf4449) Result = SUCCESS tom.fennelly : f87c72f15858edf5dd499349569497c3c2bf4449 Files : changelog.html core/pom.xml
            Hide
            tfennelly Tom FENNELLY added a comment -

            Fixed this issue (and JENKINS-25498) in the icon-shim plugin. Updated dependency to new version of same.

            Show
            tfennelly Tom FENNELLY added a comment - Fixed this issue (and JENKINS-25498 ) in the icon-shim plugin. Updated dependency to new version of same.
            Hide
            walterk82 Walter Kacynski added a comment -

            Just upgraded to 1.580.1.1 and I am experiencing this message as well. Is there a loss of functionality this this error?

            Show
            walterk82 Walter Kacynski added a comment - Just upgraded to 1.580.1.1 and I am experiencing this message as well. Is there a loss of functionality this this error?
            Hide
            jglick Jesse Glick added a comment -

            Possibly caused by JENKINS-25498, though the error message is so lacking in detail as to make it hard to tell.

            Show
            jglick Jesse Glick added a comment - Possibly caused by JENKINS-25498 , though the error message is so lacking in detail as to make it hard to tell.

              People

              Assignee:
              tfennelly Tom FENNELLY
              Reporter:
              jglick Jesse Glick
              Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: