Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25735

Mask Passwords doen't mask Credentials Parameter

    XMLWordPrintable

Details

    • New Feature
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Fixed
    • mask-passwords-plugin
    • None

    Description

      After installing Mask Passwords Plugin 2.7.2, it allows the system configuration to set the passwords to be masked. One of which is Credentials Parameter.

      However, in a project, if mask passwords is selected and an existing credential is used in the build step, the information is still displayed plaintext within the console output.

      Steps To Reproduce:

      1. Configure System
        • Mask Passwords - Parameters to automatically mask
          [x] Non-Stored Password Parameter
          [x] Credentials Parameter
          [x] Password Parameter
        • Mask Passwords - Global name/password pairs
          None added.
          I already have several "Username with password" Global credentials
      2. Create freestyle project
        • [x] Mask passwords (and enable global passwords)
          Responce: Password Parameters, or any other type of build parameters selected for masking in Hudson's/Jenkins' main configuration screen (Manage Hudson > Configure System), will be automatically masked.
        • [x] Use secret text(s) or file(s)
          Add: Username and password
          Variable: oracleCredential
          Credentials
          (*) Specific credentials
          my_oracle_username/***** (Oracle remote login)
          parameter expression: ${oracleCredential}
        • Add build step: Execute Windows batch command
          Command: @echo %oracleCredential%
        • [Save]
      3. Build Now, and examine Console Output
        Expected: ********** is displayed in place of %oracleCredential%
        Actual: Actual username:password value of %oracleCredential% is displayed.

      Attachments

        Issue Links

          Activity

            marshall Marshall GSEIT created issue -
            danielbeck Daniel Beck added a comment -

            Looks like the Credentials Binding variable, not being a build parameter, is simply not covered by the existing build options. This is more a new feature, unless you can show that actual build parameters (entries on the "Build with Parameters" form) are also affected.

            danielbeck Daniel Beck added a comment - Looks like the Credentials Binding variable, not being a build parameter, is simply not covered by the existing build options. This is more a new feature, unless you can show that actual build parameters (entries on the "Build with Parameters" form) are also affected.
            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Issue Type Bug [ 1 ] New Feature [ 2 ]
            Labels credentials, jenkins, mask-passwords plugin, security,

            Nope, this is a bug.

            When selecting "Mask passwords", the build job's configuration page then states:

            Password Parameters, or any other type of build parameters selected for masking in Hudson's/Jenkins' main configuration screen (Manage Hudson > Configure System), will be automatically masked.

            Emphasis mine.

            As long Jenkins' main configuration screen presents end-users with the option of "Credentials Parameter" under Mask Passwords; this is a bug.

            marshall Marshall GSEIT added a comment - Nope, this is a bug. When selecting "Mask passwords", the build job's configuration page then states: Password Parameters, or any other type of build parameters selected for masking in Hudson's/Jenkins' main configuration screen (Manage Hudson > Configure System), will be automatically masked. Emphasis mine. As long Jenkins' main configuration screen presents end-users with the option of "Credentials Parameter" under Mask Passwords; this is a bug.
            danielbeck Daniel Beck added a comment -

            "Credentials Parameter" is what you select in "This build is parameterized", "Add Parameter", "Credentials Parameter".

            "Use secret text(s) or file(s)" is not a build parameter.

            danielbeck Daniel Beck added a comment - "Credentials Parameter" is what you select in "This build is parameterized", "Add Parameter", "Credentials Parameter". "Use secret text(s) or file(s)" is not a build parameter.

            Daniel, thank you so much for your time.

            If I enable "This build is parameterized", and add an existing "Username with password" credential. The build outputs a GUID.
            E.g. @echo oracleCredentialParameter=%oracleCredentialParameter%
            will display oracleCredentialParameter=3F2504E0-4F89-41D3-9A0C-0305E82C3301

            The behavior is the same whether I select "Mask passwords" or not.

            I also tried adding a "String Parameter". In this case the build output the correct information.
            E.g. @echo oracleUsername=%oracleUsername%
            will display oracleUsername=ThisIsMyOracleUsername

            But, like above, the behavior is the same whether I select "Mask passwords" or not.

            marshall Marshall GSEIT added a comment - Daniel, thank you so much for your time. If I enable "This build is parameterized", and add an existing "Username with password" credential. The build outputs a GUID. E.g. @echo oracleCredentialParameter=%oracleCredentialParameter% will display oracleCredentialParameter=3F2504E0-4F89-41D3-9A0C-0305E82C3301 The behavior is the same whether I select "Mask passwords" or not. I also tried adding a "String Parameter". In this case the build output the correct information. E.g. @echo oracleUsername=%oracleUsername% will display oracleUsername=ThisIsMyOracleUsername But, like above, the behavior is the same whether I select "Mask passwords" or not.
            danielbeck Daniel Beck added a comment -

            The behavior is the same whether I select "Mask passwords" or not.

            That parameter type only provides the UUID (which isn't particularly sensitive), and needs plugins to cooperate to get the data out from the credentials store. However, I expect if the password were printed somehow, it'd be masked correctly.

            danielbeck Daniel Beck added a comment - The behavior is the same whether I select "Mask passwords" or not. That parameter type only provides the UUID (which isn't particularly sensitive), and needs plugins to cooperate to get the data out from the credentials store. However, I expect if the password were printed somehow, it'd be masked correctly.
            oleg_nenashev Oleg Nenashev added a comment -

            Workaround: Use masking features of EnvInject plugin

            oleg_nenashev Oleg Nenashev added a comment - Workaround: Use masking features of EnvInject plugin

            amazed to see 'low' priority for this

            okram999 Niristotle Okram added a comment - amazed to see 'low' priority for this
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 159712 ] JNJira + In-Review [ 180092 ]
            oleg_nenashev Oleg Nenashev made changes -
            Assignee Daniel Petisme [ danielpetisme ] Oleg Nenashev [ oleg_nenashev ]
            oleg_nenashev Oleg Nenashev made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            oleg_nenashev Oleg Nenashev added a comment -

            Reassigned to me since there is a pending PR: https://github.com/jenkinsci/mask-passwords-plugin/pull/9

            oleg_nenashev Oleg Nenashev added a comment - Reassigned to me since there is a pending PR: https://github.com/jenkinsci/mask-passwords-plugin/pull/9
            oleg_nenashev Oleg Nenashev made changes -
            Status In Progress [ 3 ] In Review [ 10005 ]
            oleg_nenashev Oleg Nenashev added a comment -

            "Right" implementation: https://github.com/jenkinsci/mask-passwords-plugin/pull/12
            Waiting for reviews there

            oleg_nenashev Oleg Nenashev added a comment - "Right" implementation: https://github.com/jenkinsci/mask-passwords-plugin/pull/12 Waiting for reviews there

            Code changed in jenkins
            User: Mads Nielsen
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/292a54d3bb5859bca88364ff0bde2dd61f71e18f
            Log:
            JENKINS-25735 Credentials can now be masked.

            There is a bug in the implemetation of the isMasked(String paramValueClassName) method.
            Simply put, the paramvalue (Specific class to mask) would never match the class of the getValue() method. For instance when using reflection the CredentialParameterDefinition getDefaultParameterValue() value, we get the return type to be ParameterValue...that is incorrect since the method returns a CredentialsParameterValue, which is the class name we use to check agains 'Credentials'.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Mads Nielsen Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java http://jenkins-ci.org/commit/mask-passwords-plugin/292a54d3bb5859bca88364ff0bde2dd61f71e18f Log: JENKINS-25735 Credentials can now be masked. There is a bug in the implemetation of the isMasked(String paramValueClassName) method. Simply put, the paramvalue (Specific class to mask) would never match the class of the getValue() method. For instance when using reflection the CredentialParameterDefinition getDefaultParameterValue() value, we get the return type to be ParameterValue...that is incorrect since the method returns a CredentialsParameterValue, which is the class name we use to check agains 'Credentials'.

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/8b71ffee601454228fe3e4d7cedc02db34e9c920
            Log:
            JENKINS-25735 - Revert formatting changes

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java http://jenkins-ci.org/commit/mask-passwords-plugin/8b71ffee601454228fe3e4d7cedc02db34e9c920 Log: JENKINS-25735 - Revert formatting changes

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/02fc70ae96ddacff8e3bb55307d8300d73cf7a88
            Log:
            JENKINS-25735 - Also check createValue(StaplerRequest) in MaskPasswordsConfig

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java http://jenkins-ci.org/commit/mask-passwords-plugin/02fc70ae96ddacff8e3bb55307d8300d73cf7a88 Log: JENKINS-25735 - Also check createValue(StaplerRequest) in MaskPasswordsConfig

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            README.md
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConsoleLogFilter.java
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsOutputStream.java
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.properties
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/config.jelly
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/config.properties
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/global.jelly
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/global.properties
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help-globalVarMaskEnabledGlobally.html
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help-globalVarMaskRegexes.html
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help-globalVarPasswordPairs.html
            src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help.html
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/c27cd39c94968c4d1cb9d76c10726d07cb9c50c8
            Log:
            Merge branch 'master' into JENKINS-25735

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: README.md src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConsoleLogFilter.java src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsOutputStream.java src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.properties src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/config.jelly src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/config.properties src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/global.jelly src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/global.properties src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help-globalVarMaskEnabledGlobally.html src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help-globalVarMaskRegexes.html src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help-globalVarPasswordPairs.html src/main/resources/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper/help.html src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java http://jenkins-ci.org/commit/mask-passwords-plugin/c27cd39c94968c4d1cb9d76c10726d07cb9c50c8 Log: Merge branch 'master' into JENKINS-25735

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/0ddf7b331c9d895152ad374aaea74af72cf549d4
            Log:
            JENKINS-25735 - Clarify the comment

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java http://jenkins-ci.org/commit/mask-passwords-plugin/0ddf7b331c9d895152ad374aaea74af72cf549d4 Log: JENKINS-25735 - Clarify the comment

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/c499cefb2aac4bc17965e78d6d36e49eec42a9eb
            Log:
            Merge branch 'JENKINS-25735' into JENKINS-41955-mask-passwords

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java http://jenkins-ci.org/commit/mask-passwords-plugin/c499cefb2aac4bc17965e78d6d36e49eec42a9eb Log: Merge branch ' JENKINS-25735 ' into JENKINS-41955 -mask-passwords

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java
            src/test/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterTest.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/d3d8c23e099f8b503b2af375105f5ffc03fad9c3
            Log:
            JENKINS-25735 JENKINS-41955 - Tests should invalidate caches where possible

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java src/test/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterTest.java http://jenkins-ci.org/commit/mask-passwords-plugin/d3d8c23e099f8b503b2af375105f5ffc03fad9c3 Log: JENKINS-25735 JENKINS-41955 - Tests should invalidate caches where possible

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            src/test/java/com/michelin/cio/hudson/plugins/integrations/CorePasswordParameterTest.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordConfigTests.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java
            src/test/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterTest.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/3d57fab2af5d3016e9bfd19eacca60095f744811
            Log:
            JENKINS-25735 JENKINS-41995 - Create more tests

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java src/test/java/com/michelin/cio/hudson/plugins/integrations/CorePasswordParameterTest.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordConfigTests.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java src/test/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterTest.java http://jenkins-ci.org/commit/mask-passwords-plugin/3d57fab2af5d3016e9bfd19eacca60095f744811 Log: JENKINS-25735 JENKINS-41995 - Create more tests

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            src/test/java/com/michelin/cio/hudson/plugins/integrations/CorePasswordParameterTest.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/0a73ebe8af0602cacdfa277df66f2685879a08a0
            Log:
            JENKINS-25735 - Always allow hudson.model.Passwordparameter and its children

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java src/test/java/com/michelin/cio/hudson/plugins/integrations/CorePasswordParameterTest.java http://jenkins-ci.org/commit/mask-passwords-plugin/0a73ebe8af0602cacdfa277df66f2685879a08a0 Log: JENKINS-25735 - Always allow hudson.model.Passwordparameter and its children

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/590e5df2b5ddae474d191079e40ae127f3cb984b
            Log:
            JENKINS-25735 - Make FindBugs happy & improve diagnostics

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java http://jenkins-ci.org/commit/mask-passwords-plugin/590e5df2b5ddae474d191079e40ae127f3cb984b Log: JENKINS-25735 - Make FindBugs happy & improve diagnostics

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java
            src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java
            src/main/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterDefinition.java
            src/test/java/com/michelin/cio/hudson/plugins/integrations/CorePasswordParameterTest.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordConfigTests.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java
            src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java
            src/test/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterTest.java
            http://jenkins-ci.org/commit/mask-passwords-plugin/bd5f530db9c5275313de247dfd3c8957a88222a6
            Log:
            Merge pull request #12 from oleg-nenashev/JENKINS-25735-41955-mask-passwords

            [JENKINS-25735, JENKINS-41955, etc.] Improve masking of passwords in the plugin

            Compare: https://github.com/jenkinsci/mask-passwords-plugin/compare/93abe61816c3...bd5f530db9c5

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsBuildWrapper.java src/main/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsConfig.java src/main/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterDefinition.java src/test/java/com/michelin/cio/hudson/plugins/integrations/CorePasswordParameterTest.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordConfigTests.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsURLEncodingTest.java src/test/java/com/michelin/cio/hudson/plugins/maskpasswords/MaskPasswordsWorkflowTest.java src/test/java/com/michelin/cio/hudson/plugins/passwordparam/PasswordParameterTest.java http://jenkins-ci.org/commit/mask-passwords-plugin/bd5f530db9c5275313de247dfd3c8957a88222a6 Log: Merge pull request #12 from oleg-nenashev/ JENKINS-25735 -41955-mask-passwords [JENKINS-25735, JENKINS-41955, etc.] Improve masking of passwords in the plugin Compare: https://github.com/jenkinsci/mask-passwords-plugin/compare/93abe61816c3...bd5f530db9c5
            oleg_nenashev Oleg Nenashev added a comment -

            I suppose it's fixed now. If no, please reopen

            oleg_nenashev Oleg Nenashev added a comment - I suppose it's fixed now. If no, please reopen
            oleg_nenashev Oleg Nenashev made changes -
            Resolution Fixed [ 1 ]
            Status In Review [ 10005 ] Resolved [ 5 ]
            jamesdumay James Dumay made changes -
            Remote Link This issue links to "CloudBees Internal OSS-2111 (Web Link)" [ 18416 ]

            People

              oleg_nenashev Oleg Nenashev
              marshall Marshall GSEIT
              Votes:
              7 Vote for this issue
              Watchers:
              11 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: