Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25758

NPE when triggering downstream job (again)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Environment:
      Jenkins 1.590
      Fedora release 20 (Heisenbug) x86_64
      OpenJDK Runtime Environment 1.7.0_71-mockbuild_2014_10_15_17_02-b00
    • Similar Issues:

      Description

      We've some jobs which check for repo changes only without any build step. They are used to trigger some downstream jobs.

      But instead of triggering the jobs they fire this NPE:

      First time build. Skipping changelog.
      Warning: you have no plugins providing access control for builds, so falling back to legacy behavior of permitting any downstream builds to be triggered
      FATAL: null
      java.lang.NullPointerException
      	at hudson.model.Result.isBetterOrEqualTo(Result.java:125)
      	at jenkins.triggers.ReverseBuildTrigger.shouldTrigger(ReverseBuildTrigger.java:133)
      	at jenkins.triggers.ReverseBuildTrigger.access$000(ReverseBuildTrigger.java:83)
      	at jenkins.triggers.ReverseBuildTrigger$1.shouldTriggerBuild(ReverseBuildTrigger.java:140)
      	at hudson.tasks.BuildTrigger.execute(BuildTrigger.java:243)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.cleanUp(AbstractBuild.java:699)
      	at hudson.model.Build$BuildExecution.cleanUp(Build.java:194)
      	at hudson.model.Run.execute(Run.java:1805)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:89)
      	at hudson.model.Executor.run(Executor.java:240)
      

      There are a lot of JENKINS-Issues related to similar problems. But all of them are resolved fixed, cannot reproduce, or duplicated. So this seems to be a new problem.

        Attachments

          Issue Links

            Activity

            sledz Steffen Sledz created issue -
            sledz Steffen Sledz made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-22821 [ JENKINS-22821 ]
            sledz Steffen Sledz made changes -
            Link This issue is related to JENKINS-23686 [ JENKINS-23686 ]
            sledz Steffen Sledz made changes -
            Link This issue is related to JENKINS-22397 [ JENKINS-22397 ]
            sledz Steffen Sledz made changes -
            Link This issue is related to JENKINS-16956 [ JENKINS-16956 ]
            sledz Steffen Sledz made changes -
            Labels dependencies trigger
            sledz Steffen Sledz made changes -
            Labels dependencies trigger dependencies permissions trigger
            sledz Steffen Sledz made changes -
            Description We've some trigger-only jobs which check for repo changes only without any build step. They are used to trigger some downstream jobs only but fire this NPE:
            {noformat}
            First time build. Skipping changelog.
            Warning: you have no plugins providing access control for builds, so falling back to legacy behavior of permitting any downstream builds to be triggered
            FATAL: null
            java.lang.NullPointerException
            at hudson.model.Result.isBetterOrEqualTo(Result.java:125)
            at jenkins.triggers.ReverseBuildTrigger.shouldTrigger(ReverseBuildTrigger.java:133)
            at jenkins.triggers.ReverseBuildTrigger.access$000(ReverseBuildTrigger.java:83)
            at jenkins.triggers.ReverseBuildTrigger$1.shouldTriggerBuild(ReverseBuildTrigger.java:140)
            at hudson.tasks.BuildTrigger.execute(BuildTrigger.java:243)
            at hudson.model.AbstractBuild$AbstractBuildExecution.cleanUp(AbstractBuild.java:699)
            at hudson.model.Build$BuildExecution.cleanUp(Build.java:194)
            at hudson.model.Run.execute(Run.java:1805)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:89)
            at hudson.model.Executor.run(Executor.java:240)
            {noformat}

            There are a lot of JENKINS-Issues related to similar problems. But all of them are resolved *fixed*, *cannot reproduce*, or *duplicated*. So this seems to be a new problem.
            We've some jobs which check for repo changes only without any build step. They are used to trigger some downstream jobs.

            But instead of triggering the jobs they fire this NPE:

            {noformat}
            First time build. Skipping changelog.
            Warning: you have no plugins providing access control for builds, so falling back to legacy behavior of permitting any downstream builds to be triggered
            FATAL: null
            java.lang.NullPointerException
            at hudson.model.Result.isBetterOrEqualTo(Result.java:125)
            at jenkins.triggers.ReverseBuildTrigger.shouldTrigger(ReverseBuildTrigger.java:133)
            at jenkins.triggers.ReverseBuildTrigger.access$000(ReverseBuildTrigger.java:83)
            at jenkins.triggers.ReverseBuildTrigger$1.shouldTriggerBuild(ReverseBuildTrigger.java:140)
            at hudson.tasks.BuildTrigger.execute(BuildTrigger.java:243)
            at hudson.model.AbstractBuild$AbstractBuildExecution.cleanUp(AbstractBuild.java:699)
            at hudson.model.Build$BuildExecution.cleanUp(Build.java:194)
            at hudson.model.Run.execute(Run.java:1805)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:89)
            at hudson.model.Executor.run(Executor.java:240)
            {noformat}

            There are a lot of JENKINS-Issues related to similar problems. But all of them are resolved *fixed*, *cannot reproduce*, or *duplicated*. So this seems to be a new problem.
            danielbeck Daniel Beck added a comment -

            This looks a lot like JENKINS-23191. Make sure the downstream project (the one with the trigger defined) has one of the result options selected.

            sledz Steffen Sledz made changes -
            Link This issue duplicates JENKINS-23191 [ JENKINS-23191 ]
            sledz Steffen Sledz added a comment -

            You're right. After resetting the result options for all downstream projects everything works well.

            sledz Steffen Sledz made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 159736 ] JNJira + In-Review [ 196183 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              sledz Steffen Sledz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: