Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26030

Build deletion fails due to file lock

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      After running a trivial flow

      node {}
      

      on Windows, trying to delete it fails due to a lock error on 3.log, the one with (one line of) output.

      Deleting a build of an empty flow works, as does a flow

      echo 'hello'
      

      so the problem might be specific to ExecutorStep.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick created issue -
            jglick Jesse Glick added a comment -

            Symptoms similar to those in JENKINS-22205 reported in the case of NFS storage.

            jglick Jesse Glick made changes -
            Field Original Value New Value
            Link This issue is related to JENKINS-22205 [ JENKINS-22205 ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jglick Jesse Glick added a comment -

            7608ed3dc3c77fbfd946697869d4e669c1fc334b

            jglick Jesse Glick made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: ikedam
            Path:
            src/test/java/hudson/plugins/copyartifact/CopyArtifactTest.java
            src/test/java/hudson/plugins/copyartifact/CopyArtifactWorkflowTest.java
            http://jenkins-ci.org/commit/copyartifact-plugin/1308f8da0170ff3010054417bdcf5d88bd536df4
            Log:
            JENKINS-26694 Make tests succeed on Windows: HudsonTestCase using workflow-1.1 fails for JENKINS-26030.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            support/src/main/java/org/jenkinsci/plugins/workflow/support/DefaultStepContext.java
            http://jenkins-ci.org/commit/workflow-support-plugin/d054b77128dcf8e83563271bc216edabcf493c4c
            Log:
            [FIXED JENKINS-26030] Close logger streams after the owning node finishes, so we do not leak file handles.
            Originally-Committed-As: 7608ed3dc3c77fbfd946697869d4e669c1fc334b

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 160020 ] JNJira + In-Review [ 196282 ]
            abayer Andrew Bayer made changes -
            Component/s pipeline-general [ 21692 ]
            abayer Andrew Bayer made changes -
            Component/s workflow-plugin [ 18820 ]
            menges_ghebre Mengesteab Ghebreyesus added a comment -

            We are running Jenkins version 2.56  on Windows 7

            We have separated builds storage (builds on anther driver)

            We have the same problem (deletion of builds fails due to file lock on log file). But only on Builds, which run hourly.

            need help. Thank you very much

            menges_ghebre Mengesteab Ghebreyesus made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            jglick Jesse Glick added a comment -

            Mengesteab Ghebreyesus please do not reopen. File a fresh bug report with complete, self-contained steps to reproduce your error from scratch, and link to this or anything else which seems potentially related.

            jglick Jesse Glick made changes -
            Resolution Fixed [ 1 ]
            Status Reopened [ 4 ] Resolved [ 5 ]

              People

              Assignee:
              jglick Jesse Glick
              Reporter:
              jglick Jesse Glick
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: