Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26081

footer-container is not fixed

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      #footer-container is defined as
      position: absolute;

      but must be
      position: fixed;

      because footer moves up when any page is vertically scrolled.

        Attachments

          Activity

          aleixce Aleix CE created issue -
          aleixce Aleix CE added a comment -

          css/style.css

          danielbeck Daniel Beck made changes -
          Field Original Value New Value
          Labels gui gui user-experience
          danielbeck Daniel Beck added a comment -

          Could you upload a screenshot (GIF, PNG or JPG) demonstrating the problem?

          aleixce Aleix CE made changes -
          Attachment jenkins.footer.notfixed.png [ 28187 ]
          draugz Edgars Grinvalds made changes -
          Assignee Edgars Grinvalds [ draugz ]
          draugz Edgars Grinvalds added a comment -

          Fixed. Take a look at pull request:

          https://github.com/jenkinsci/jenkins/pull/1545

          draugz Edgars Grinvalds made changes -
          Assignee Edgars Grinvalds [ draugz ]
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          kohsuke Kohsuke Kawaguchi added a comment -

          The idea is that we don't want footer to be visible all the time, because it doesn't add much useful information. I also couldn't reproduce the problem.

          I suspect e2ec9eb3c23a6b4f63c338e634d647486a136f7b has fixed this issue, which went into 1.598. And since the left sidebar is float, if this problem resurfaces, I wonder if we can fix it by just adding "clear:both" on #footer-container.

          kohsuke Kohsuke Kawaguchi made changes -
          Assignee Kohsuke Kawaguchi [ kohsuke ]
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 160071 ] JNJira + In-Review [ 208298 ]

            People

            Assignee:
            kohsuke Kohsuke Kawaguchi
            Reporter:
            aleixce Aleix CE
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: