Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26272

Listing plugins with Jenkins cli doesn't show available updates

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: cli
    • Labels:
    • Environment:
      Ubuntu 12.04
      Jenkins 1.595
    • Similar Issues:

      Description

      Deployed Jenkins and right after listed the plugins. Here is the script:

      sudo sh -c 'echo deb http://pkg.jenkins-ci.org/debian binary/ > /etc/apt/sources.list.d/jenkins.list'
      sudo apt-get update
      sudo apt-get install -y jenkins
      sleep 30s
      curl -s http://$CI_HOSTNAME:8080/jnlpJars/jenkins-cli.jar > $JENKINS_CLI_JAR
      java -jar $JENKINS_CLI_JAR -s http://$CI_HOSTNAME:8080/ list-plugins

      This is the output:

      [exec] ==> ci: javadoc Javadoc Plugin 1.1
      [exec] ==> ci: translation Translation Assistance plugin 1.10
      [exec] ==> ci:
      [exec] ==> ci: ssh-slaves SSH Slaves plugin 1.9
      [exec] ==> ci: maven-plugin Maven Integration plugin 2.7.1
      [exec] ==> ci: windows-slaves Windows Slaves Plugin 1.0
      [exec] ==> ci: subversion Subversion Plug-in 1.54
      [exec] ==> ci: mailer Mailer Plugin 1.11
      [exec] ==> ci: matrix-auth Matrix Authorization Strategy Plugin 1.1
      [exec] ==> ci: junit JUnit Plugin 1.2-beta-4
      [exec] ==> ci: cvs CVS Plug-in 2.11
      [exec] ==> ci: ldap LDAP Plugin 1.6
      [exec] ==> ci: pam-auth PAM Authentication plugin 1.1
      [exec] ==> ci: matrix-project Matrix Project Plugin 1.3
      [exec] ==> ci: antisamy-markup-formatter OWASP Markup Formatter Plugin 1.1
      [exec] ==> ci: ant Ant Plugin 1.2
      [exec] ==> ci: credentials Credentials Plugin 1.18
      [exec] ==> ci: ssh-credentials SSH Credentials Plugin 1.10
      [exec] ==> ci: external-monitor-job External Monitor Job Type Plugin 1.4

      Using the GUI doesn't show the updates list either, nor the available plugins.

        Attachments

          Activity

          lioramilbaum Liora Milbaum created issue -
          danielbeck Daniel Beck added a comment -

          Not a bug, it takes a while for Jenkins to download update center metadata (and usually interactive access to its UI).

          danielbeck Daniel Beck made changes -
          Field Original Value New Value
          Resolution Not A Defect [ 7 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 160333 ] JNJira + In-Review [ 196388 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            lioramilbaum Liora Milbaum
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: