Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26347

Credentials not found for merge from mainline

    XMLWordPrintable

Details

    • Bug
    • Status: In Progress (View Workflow)
    • Critical
    • Resolution: Unresolved
    • svnmerge-plugin
    • None
    • jenkins 1.595, svnmerge 2.4, CentOS 6.3, Firefox, Oracle java 1.7

    Description

      svnmerge plugin 2.4, jenkins 1.595, matrix-based access control (with additional boxes checked), single module.

      At the build step "Rebase with upstream Subversion revision" set to "Latest revision", I get the error:

      13:24:06 [EnvInject] - Executing scripts and injecting environment variables after the SCM step.
      ...
      13:24:06 [EnvInject] - Variables injected successfully.
      13:24:06 FATAL: hudson.scm.SubversionSCM.createAuthenticationProvider(Lhudson/model/AbstractProject;Lhudson/scm/SubversionSCM$ModuleLocation;)Lorg/tmatesoft/svn/core/auth/ISVNAuthenticationProvider;
      13:24:06 java.lang.NoSuchMethodError: hudson.scm.SubversionSCM.createAuthenticationProvider(Lhudson/model/AbstractProject;Lhudson/scm/SubversionSCM$ModuleLocation;)Lorg/tmatesoft/svn/core/auth/ISVNAuthenticationProvider;
      13:24:06 at jenkins.plugins.svnmerge.FeatureBranchProperty.rebase(FeatureBranchProperty.java:162)
      13:24:06 at jenkins.plugins.svnmerge.RebaseAction.perform(RebaseAction.java:115)
      13:24:06 at jenkins.plugins.svnmerge.RebaseBuilder.perform(RebaseBuilder.java:50)
      13:24:06 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      13:24:06 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
      13:24:06 at hudson.model.Build$BuildExecution.build(Build.java:199)
      13:24:06 at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      13:24:06 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      13:24:06 at hudson.model.Run.execute(Run.java:1759)
      13:24:06 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      13:24:06 at hudson.model.ResourceController.execute(ResourceController.java:89)
      13:24:06 at hudson.model.Executor.run(Executor.java:240)

      I'm not sure what this error is telling me. The original sync from the feature branch worked flawlessly. It would appear that it's trying to do some new authentication for the merge, but it's not clear why it's not getting credentials to use. Wouldn't it just be using the credentials from the feature branch sync?

      Attachments

        Issue Links

          Activity

            greghansen Greg Hansen created issue -
            hugueschabot Hugues Chabot made changes -
            Field Original Value New Value
            Assignee Kohsuke Kawaguchi [ kohsuke ] Hugues Chabot [ hugueschabot ]
            hugueschabot Hugues Chabot made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            hugueschabot Hugues Chabot made changes -
            Link This issue is related to JENKINS-26357 [ JENKINS-26357 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 160410 ] JNJira + In-Review [ 185563 ]

            People

              hugueschabot Hugues Chabot
              greghansen Greg Hansen
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated: