Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2658

Use of images for histograms makes page load very slow

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • warnings-plugin
    • None
    • Platform: All, OS: All

    Description

      Every row in a page like in the above URL apparently loads a separate image from
      the server to display the histogram bar, e.g.

      http://deadlock.netbeans.org/hudson/job/test-compilation/lastSuccessfulBuild/warningsResult/category.deprecation/statistics?object=package.org.netbeans.modules.visualweb.jsfsupport.container

      For a large build, it therefore can take several minutes (and plenty of network
      activity and server load) just to display a single bar chart.

      This is silly. Consider using JavaScript and/or CSS to render bars using HTML.

      Attachments

        Issue Links

          Activity

            jglick Jesse Glick created issue -
            drulli Ulli Hafner added a comment -

            Duplicate.

            drulli Ulli Hafner added a comment - Duplicate.
            drulli Ulli Hafner made changes -
            Field Original Value New Value
            Status Open [ 1 ] In Progress [ 3 ]
            drulli Ulli Hafner added a comment -

            Do you have a suggestion on how to render this with CSS? Please use issue 2429
            for your comments. Thanks, Ulli

                • This issue has been marked as a duplicate of 2429 ***
            drulli Ulli Hafner added a comment - Do you have a suggestion on how to render this with CSS? Please use issue 2429 for your comments. Thanks, Ulli This issue has been marked as a duplicate of 2429 ***
            drulli Ulli Hafner made changes -
            Resolution Duplicate [ 3 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            drulli Ulli Hafner made changes -
            Link This issue duplicates JENKINS-2429 [ JENKINS-2429 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 132731 ] JNJira + In-Review [ 201624 ]

            People

              drulli Ulli Hafner
              jglick Jesse Glick
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: