Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26737

AD can not log on with email address (regression in 1.39)

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Fixed
    • None
    • Jenkins ver 1.580.3 / Debian Wheezy (amd64)

    Description

      When using Active Directory, connection with email (e.g. john.doe@company.com) + Domain password fails.

      But:

      • connection with AD account (e.g. ADGROUP1\johndoe) + domain password works as expected.
      • the "Test" connection button returns "success" when using the email (e.g "Bind DN = john.doe@company.com" and "Bind Password = <domain password">)

      This is a regression of version 1.39
      (versions <= 1.38 work)

      Attachments

        Activity

          aeschbacher aeschbacher created issue -
          aeschbacher aeschbacher made changes -
          Field Original Value New Value
          Environment Debian Wheezy (amd64) Jenkins ver 1.580.3 / Debian Wheezy (amd64)
          scm_issue_link SCM/JIRA link daemon made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 160814 ] JNJira + In-Review [ 196575 ]

          People

            Unassigned Unassigned
            aeschbacher aeschbacher
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: