Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27147

Apostrophes are escaped as '

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: email-ext-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.599, Email ext plugin 2.39, Jenkins master running on Windows 7
    • Similar Issues:

      Description

      HTML format emails generated by the email ext plugin can include

      '

      strings.

      '

      is not a valid html escape sequence (see http://stackoverflow.com/questions/2083754/why-shouldnt-apos-be-used-to-escape-single-quotes) so when the email is viewed the escape sequence may not be correctly replaced by an actual apostrophe.

      The stack overflow question linked suggest using the escape sequence

      '

      instead.

        Attachments

          Issue Links

            Activity

            acecil Andrew Cecil created issue -
            slide_o_mix Alex Earl made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-26293 [ JENKINS-26293 ]
            slide_o_mix Alex Earl made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            danielbeck Daniel Beck made changes -
            Description HTML format emails generated by the email ext plugin can include "'" strings. "'" is not a valid html escape sequence (see http://stackoverflow.com/questions/2083754/why-shouldnt-apos-be-used-to-escape-single-quotes) so when the email is viewed the escape sequence may not be correctly replaced by an actual apostrophe.

            The stack overflow question linked suggest using the escape sequence "'" instead.
            HTML format emails generated by the email ext plugin can include {code}'{code} strings. {code}'{code} is not a valid html escape sequence (see http://stackoverflow.com/questions/2083754/why-shouldnt-apos-be-used-to-escape-single-quotes) so when the email is viewed the escape sequence may not be correctly replaced by an actual apostrophe.

            The stack overflow question linked suggest using the escape sequence {code}'{code} instead.
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 161343 ] JNJira + In-Review [ 196724 ]

              People

              Assignee:
              slide_o_mix Alex Earl
              Reporter:
              acecil Andrew Cecil
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: