Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27282

Github Webhook not working after upgrade Jenkins and plugins

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • git-plugin, github-plugin
    • None
    • Latest Jenkins 1.601 but hte issue had appeared in 1.600

    Description

      When github sends a webhook to trigger a build in Jenkins, the Job does not start.
      I've already downgraded Jenkins and github plugin back to original versions but the issue persists.
      I've also wiped the workspace and started an initial build manually, and the issue persists
      Adding the logger: "com.cloudbees.jenkins.GitHubWebHook" I can see this stacktrace:

      Mar 08, 2015 6:29:57 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
      Received POST for https://github.com/MyCompany/MyRepository
      Mar 08, 2015 6:29:57 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
      Poked MyJob
      Mar 08, 2015 6:29:57 PM SEVERE com.cloudbees.jenkins.GitHubPushTrigger$1 runPolling
      Failed to record SCM polling
      java.lang.NullPointerException
      	at org.jenkinsci.plugins.envinject.EnvInjectPluginAction$1.transformEntry(EnvInjectPluginAction.java:25)
      	at org.jenkinsci.plugins.envinject.EnvInjectPluginAction$1.transformEntry(EnvInjectPluginAction.java:23)
      	at com.google.common.collect.Maps$TransformedEntriesMap$1$1.apply(Maps.java:1218)
      	at com.google.common.collect.Maps$TransformedEntriesMap$1$1.apply(Maps.java:1216)
      	at com.google.common.collect.Iterators$8.next(Iterators.java:812)
      	at java.util.AbstractMap.putAll(AbstractMap.java:272)
      	at java.util.TreeMap.putAll(TreeMap.java:321)
      	at org.jenkinsci.plugins.envinject.EnvInjectVarList.<init>(EnvInjectVarList.java:26)
      	at org.jenkinsci.plugins.envinject.EnvInjectPluginAction.getTarget(EnvInjectPluginAction.java:22)
      	at org.jenkinsci.plugins.envinject.EnvInjectPluginAction.buildEnvVars(EnvInjectPluginAction.java:31)
      	at hudson.model.AbstractBuild.getEnvironment(AbstractBuild.java:929)
      	at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:564)
      	at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:526)
      	at hudson.scm.SCM.compareRemoteRevisionWith(SCM.java:380)
      	at hudson.scm.SCM.poll(SCM.java:397)
      	at hudson.model.AbstractProject._poll(AbstractProject.java:1446)
      	at hudson.model.AbstractProject.poll(AbstractProject.java:1349)
      	at com.cloudbees.jenkins.GitHubPushTrigger$1.runPolling(GitHubPushTrigger.java:81)
      	at com.cloudbees.jenkins.GitHubPushTrigger$1.run(GitHubPushTrigger.java:106)
      	at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
      	at java.lang.Thread.run(Thread.java:679)Mar 08, 2015 6:29:57 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
      

      Attachments

        Activity

          I also had the same problem with Git plugin. A workaround for me was downgrading EnvInject plugin to 1.90, everything works now.

          cezarsa Cezar Espinola added a comment - I also had the same problem with Git plugin. A workaround for me was downgrading EnvInject plugin to 1.90, everything works now.
          alexandrezia Alexandre Zia added a comment -

          Thanks for the hint.

          I've upgraded Jenkins to 1.602 and downgraded envinject to 1.90

          Now there is no backtrace, but no build also

          __________________________
          GitHubWebHook log :

          Mar 09, 2015 7:05:21 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          Received POST for https://github.com/MyCompany/MyJob
          Mar 09, 2015 7:05:21 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          Poked MyJob
          Mar 09, 2015 7:05:21 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload

          __________________________
          GitHub Hook Log

          Last GitHub Push

          Started on Mar 9, 2015 7:09:08 PM
          Using strategy: Default
          [poll] Last Built Revision: Revision 6fa1b84438478b04d1fc8b5de9180b0e65ad8acb (refs/remotes/origin/dev)
          > git --version # timeout=10
          > git -c core.askpass=true ls-remote -h git@github.com:MyCompany/MyRepos.git # timeout=10
          Done. Took 0.92 sec
          No changes

          __________________________

          Whenever my Jenkins receives a github webhook it updates Github Hook Log date, so I'm considering thar the webhook from github is firing a poll in my repository to check for new commits in my repository.
          However my repository on github is not on this Revision, it is several commits ahead, but when Jenkins receives the Github webhook it runs thius check and don't actually see the real position in guthub

          Regards
          Alexandre

          alexandrezia Alexandre Zia added a comment - Thanks for the hint. I've upgraded Jenkins to 1.602 and downgraded envinject to 1.90 Now there is no backtrace, but no build also __________________________ GitHubWebHook log : Mar 09, 2015 7:05:21 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload Received POST for https://github.com/MyCompany/MyJob Mar 09, 2015 7:05:21 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload Poked MyJob Mar 09, 2015 7:05:21 PM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload __________________________ GitHub Hook Log Last GitHub Push Started on Mar 9, 2015 7:09:08 PM Using strategy: Default [poll] Last Built Revision: Revision 6fa1b84438478b04d1fc8b5de9180b0e65ad8acb (refs/remotes/origin/dev) > git --version # timeout=10 > git -c core.askpass=true ls-remote -h git@github.com:MyCompany/MyRepos.git # timeout=10 Done. Took 0.92 sec No changes __________________________ Whenever my Jenkins receives a github webhook it updates Github Hook Log date, so I'm considering thar the webhook from github is firing a poll in my repository to check for new commits in my repository. However my repository on github is not on this Revision, it is several commits ahead, but when Jenkins receives the Github webhook it runs thius check and don't actually see the real position in guthub Regards Alexandre
          alexandrezia Alexandre Zia added a comment -

          Update:

          I'm using EnvInject plugin, and set "Prepare an environment for the run", then setting several varibles in "Properties Content" like: GIT_BRANCH=dev
          Then in git configuration, in "Branches to build" I'm using the variable: refs/heads/${GIT_BRANCH}
          That always worked.

          So I've tested several ways, without sucess:

          refs/heads/${GIT_BRANCH}
          refs/heads/$GIT_BRANCH
          */${GIT_BRANCH}
          */$GIT_BRANCH

          I just tried removing the variable and set it hardcoded:

          refs/heads/dev => not worked

          And then, simply:

          dev
          */dev

          then it worked, any of the two combinations above, without varaibles and without specifying

          alexandrezia Alexandre Zia added a comment - Update: I'm using EnvInject plugin, and set "Prepare an environment for the run", then setting several varibles in "Properties Content" like: GIT_BRANCH=dev Then in git configuration, in "Branches to build" I'm using the variable: refs/heads/${GIT_BRANCH} That always worked. So I've tested several ways, without sucess: refs/heads/${GIT_BRANCH} refs/heads/$GIT_BRANCH */${GIT_BRANCH} */$GIT_BRANCH I just tried removing the variable and set it hardcoded: refs/heads/dev => not worked And then, simply: dev */dev then it worked, any of the two combinations above, without varaibles and without specifying
          anantn Anant Narayanan added a comment - - edited

          I have the same problem with Jenkins 1.600 and 1.601, but with a slightly different error in the "Github Hook Log". I do not have the EnvInject plugin installed.

          Using strategy: Default
          [poll] Last Built Revision: Revision 11aa79761c883cceac79c26ff8b6f5f777d80965 (refs/remotes/origin/master)
          > git --version # timeout=10
          > git -c core.askpass=true ls-remote -h git@github.com:anantn/myrepo.git # timeout=10
          ERROR: Failed to record SCM polling
          org.eclipse.jgit.errors.InvalidObjectIdException: Invalid id : Process leaked file descriptors. See htt
          at org.eclipse.jgit.lib.ObjectId.fromHexString(ObjectId.java:245)
          at org.eclipse.jgit.lib.ObjectId.fromString(ObjectId.java:233)
          at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getHeadRev(CliGitAPIImpl.java:2333)
          at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:576)
          at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:526)
          at hudson.scm.SCM.compareRemoteRevisionWith(SCM.java:380)
          at hudson.scm.SCM.poll(SCM.java:397)
          at hudson.model.AbstractProject._poll(AbstractProject.java:1446)
          at hudson.model.AbstractProject.poll(AbstractProject.java:1349)
          at com.cloudbees.jenkins.GitHubPushTrigger$1.runPolling(GitHubPushTrigger.java:81)
          at com.cloudbees.jenkins.GitHubPushTrigger$1.run(GitHubPushTrigger.java:106)
          at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
          at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
          at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
          at java.util.concurrent.FutureTask.run(FutureTask.java:262)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
          at java.lang.Thread.run(Thread.java:745)

          anantn Anant Narayanan added a comment - - edited I have the same problem with Jenkins 1.600 and 1.601, but with a slightly different error in the "Github Hook Log". I do not have the EnvInject plugin installed. Using strategy: Default [poll] Last Built Revision: Revision 11aa79761c883cceac79c26ff8b6f5f777d80965 (refs/remotes/origin/master) > git --version # timeout=10 > git -c core.askpass=true ls-remote -h git@github.com:anantn/myrepo.git # timeout=10 ERROR: Failed to record SCM polling org.eclipse.jgit.errors.InvalidObjectIdException: Invalid id : Process leaked file descriptors. See htt at org.eclipse.jgit.lib.ObjectId.fromHexString(ObjectId.java:245) at org.eclipse.jgit.lib.ObjectId.fromString(ObjectId.java:233) at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getHeadRev(CliGitAPIImpl.java:2333) at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:576) at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:526) at hudson.scm.SCM.compareRemoteRevisionWith(SCM.java:380) at hudson.scm.SCM.poll(SCM.java:397) at hudson.model.AbstractProject._poll(AbstractProject.java:1446) at hudson.model.AbstractProject.poll(AbstractProject.java:1349) at com.cloudbees.jenkins.GitHubPushTrigger$1.runPolling(GitHubPushTrigger.java:81) at com.cloudbees.jenkins.GitHubPushTrigger$1.run(GitHubPushTrigger.java:106) at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118) at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) at java.util.concurrent.FutureTask.run(FutureTask.java:262) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:745)
          alexandrezia Alexandre Zia added a comment -

          @Anant for this error "ERROR: Failed to record SCM polling" you can downgrade EnvInject Plugin to 1.90

          alexandrezia Alexandre Zia added a comment - @Anant for this error "ERROR: Failed to record SCM polling" you can downgrade EnvInject Plugin to 1.90

          @Alexandre Yes, but I do not have the EnvInject plugin installed at all!

          anantn Anant Narayanan added a comment - @Alexandre Yes, but I do not have the EnvInject plugin installed at all!

          @Alexandre that fixed it for me. Thanks!

          fijimunkii Harrison Powers added a comment - @Alexandre that fixed it for me. Thanks!
          llibicpep Dee Kryvenko added a comment - - edited

          Ran into this issue as well after recently upgraded Jenkins (always using stable only).

          Git plugin 2.3.5
          GitHub API plugin 1.68
          GitHub plugin 1.11.3
          Jenkins 1.609.1
          GitHub Enterprise 11.10.348

          In the logs I can see that all required jobs are "poked", but nothing happens after that pokes.
          Repro steps:
          1. Create new freestyle project
          2. Setup SCM as Git to pointing some repo
          3. Change Branch Specifier from */master to refs/heads/master
          4. Add GitHub web-hook
          5. Push commit to the repo

          Note that it works fine with */master as a branch settings.

          llibicpep Dee Kryvenko added a comment - - edited Ran into this issue as well after recently upgraded Jenkins (always using stable only). Git plugin 2.3.5 GitHub API plugin 1.68 GitHub plugin 1.11.3 Jenkins 1.609.1 GitHub Enterprise 11.10.348 In the logs I can see that all required jobs are "poked", but nothing happens after that pokes. Repro steps: 1. Create new freestyle project 2. Setup SCM as Git to pointing some repo 3. Change Branch Specifier from */master to refs/heads/master 4. Add GitHub web-hook 5. Push commit to the repo Note that it works fine with */master as a branch settings.
          llibicpep Dee Kryvenko added a comment - - edited

          UPD: It is also works fine with refs/heads/master if "Force polling using workspace" is enabled. Looks like a Jenkins Core or git-plugin regression.

          llibicpep Dee Kryvenko added a comment - - edited UPD: It is also works fine with refs/heads/master if "Force polling using workspace" is enabled. Looks like a Jenkins Core or git-plugin regression.
          llibicpep Dee Kryvenko added a comment -

          UPD: This issue caused by one of this issues: JENKINS-28506 or JENKINS-27332

          llibicpep Dee Kryvenko added a comment - UPD: This issue caused by one of this issues: JENKINS-28506 or JENKINS-27332
          markewaite Mark Waite added a comment - - edited

          llibicpep if you are willing to test drive the upcoming version of the git plugin, it includes a fix for JENKINS-28506.

          The git plugin and git client plugin are being tested in hopes of releasing new versions before the end of June. If you're willing to assist with the testing, please download and install a pre-release build of the git client plugin and the git plugin. Problems detected in the pre-release should be e-mailed to MarkEWaite and ndeloof.

          I wrote some test ideas if you would like suggestions of areas that need testing. The git plugin supports many different use cases and its automated tests only evaluate a very few of those use cases.

          markewaite Mark Waite added a comment - - edited llibicpep if you are willing to test drive the upcoming version of the git plugin, it includes a fix for JENKINS-28506 . The git plugin and git client plugin are being tested in hopes of releasing new versions before the end of June. If you're willing to assist with the testing, please download and install a pre-release build of the git client plugin and the git plugin . Problems detected in the pre-release should be e-mailed to MarkEWaite and ndeloof . I wrote some test ideas if you would like suggestions of areas that need testing. The git plugin supports many different use cases and its automated tests only evaluate a very few of those use cases.
          liya Liya Katz added a comment -

          Had the same problem in Jenkins 1.609.1 (latest stable) with plugins:
          Git plugin 2.3.5
          GitHub plugin 1.11.3
          Git Client 1.17.1
          GitHub Api 1.68

          Downgrade to the previous stable release (Jenkins 1.596.3) without changing any plugin solved the problem - it looks like core and not a plugin problem

          liya Liya Katz added a comment - Had the same problem in Jenkins 1.609.1 (latest stable) with plugins: Git plugin 2.3.5 GitHub plugin 1.11.3 Git Client 1.17.1 GitHub Api 1.68 Downgrade to the previous stable release (Jenkins 1.596.3) without changing any plugin solved the problem - it looks like core and not a plugin problem
          llibicpep Dee Kryvenko added a comment -

          markewaite, I've checked with latest https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/829/ build, the issue is not reproducible anymore. Looking forward to have new git-plugin available in stable!

          liya, most probably issue was caused by core change, but it's not explicitly tell us this is a core issue. I've looked into a core code first, and buggy method realization is in git-plugin. So that's pure git-plugin issue, that is already fixed and tested, we should just wait for a next git-plugin release.

          llibicpep Dee Kryvenko added a comment - markewaite , I've checked with latest https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/829/ build, the issue is not reproducible anymore. Looking forward to have new git-plugin available in stable! liya , most probably issue was caused by core change, but it's not explicitly tell us this is a core issue. I've looked into a core code first, and buggy method realization is in git-plugin. So that's pure git-plugin issue, that is already fixed and tested, we should just wait for a next git-plugin release.
          liya Liya Katz added a comment -

          Where can I download the version that works?

          liya Liya Katz added a comment - Where can I download the version that works?
          llibicpep Dee Kryvenko added a comment - - edited

          From the Jenkins https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/ws/target/git.hpi
          But this is a CI build, personally I wouldn't recommend you to use it on a production Jenkins instance...

          llibicpep Dee Kryvenko added a comment - - edited From the Jenkins https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/ws/target/git.hpi But this is a CI build, personally I wouldn't recommend you to use it on a production Jenkins instance...
          liya Liya Katz added a comment -

          I meant from specific build you've checked.. The artifacts are not archived there.

          liya Liya Katz added a comment - I meant from specific build you've checked.. The artifacts are not archived there.
          liya Liya Katz added a comment - - edited

          Latest git.hpi from the job workspace (https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/ws/target/git.hpi) doesn't work for me with Jenkins 1.609.1
          I can see in the log:

          Received POST for https://github.com/xxx/vvv
          Jun 21, 2015 10:57:47 AM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          Received POST for https://github.com/xxx/vvv
          Jun 21, 2015 10:57:47 AM WARNING hudson.ExtensionFinder$GuiceFinder$FaultTolerantScope$1 error
          Failed to instantiate optional component com.cloudbees.jenkins.GitHubRepositoryNameContributor$FromMultiSCM; skipping
          Jun 21, 2015 10:57:47 AM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          Poked vvv
          Jun 21, 2015 10:57:47 AM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          Poked vvv

          But nothing happens, the job vvv doesn't run

          liya Liya Katz added a comment - - edited Latest git.hpi from the job workspace ( https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/ws/target/git.hpi ) doesn't work for me with Jenkins 1.609.1 I can see in the log: Received POST for https://github.com/xxx/vvv Jun 21, 2015 10:57:47 AM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload Received POST for https://github.com/xxx/vvv Jun 21, 2015 10:57:47 AM WARNING hudson.ExtensionFinder$GuiceFinder$FaultTolerantScope$1 error Failed to instantiate optional component com.cloudbees.jenkins.GitHubRepositoryNameContributor$FromMultiSCM; skipping Jun 21, 2015 10:57:47 AM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload Poked vvv Jun 21, 2015 10:57:47 AM INFO com.cloudbees.jenkins.GitHubWebHook processGitHubPayload Poked vvv But nothing happens, the job vvv doesn't run

          I'm seeing the same problem.

          with https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/ws/target/git.hpi
          I get absolutely nothing when tailing jenkins.log

          Downgrading to git-plugin 2.24

          Jun 23, 2015 8:43:09 PM hudson.model.UpdateCenter$PluginDowngradeJob run
          INFO: Starting the downgrade of Git Plugin on behalf of kroughton
          Jun 23, 2015 8:43:09 PM hudson.model.UpdateCenter$PluginDowngradeJob run
          INFO: Downgrade successful: Git Plugin

          I see this when creating a new PR.

          Jun 23, 2015 8:44:35 PM com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          INFO: Received POST for https://github.com/xxx/vvv
          Jun 23, 2015 8:44:35 PM com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          INFO: Poked vvv-latest
          Jun 23, 2015 8:44:35 PM com.cloudbees.jenkins.GitHubWebHook processGitHubPayload
          INFO: Poked vvv-master

          And I get a successful build if i create a comment "test this please" on the PR as per https://wiki.jenkins-ci.org/display/JENKINS/GitHub+pull+request+builder+plugin

          Jun 23, 2015 8:58:13 PM org.jenkinsci.plugins.ghprb.GhprbWebHook handleWebHook
          INFO: Got payload event: issue_comment

          git version inside jenkins slave container 2.2.1
          ghprb 1.24.1
          github-plugin 1.11.3
          git-plugin 2.2.4 or 2.3.6-SNAPSHOT-private-41dfda54-jenkins
          git-client-plugin 1.17.1

          I believe we should see
          INFO: Got payload event: pull_request

          kbroughton kesten broughton added a comment - I'm seeing the same problem. with https://jenkins.ci.cloudbees.com/job/plugins/job/git-plugin/ws/target/git.hpi I get absolutely nothing when tailing jenkins.log Downgrading to git-plugin 2.24 Jun 23, 2015 8:43:09 PM hudson.model.UpdateCenter$PluginDowngradeJob run INFO: Starting the downgrade of Git Plugin on behalf of kroughton Jun 23, 2015 8:43:09 PM hudson.model.UpdateCenter$PluginDowngradeJob run INFO: Downgrade successful: Git Plugin I see this when creating a new PR. Jun 23, 2015 8:44:35 PM com.cloudbees.jenkins.GitHubWebHook processGitHubPayload INFO: Received POST for https://github.com/xxx/vvv Jun 23, 2015 8:44:35 PM com.cloudbees.jenkins.GitHubWebHook processGitHubPayload INFO: Poked vvv-latest Jun 23, 2015 8:44:35 PM com.cloudbees.jenkins.GitHubWebHook processGitHubPayload INFO: Poked vvv-master And I get a successful build if i create a comment "test this please" on the PR as per https://wiki.jenkins-ci.org/display/JENKINS/GitHub+pull+request+builder+plugin Jun 23, 2015 8:58:13 PM org.jenkinsci.plugins.ghprb.GhprbWebHook handleWebHook INFO: Got payload event: issue_comment git version inside jenkins slave container 2.2.1 ghprb 1.24.1 github-plugin 1.11.3 git-plugin 2.2.4 or 2.3.6-SNAPSHOT-private-41dfda54-jenkins git-client-plugin 1.17.1 I believe we should see INFO: Got payload event: pull_request
          markewaite Mark Waite added a comment - - edited

          kbroughton I'm very glad that you found a version that works. There are many changes between 2.2.4 and 2.3.5. Would you be willing to try more recent versions, searching for the most recent version which stopped working?

          I'm especially interested in 2.3.4 behaves like 2.2.4 rather than like 2.3.5.

          markewaite Mark Waite added a comment - - edited kbroughton I'm very glad that you found a version that works. There are many changes between 2.2.4 and 2.3.5. Would you be willing to try more recent versions, searching for the most recent version which stopped working? I'm especially interested in 2.3.4 behaves like 2.2.4 rather than like 2.3.5.

          I actually tried 2.3.2 and 2.2.12 and neither worked so i went back to 2.2.4

          kbroughton kesten broughton added a comment - I actually tried 2.3.2 and 2.2.12 and neither worked so i went back to 2.2.4
          tkambler Tim Ambler added a comment -

          Same here. Still broken?

          tkambler Tim Ambler added a comment - Same here. Still broken?
          tkambler Tim Ambler added a comment -

          How does one downgrade this plugin to 2.2.4?

          tkambler Tim Ambler added a comment - How does one downgrade this plugin to 2.2.4?
          tkambler Tim Ambler added a comment -

          Downgraded to 2.2.4 found here - https://updates.jenkins-ci.org/download/plugins/git/ - and still broken.

          tkambler Tim Ambler added a comment - Downgraded to 2.2.4 found here - https://updates.jenkins-ci.org/download/plugins/git/ - and still broken.
          tkambler Tim Ambler added a comment -

          WARNING: Failed to instantiate optional component com.cloudbees.jenkins.GitHubRepositoryNameContributor$FromMultiSCM; skipping

          tkambler Tim Ambler added a comment - WARNING: Failed to instantiate optional component com.cloudbees.jenkins.GitHubRepositoryNameContributor$FromMultiSCM; skipping
          tkambler Tim Ambler added a comment - This looks to be very relevant - http://comments.gmane.org/gmane.comp.java.hudson.user/65493
          markewaite Mark Waite added a comment -

          I don't have a GitHub Webhook available, so I can't test it, but it is hoped that the fix is included in git plugin 2.4.0 released 18 July 2015. If someone with a GitHub Webhook available could test it and mark it "resolved" (if 2.4.0 resolves it), that would be much appreciated.

          markewaite Mark Waite added a comment - I don't have a GitHub Webhook available, so I can't test it, but it is hoped that the fix is included in git plugin 2.4.0 released 18 July 2015. If someone with a GitHub Webhook available could test it and mark it "resolved" (if 2.4.0 resolves it), that would be much appreciated.
          llibicpep Dee Kryvenko added a comment -

          Jenkins 1.609.1
          git plugin 2.4.0

          Confirm that the issue has been resolved.
          Tests done:
          1. Created freestyle project
          2. Added Git SCM configuration with the branch "refs/heads/master" value
          3. Checkbox enabled "Build when a change is pushed to github"
          4. Verified few times that the job is triggered per push to github

          llibicpep Dee Kryvenko added a comment - Jenkins 1.609.1 git plugin 2.4.0 Confirm that the issue has been resolved. Tests done: 1. Created freestyle project 2. Added Git SCM configuration with the branch "refs/heads/master" value 3. Checkbox enabled "Build when a change is pushed to github" 4. Verified few times that the job is triggered per push to github

          People

            Unassigned Unassigned
            alexandrezia Alexandre Zia
            Votes:
            6 Vote for this issue
            Watchers:
            10 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: