Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27662

Double quotes in commit message results in merge failure (Praqma case 12871)

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Merge fails when commit message has "" double quotes.

      Work around:

      Modify commits messages and push again.

        Attachments

          Activity

          bue Bue Petersen created issue -
          bue Bue Petersen added a comment -

          This problem could also indirectly be reported as JENKINS-27309

          bue Bue Petersen made changes -
          Field Original Value New Value
          Summary Double quotes in commit message results in merge failure Double quotes in commit message results in merge failure (Praqma case 12871)
          bue Bue Petersen made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Bue Petersen
          Path:
          src/main/java/org/jenkinsci/plugins/pretestedintegration/scm/git/AccumulatedCommitStrategy.java
          src/main/java/org/jenkinsci/plugins/pretestedintegration/scm/git/SquashCommitStrategy.java
          http://jenkins-ci.org/commit/pretested-integration-plugin/bba993008f51195ebf913d760d405d7b28aa5ad6
          Log:
          JENKINS-27690,JENKINS-27662,JENKINS-27697: checkstyle fixes

          Fixed some checkstyle warnings to pass thressholds.

          bue Bue Petersen made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          bue Bue Petersen added a comment -

          We have written some tests that shows that this should be a problem, and that the git merge may have failed because of some other merge problem.

          That merge problem isn't really reported in a good way, and the error reporting from the plugin hides the real cause of merge problems in some cases. Thus we have created JENKINS-27690 to improve logging.

          This issues will then be resolved, by now including tests that integrate commits with double quotes in one of the commit messages.

          bue Bue Petersen made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          bue Bue Petersen made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          bue Bue Petersen made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Reopened [ 4 ] Resolved [ 5 ]
          bue Bue Petersen made changes -
          Assignee Praqma Support [ praqma ] Bue Petersen [ bue ]
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 161910 ] JNJira + In-Review [ 208586 ]

            People

            Assignee:
            bue Bue Petersen
            Reporter:
            bue Bue Petersen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: