Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27750

SSH Credential's from Jenkins credential-store are not used.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      Linux, Umbuntu, using clean Docker official Jenkins image
    • Similar Issues:

      Description

      Using version 0.0.8

      1) Click "credentials" button, then "Global credentials", then "Add Credentials".
      2) Choose "SSH Username with private key, scope Global (or System), Username (default): jenkins, Private Key: paste a generated Private SSH key which has access to your Git repo.
      3) Click OK
      4) Navigate to Manage Jenkins > Configure System to update SCM Sync configuration settings.
      5) Switch SCM to "git", and set Repository URL.
      6) Click Save.

      Notice:
      SCM Sync status errors.

        Attachments

          Issue Links

            Activity

            haysclark Hays Clark created issue -
            fcamblor Frédéric Camblor made changes -
            Field Original Value New Value
            Link This issue duplicates JENKINS-18129 [ JENKINS-18129 ]
            fcamblor Frédéric Camblor added a comment -

            Dupe of JENKINS-18129

            fcamblor Frédéric Camblor made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]
            danielbeck Daniel Beck added a comment -

            Quoting https://wiki.jenkins-ci.org/display/JENKINS/ScmSyncConfig+Troubleshootings:

            If you use Git then you should use SSH key with default name. It's "id_rsa". SCM Sync does not have option to specify ssh key path. SCM Sync uses .ssh/id_rsa from home directory of the jenkins process owner.

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 162212 ] JNJira + In-Review [ 208600 ]

              People

              Assignee:
              fcamblor Frédéric Camblor
              Reporter:
              haysclark Hays Clark
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: