Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27886

Git can't fetch from origin error

    XMLWordPrintable

Details

    Description

      I've configured Jenkins with Git plugin. When I commit my code test automation project to GitHub, it triggered Jenkins, which built the project automatically. But, the problem is, I am able to run the Jenkins project only on Jenkin's master machine successfully.When I try to run this on Jenkin's slave machine, an error 'ERROR: Error cloning remote repo 'origin' is displayed. Please help me out if I need to change any settings in order to work with Slave machine.

      I am using jenkins-1.606.

      Attachments

        Issue Links

          Activity

            srivallikolli srivalli kolli created issue -

            Should be not a github-plugin issue, right error logging in git-plugin suppressed.

            integer Kanstantsin Shautsou added a comment - Should be not a github-plugin issue, right error logging in git-plugin suppressed.
            integer Kanstantsin Shautsou made changes -
            Field Original Value New Value
            Component/s git-plugin [ 15543 ]
            Component/s github-plugin [ 15896 ]
            Summary Unable to run scripts on Jenkins slave from GitHub Git can't fetch from origin error
            markewaite Mark Waite added a comment -

            I agree with integer that the core bug here is the git plugin suppressing the root cause of the error. I think that makes it a duplicate of JENKINS-27567

            markewaite Mark Waite added a comment - I agree with integer that the core bug here is the git plugin suppressing the root cause of the error. I think that makes it a duplicate of JENKINS-27567
            markewaite Mark Waite made changes -
            Link This issue duplicates JENKINS-27567 [ JENKINS-27567 ]
            markewaite Mark Waite added a comment -

            Fix included in git plugin 2.4.0 released 18 July 2015

            markewaite Mark Waite added a comment - Fix included in git plugin 2.4.0 released 18 July 2015
            markewaite Mark Waite made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 162479 ] JNJira + In-Review [ 208674 ]

            People

              Unassigned Unassigned
              srivallikolli srivalli kolli
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: