Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-280

Slave agent can't execute programm on Win

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Hi set master/slave configuration where slave is Win XP machine. I tested that
      ant is on path, see screenshot. Then I started a new build but the exception is
      thrown:

      FATAL: command execution failed
      java.io.IOException: Cannot run program "ant" (in directory
      "E:\hudson\space\workspace\TestBinary"): CreateProcess error=2, The system
      cannot find the file specified
      at java.lang.ProcessBuilder.start(Unknown Source)
      at java.lang.Runtime.exec(Unknown Source)
      at hudson.Proc$LocalProc.<init>(Proc.java:79)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:130)
      at hudson.model.Slave$RemoteLaunchCallable.call(Slave.java:415)
      at hudson.model.Slave$RemoteLaunchCallable.call(Slave.java:399)
      at hudson.remoting.UserRequest.perform(UserRequest.java:57)
      at hudson.remoting.UserRequest.perform(UserRequest.java:22)
      at hudson.remoting.Request$2.run(Request.java:167)
      at
      edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
      at
      edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: CreateProcess error=2, The system cannot find
      the file specified
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.<init>(Unknown Source)
      at java.lang.ProcessImpl.start(Unknown Source)
      ... 12 more

        Attachments

          Activity

          blaha blaha created issue -
          blaha blaha added a comment -

          Created an attachment (id=36)
          screenshot

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.80.

          kohsuke Kohsuke Kawaguchi made changes -
          Field Original Value New Value
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          abayer Andrew Bayer made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          ircbot Jenkins IRC Bot made changes -
          Component/s core [ 15593 ]
          Component/s www [ 15484 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 130353 ] JNJira + In-Review [ 199736 ]

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            blaha blaha
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: