Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28788

buildWithParameters url loading blank

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
    • Environment:
      Linux
      Jenkins ver. 1.614
      Client Browser Chrome Firefox IE
    • Similar Issues:

      Description

      I recently upgraded my Jenkins to version 1.614 and noticed issue with build with parameter url using post method which is loading blank and we have to reshape the url to view build status, whereas, we were able to see the build job by only triggering the remote build itself.

      Here is what we are doing to trigger the remote build :

      ~<form name=myform id=myform method=post action=http://myjenkins-server:8080/jenkins/job/Repository_Access/buildWithParameters>


      ---- hidden value in form


      <div><input type=submit id=getToken name=getToken value=Initiate></div>~

      Above action is send via email with hidden value and then admin user clicks on "initiate" button to trigger the job. It was working earlier before upgrade but after upgrade we get the URL "http://myjenkins-server:9096/jenkins/job/Repository_Access/buildWithParameters" completely blank. To access the build we have to remove "buildWithParameters" keywrod from the url and then click on build id shown at left hand side.

      I am not sure what exactly changed after the upgrade which has caused the issue. Any idea we have not changed anything in script or server.

        Attachments

          Issue Links

            Activity

            pratapsingh Pratap Singh created issue -
            Hide
            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-22865. This is not a defect, but working as designed.

            Show
            danielbeck Daniel Beck added a comment - Duplicates JENKINS-22865 . This is not a defect, but working as designed.
            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            danielbeck Daniel Beck made changes -
            Link This issue duplicates JENKINS-22865 [ JENKINS-22865 ]
            Hide
            pratapsingh Pratap Singh added a comment -

            I referred to the mentioned bug (https://issues.jenkins-ci.org/browse/JENKINS-22865) but it is still not clear how to get the build url working. We need to see the build status after triggering the build. Help me to understand how to get build status displayed after triggering the remote build.

            Here is my form with hidden value with /build url :

            ~echo "<br>" >> $temp_html ;
            echo "<form name="myform" id="myform" method="post" action=http://myjenkins-server:8080/jenkins/job/Repository_Access/build>" >> $temp_html ;
            echo "<input type="hidden" name="\"Mail_ID\"" value="\"$user_email_id\"" />" >> $temp_html ;
            echo "<input type="hidden" name="\"Access_Type\"" value="\"$Access_Type\"" />" >> $temp_html ;
            echo "<input type="hidden" name="\"Repository_List\"" value="\"$Repository_List\"" />" >> $temp_html ;
            echo "<div><input type="submit" id="getToken" name="getToken" value="Initiate"></div>" >> $temp_html ;
            echo "</form>" >> $temp_html ;
            echo "<br>Only <b>Admin</b> has the rights to click on this Initiate button.<br>" >> $temp_html ;~

            Show
            pratapsingh Pratap Singh added a comment - I referred to the mentioned bug ( https://issues.jenkins-ci.org/browse/JENKINS-22865 ) but it is still not clear how to get the build url working. We need to see the build status after triggering the build. Help me to understand how to get build status displayed after triggering the remote build. Here is my form with hidden value with /build url : ~echo "<br>" >> $temp_html ; echo "<form name="myform" id="myform" method="post" action= http://myjenkins-server:8080/jenkins/job/Repository_Access/build >" >> $temp_html ; echo "<input type="hidden" name="\"Mail_ID\"" value="\"$user_email_id\"" />" >> $temp_html ; echo "<input type="hidden" name="\"Access_Type\"" value="\"$Access_Type\"" />" >> $temp_html ; echo "<input type="hidden" name="\"Repository_List\"" value="\"$Repository_List\"" />" >> $temp_html ; echo "<div><input type="submit" id="getToken" name="getToken" value="Initiate"></div>" >> $temp_html ; echo "</form>" >> $temp_html ; echo "<br>Only <b>Admin</b> has the rights to click on this Initiate button.<br>" >> $temp_html ;~
            Hide
            danielbeck Daniel Beck added a comment -

            I suggest you just do whatever the regular "build with parameters" form does, i.e. same form action and everything.

            For further assistance and questions on how to use Jenkins, please email the jenkinsci-users mailing list, or ask in #jenkins on Freenode.

            Show
            danielbeck Daniel Beck added a comment - I suggest you just do whatever the regular "build with parameters" form does, i.e. same form action and everything. For further assistance and questions on how to use Jenkins, please email the jenkinsci-users mailing list, or ask in #jenkins on Freenode.
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 163646 ] JNJira + In-Review [ 197264 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              pratapsingh Pratap Singh
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: