Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28955

Jenkins unusable after downgrade from latest weekly release to LTS



    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
    • Environment:
      Host: Ubuntu 14.04 server VM
      Jenkins 1.617 --> Jenkins 1.609.1
    • Similar Issues:


      After doing a dpkg -i of jenkins_1.609.1_all.deb on top of my current weekly release of jenkins_1.617_all.deb, Jenkins is no longer usable (see main screen screenshot).

      I tried going back to 617, but I get the same result. This is my Jenkins sandbox. I'm not sure what to do to recover from this. I was going to test the latest LTS so we could move our production Jenkins instance to it, but my sandbox is unusable now, so we're stuck unless I copy over a new Jenkins backup and set it back up as a sandbox. I'm not sure that solves my problem though. I've switched around between Jenkins releases before and never had this happen.


      hudson.util.HudsonFailedToLoad: org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.WebAppMain$3.run(WebAppMain.java:237)
      Caused by: org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:44)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:915)
      at jenkins.model.Jenkins.<init>(Jenkins.java:814)
      at hudson.model.Hudson.<init>(Hudson.java:83)
      at hudson.model.Hudson.<init>(Hudson.java:79)
      at hudson.WebAppMain$3.run(WebAppMain.java:225)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)
      at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:176)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:904)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:606)
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:106)
      ... 8 more
      Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
      at java.util.ArrayList.rangeCheck(ArrayList.java:635)
      at java.util.ArrayList.get(ArrayList.java:411)
      at hudson.ExtensionList.get(ExtensionList.java:158)
      at hudson.PluginManager$PluginUpdateMonitor.getInstance(PluginManager.java:1257)
      at hudson.maven.PluginImpl.init(PluginImpl.java:58)
      ... 13 more


          Issue Links


            kerrhome Shannon Kerr created issue -
            kerrhome Shannon Kerr made changes -
            Field Original Value New Value
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]
            kerrhome Shannon Kerr made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            integer Kanstantsin Shautsou made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Closed [ 6 ] Reopened [ 4 ]
            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-21486 [ JENKINS-21486 ]
            jglick Jesse Glick made changes -
            Resolution Duplicate [ 3 ]
            Status Reopened [ 4 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 163819 ] JNJira + In-Review [ 197326 ]


              Unassigned Unassigned
              kerrhome Shannon Kerr
              2 Vote for this issue
              6 Start watching this issue