Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29193

Same sha used for multiple git checkouts

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I have a job configured with 2 git checkouts. Sometimes it will use the sha from the first checkout on the second git checkout, failing the job since the sha does not exist there.
      I have not been able to replicate this consistently. But I have about 15 jobs using this plugin, which run a few times an hour. I notice the issue at least once every couple hours.
      The issue will randomly fix it self after a few tries.

        Attachments

          Issue Links

            Activity

            ninjonxb jon heckman created issue -
            markewaite Mark Waite added a comment - - edited

            Can you provide sufficient detail so that the problem is repeatable for others?

            Is the problem visible with the latest release of the git plugin, version 2.3.5 (released March 2015)?

            Is the problem visible with the latest release of the multiple SCM plugin, 1.4, (released March 2015)?

            markewaite Mark Waite added a comment -

            After two weeks without a response to the request for more information, I'm closing this bug as "Cannot reproduce". There is a small chance that the improvements in git plugin 2.4.0 and git client plugin 1.18.0, but without a set of steps to duplicate the problem, we can't be sure.

            markewaite Mark Waite made changes -
            Field Original Value New Value
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 164061 ] JNJira + In-Review [ 208941 ]
            leedega Kevin Phillips made changes -
            Link This issue is related to JENKINS-54732 [ JENKINS-54732 ]

              People

              Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              ninjonxb jon heckman
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: