Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29573

IndexOutOfBoundsException error when jql returns no issue

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I'm getting an error when Jira issue updater can't find any issue to update.
      I've looked the code and the problem is here "issues.get(0)" at line 228, maybe just change the if clause at line 227 is going to work (if ( ! fixedVersionNames.isEmpty() && !issues.isEmpty() ))

      This is the stack I got:
      Your JQL, 'IssueKey IN (PRD-0000)' did not return any issues. No issues will be updated during this build.
      ERROR: Build step failed with exception
      java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
      at java.util.ArrayList.rangeCheck(Unknown Source)
      at java.util.ArrayList.get(Unknown Source)
      at info.bluefloyd.jenkins.IssueUpdatesBuilder.perform(IssueUpdatesBuilder.java:228)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
      at hudson.model.Build$BuildExecution.build(Build.java:205)
      at hudson.model.Build$BuildExecution.doRun(Build.java:162)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:537)
      at hudson.model.Run.execute(Run.java:1741)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:381)

      Thank you!

        Attachments

          Activity

          idenardi Ivan Denardi created issue -
          idenardi Ivan Denardi made changes -
          Field Original Value New Value
          Description I'm getting an error when Jira issue updater can't find any issue to update.

          this is the stack:Your JQL, 'IssueKey IN (PRD-0000)' did not return any issues. No issues will be updated during this build.
          ERROR: Build step failed with exception
          java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
          at java.util.ArrayList.rangeCheck(Unknown Source)
          at java.util.ArrayList.get(Unknown Source)
          at info.bluefloyd.jenkins.IssueUpdatesBuilder.perform(IssueUpdatesBuilder.java:228)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
          at hudson.model.Build$BuildExecution.build(Build.java:205)
          at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:537)
          at hudson.model.Run.execute(Run.java:1741)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:381)
          I'm getting an error when Jira issue updater can't find any issue to update.

          This is the stack:
          Your JQL, 'IssueKey IN (PRD-0000)' did not return any issues. No issues will be updated during this build.
          ERROR: Build step failed with exception
          java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
          at java.util.ArrayList.rangeCheck(Unknown Source)
          at java.util.ArrayList.get(Unknown Source)
          at info.bluefloyd.jenkins.IssueUpdatesBuilder.perform(IssueUpdatesBuilder.java:228)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
          at hudson.model.Build$BuildExecution.build(Build.java:205)
          at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:537)
          at hudson.model.Run.execute(Run.java:1741)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:381)
          Labels jira_plugin plugin
          idenardi Ivan Denardi made changes -
          Description I'm getting an error when Jira issue updater can't find any issue to update.

          This is the stack:
          Your JQL, 'IssueKey IN (PRD-0000)' did not return any issues. No issues will be updated during this build.
          ERROR: Build step failed with exception
          java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
          at java.util.ArrayList.rangeCheck(Unknown Source)
          at java.util.ArrayList.get(Unknown Source)
          at info.bluefloyd.jenkins.IssueUpdatesBuilder.perform(IssueUpdatesBuilder.java:228)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
          at hudson.model.Build$BuildExecution.build(Build.java:205)
          at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:537)
          at hudson.model.Run.execute(Run.java:1741)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:381)
          I'm getting an error when Jira issue updater can't find any issue to update.
          I've looked the code and the problem is here "issues.get(0)" at line 228, maybe just change the if clause at line 227 is going to work (if ( ! fixedVersionNames.isEmpty() && !issues.isEmpty() ))

          This is the stack I got:
          Your JQL, 'IssueKey IN (PRD-0000)' did not return any issues. No issues will be updated during this build.
          ERROR: Build step failed with exception
          java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
          at java.util.ArrayList.rangeCheck(Unknown Source)
          at java.util.ArrayList.get(Unknown Source)
          at info.bluefloyd.jenkins.IssueUpdatesBuilder.perform(IssueUpdatesBuilder.java:228)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
          at hudson.model.Build$BuildExecution.build(Build.java:205)
          at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:537)
          at hudson.model.Run.execute(Run.java:1741)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:98)
          at hudson.model.Executor.run(Executor.java:381)


          Thank you!
          jbaiza Jānis Baiža made changes -
          Assignee Jānis Baiža [ jbaiza ]
          jbaiza Jānis Baiža made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          jbaiza Jānis Baiža made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          jbaiza Jānis Baiža added a comment -
          jbaiza Jānis Baiža made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Resolved [ 5 ]
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Janis Baiza
          Path:
          src/main/java/info/bluefloyd/jenkins/IssueUpdatesBuilder.java
          http://jenkins-ci.org/commit/jira-issue-updater-plugin/4c678827d5512f36a081fad61c2b8984e300d311
          Log:
          Solved https://issues.jenkins-ci.org/browse/JENKINS-29573

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Laszlo Miklosik
          Path:
          src/main/java/info/bluefloyd/jenkins/IssueUpdatesBuilder.java
          http://jenkins-ci.org/commit/jira-issue-updater-plugin/bc22b5ef0c26bf467ce77cc1869c6190295ab32e
          Log:
          Merge pull request #8 from jbaiza/JENKINS-29573

          Solved https://issues.jenkins-ci.org/browse/JENKINS-29573

          Compare: https://github.com/jenkinsci/jira-issue-updater-plugin/compare/dffaec0178f9...bc22b5ef0c26

          laszlomiklosik Laszlo Miklosik added a comment -

          Thanks! Merged and released right now. The new version (1.13) should appear in the Jenkins release center in a few hours.

          laszlomiklosik Laszlo Miklosik made changes -
          Assignee Jānis Baiža [ jbaiza ] Ivan Denardi [ idenardi ]
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 164453 ] JNJira + In-Review [ 209039 ]

            People

            Assignee:
            idenardi Ivan Denardi
            Reporter:
            idenardi Ivan Denardi
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: