Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30529

Import failed when trying to import from another centos version jenkins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: job-import-plugin
    • Labels:
      None
    • Environment:
      Centos 7 on local jenkins, Centos 6 on remote
      Java 1.8 (open jdk)
    • Similar Issues:

      Description

      When i try to import jenkins job from one instance (centos6.6) to another (centos7) (using plugin) i get error:

      FAILED - Unable to read /var/lib/jenkins/jobs/HEAD/config.xml
      

      However, i thought the reason was on the remote jenkins instance, so i tried to import job on 3rd instance (centos6.6 too) and it succeeded.
      I think the reason is in OS version difference.
      Also i tried to copy job folders manually, then reload config, but still no succeeded, jobs are unseen.

        Attachments

          Activity

          zpf7879 John Zhang added a comment -

          To me, the problem is because of Maven. I tried to import a list of project. All the projects that have nothing to do with Maven were imported successfully. However, all the Maven projects failed.
          I tried to manually copy a Maven project from the jobs directory in the old Jenkins server to the new server, and manage to build it. During this process, I did a lot of Maven configuration, e.g. install maven-related Jenkins plugins, set the Maven in the global tools, etc. After all of these work, I can import the maven jobs now. Fantastic!

          thomas_storm Thomas Storm added a comment -

          It was missing folder plugin, which was causing errors in job copy, sorry, false alarm

          thomas_storm Thomas Storm added a comment -

          guys, any news?


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            thomas_st0rm Thomas Storm
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: