Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-30554

Complete ability to manually deploy artifacts TO a repository

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I see that there is ArtifactDeployer at https://github.com/jenkinsci/repository-connector-plugin/blob/master/src/main/java/org/jvnet/hudson/plugins/repositoryconnector/ArtifactDeployer.java
      But for life of me can't figure out how to actually, manually upload an artifact to a Nexus repo ... I would hope/suspect there would be a Builder or Publisher that could do it.

        Attachments

          Activity

          brantone Brantone created issue -
          brantone Brantone made changes -
          Field Original Value New Value
          Summary Completely ability to manually deploy artifacts TO a repository Complete ability to manually deploy artifacts TO a repository
          brantone Brantone added a comment -

          Yup ... but there was also a bug where the list of repos wouldn't display until the config is saved, then you go back into it and the list magically appears.
          I have a code fix inbound shortly to address that ... took a bit of time to sort out, situation where JENKINS-30560 would have come in handy to avoid jumping back 'n forth between global and job configs.

          brantone Brantone added a comment -

          It's also unclear why it would be disabled??

          brantone Brantone made changes -
          Comment [ PR: https://github.com/jenkinsci/repository-connector-plugin/pull/14

          Auto-merge not applicable probably due to white-space clean up (bad mix of spaces/tabs).

          [Edit] Yup, didn't like white-space change :( ]
          brantone Brantone added a comment -
          brantone Brantone made changes -
          Assignee Brantone [ brantone ]
          brantone Brantone made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          brantone Brantone added a comment -

          Resolving in hopes of drawing attention to the PR

          brantone Brantone made changes -
          Resolution Done [ 10000 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 165666 ] JNJira + In-Review [ 197781 ]

            People

            Assignee:
            brantone Brantone
            Reporter:
            brantone Brantone
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: