Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3085

$CHANGES token returns too little info

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • email-ext-plugin
    • None
    • Platform: All, OS: All

    Description

      When I tried to use the $CHANGES token in Email-ext message body, it only
      returned the name(s) of the SVN users, who have checked in files, not any other
      details, such as: time of change, check-in comments, and, above all files. I
      think it is a bug.

      Also, is it possible to have different body messages for different build
      statuses? E.g., return the $BUILD_LOG for failed builds, but not for successful
      builds?

      Attachments

        Issue Links

          Activity

            mdonohue mdonohue added a comment -
                • Issue 3779 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment - Issue 3779 has been marked as a duplicate of this issue. ***
            mdonohue mdonohue added a comment -

            issue 3779 also requests the file content diffs, though this isn't even
            available in Hudson's web UI at the moment.

            mdonohue mdonohue added a comment - issue 3779 also requests the file content diffs, though this isn't even available in Hudson's web UI at the moment.
            mindless Alan Harder added a comment -

            Much of what you ask for is available now in email-ext 2.3 (released today) with the showPaths and format parameters for $CHANGES.
            Regarding body of messages.. you can already set a different body for different status when configuring a project (click "Advanced" and then "expand"). Different defaults in the global settings has been requested in JENKINS-3670.

            So, closing this issue.. if the $CHANGES params in 2.3 aren't sufficient, please file a new request detailing what else you'd like to see, thanks.

            mindless Alan Harder added a comment - Much of what you ask for is available now in email-ext 2.3 (released today) with the showPaths and format parameters for $CHANGES. Regarding body of messages.. you can already set a different body for different status when configuring a project (click "Advanced" and then "expand"). Different defaults in the global settings has been requested in JENKINS-3670 . So, closing this issue.. if the $CHANGES params in 2.3 aren't sufficient, please file a new request detailing what else you'd like to see, thanks.

            People

              againjj againjj
              sogy sogy
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: