Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31202

Trend Graphs are not shown in Job view for Workflow builds

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Fixed
    • analysis-core-plugin
    • None
    • Jenkins Version: 1.609.1
      analysis-core version: 1.74

    Description

      The Job-level trend graphs for the static analyses I run (checkstyle, warnings, and tasks) are not showing up. The reports are being generated and published correctly at the run level, but I don't have any trending. Is there a configuration option I may have missed?

      Attachments

        Issue Links

          Activity

            greg_symons Gregory Symons created issue -
            drulli Ulli Hafner added a comment -

            I don't know how this is done for workflows. Maybe this part has not been implemented yet.

            drulli Ulli Hafner added a comment - I don't know how this is done for workflows. Maybe this part has not been implemented yet.
            cruftex Jens Wilke added a comment -

            +1

            To reproduce I used the minimal workflow:

            node {
              step([$class: 'AnalysisPublisher'])
            }
            
            cruftex Jens Wilke added a comment - +1 To reproduce I used the minimal workflow: node { step([$class: 'AnalysisPublisher' ]) }
            cruftex Jens Wilke added a comment -

            For the JUnit Publisher a trend report shows up. E.g.:

            step([$class: 'JUnitResultArchiver', testResults: '**/target/surefire-reports/*.xml'])
            
            cruftex Jens Wilke added a comment - For the JUnit Publisher a trend report shows up. E.g.: step([$class: 'JUnitResultArchiver' , testResults: '**/target/surefire-reports/*.xml' ])

            drulli I can take care of this. Reassigning.

            amuniz Antonio Muñiz added a comment - drulli I can take care of this. Reassigning.
            amuniz Antonio Muñiz made changes -
            Field Original Value New Value
            Assignee Ulli Hafner [ drulli ] Antonio Muñiz [ amuniz ]

            Might this be connected with JENKINS-31926 ?

            nickolayr Nickolay Rumyantsev added a comment - Might this be connected with JENKINS-31926 ?

            Might this be connected with JENKINS-31926 ?

            No, it's unrelated.

            amuniz Antonio Muñiz added a comment - Might this be connected with JENKINS-31926 ? No, it's unrelated.
            drulli Ulli Hafner made changes -
            Link This issue is duplicated by JENKINS-33472 [ JENKINS-33472 ]

            I just noticed the same problem with the (master branch of) Android Lint plugin, which is also based upon analysis-core.

            orrc Christopher Orr added a comment - I just noticed the same problem with the (master branch of) Android Lint plugin, which is also based upon analysis-core.
            orrc Christopher Orr made changes -
            Link This issue is duplicated by JENKINS-34621 [ JENKINS-34621 ]
            tknerr Torben Knerr added a comment -

            amuniz same here with latest jenkins 2.3 and multibranch pipeline workflows. Would have expected that this is a basic feature with new jenkins 2.3 – or is this a known issue?

            tknerr Torben Knerr added a comment - amuniz same here with latest jenkins 2.3 and multibranch pipeline workflows. Would have expected that this is a basic feature with new jenkins 2.3 – or is this a known issue?

            tknerr the issue is not in Jenkins core nor Pipeline, it's something to fix in analysis-core. A known issue.

            amuniz Antonio Muñiz added a comment - tknerr the issue is not in Jenkins core nor Pipeline, it's something to fix in analysis-core. A known issue.
            drulli Ulli Hafner made changes -
            Labels analysis-core-2.0

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            src/main/java/hudson/plugins/analysis/core/AbstractResultAction.java
            http://jenkins-ci.org/commit/analysis-core-plugin/b0f1a2c18dcff86c3d2e1e836b8616f352f1eb74
            Log:
            JENKINS-31202 Provide empty list of project actions for pipelines.

            Compare: https://github.com/jenkinsci/analysis-core-plugin/compare/599fa66cb013...b0f1a2c18dcf

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: src/main/java/hudson/plugins/analysis/core/AbstractResultAction.java http://jenkins-ci.org/commit/analysis-core-plugin/b0f1a2c18dcff86c3d2e1e836b8616f352f1eb74 Log: JENKINS-31202 Provide empty list of project actions for pipelines. Compare: https://github.com/jenkinsci/analysis-core-plugin/compare/599fa66cb013...b0f1a2c18dcf
            drulli Ulli Hafner made changes -
            Link This issue is duplicated by JENKINS-35295 [ JENKINS-35295 ]

            Just tried to build and install master branch of analysis-core-plugin, and it seems that it still does not display trend graphs and other things on the main job page (currently I'm using chuck-norris plugin, pmd, findbugs, checkstyle, jacoco, warnings, tasks)

            szhem Sergey Zhemzhitsky added a comment - Just tried to build and install master branch of analysis-core-plugin, and it seems that it still does not display trend graphs and other things on the main job page (currently I'm using chuck-norris plugin, pmd, findbugs, checkstyle, jacoco, warnings, tasks)
            drulli Ulli Hafner added a comment - - edited

            Yes of course. There is no fix available yet. The commit above adds only the interface so far.

            The refactoring effort is quite large since all occurrences of AbstractProject need to be replaced with Job. Therefore I labeled it with the 2.0 flag.

            drulli Ulli Hafner added a comment - - edited Yes of course. There is no fix available yet. The commit above adds only the interface so far. The refactoring effort is quite large since all occurrences of AbstractProject need to be replaced with Job . Therefore I labeled it with the 2.0 flag.
            drulli Ulli Hafner made changes -
            Assignee Antonio Muñiz [ amuniz ] Ulli Hafner [ drulli ]
            centic centic made changes -
            Link This issue is blocking JENKINS-27120 [ JENKINS-27120 ]
            mheinzerling Martin Heinzerling added a comment - - edited

            drulli, anything we can do here, to support you? I would like to complete the JaCoCo pipeline ASAP.

            mheinzerling Martin Heinzerling added a comment - - edited drulli , anything we can do here, to support you? I would like to complete the JaCoCo pipeline ASAP.
            drulli Ulli Hafner added a comment -

            How is this related to the JaCoCo plugin?

            drulli Ulli Hafner added a comment - How is this related to the JaCoCo plugin?

            Sorry my bad, just saw the blocker, but Jacoco is actually not using analysis-core.

            mheinzerling Martin Heinzerling added a comment - Sorry my bad, just saw the blocker, but Jacoco is actually not using analysis-core.
            mheinzerling Martin Heinzerling made changes -
            Link This issue is blocking JENKINS-27120 [ JENKINS-27120 ]
            mheinzerling Martin Heinzerling made changes -
            Link This issue is related to JENKINS-36536 [ JENKINS-36536 ]
            vollmilch Benjamin Fuchs made changes -
            Attachment trendgraph.png [ 33331 ]
            vollmilch Benjamin Fuchs added a comment - - edited

            Hi, I'm very interested in resolving this issue.
            I tried to get as far as I can and I got a trend graph showing up in my workflow:

            I pushed my changes here: https://github.com/benjaminfuchs/analysis-core-plugin/tree/JENKINS-31202
            ...and also had to change the warnings-plugin: https://github.com/benjaminfuchs/warnings-plugin/tree/JENKINS-31202

            I got my changes running with: $ mvn hpi:run

            I would appreciate some feedback and as I really would like to help resolving this issue!
            Greetings!

            vollmilch Benjamin Fuchs added a comment - - edited Hi, I'm very interested in resolving this issue. I tried to get as far as I can and I got a trend graph showing up in my workflow: I pushed my changes here: https://github.com/benjaminfuchs/analysis-core-plugin/tree/JENKINS-31202 ...and also had to change the warnings-plugin: https://github.com/benjaminfuchs/warnings-plugin/tree/JENKINS-31202 I got my changes running with: $ mvn hpi:run I would appreciate some feedback and as I really would like to help resolving this issue! Greetings!
            vollmilch Benjamin Fuchs added a comment - - edited I created a PR: https://github.com/jenkinsci/analysis-core-plugin/pull/36
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 166388 ] JNJira + In-Review [ 182381 ]

            Any updates?

            vollmilch Benjamin Fuchs added a comment - Any updates?
            allan_burdajewicz Allan BURDAJEWICZ added a comment - - edited

            As several plugins depend on it, shoudln't we increase the priority of this issue?

            allan_burdajewicz Allan BURDAJEWICZ added a comment - - edited As several plugins depend on it, shoudln't we increase the priority of this issue?
            drulli Ulli Hafner added a comment -

            Allan, please see https://github.com/jenkinsci/analysis-core-plugin/pull/36. Changing the priority will not help...

            drulli Ulli Hafner added a comment - Allan, please see https://github.com/jenkinsci/analysis-core-plugin/pull/36 . Changing the priority will not help...

            Hi, some updates:
            The changes I committed work fine on my instance.
            I created a PR for the changes on the warnings-plugin depending on this issue: https://github.com/jenkinsci/warnings-plugin/pull/80

            vollmilch Benjamin Fuchs added a comment - Hi, some updates: The changes I committed work fine on my instance. I created a PR for the changes on the warnings-plugin depending on this issue: https://github.com/jenkinsci/warnings-plugin/pull/80

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            pom.xml
            http://jenkins-ci.org/commit/analysis-pom-plugin/e95e14519a7a03bc9a24f5bb34a84e7daa8b1e80
            Log:
            Merge pull request #4 from benjaminfuchs/JENKINS-31202

            Update Jenkins version for multibranch support.

            Compare: https://github.com/jenkinsci/analysis-pom-plugin/compare/fe4fcf2edc92...e95e14519a7a

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: pom.xml http://jenkins-ci.org/commit/analysis-pom-plugin/e95e14519a7a03bc9a24f5bb34a84e7daa8b1e80 Log: Merge pull request #4 from benjaminfuchs/ JENKINS-31202 Update Jenkins version for multibranch support. Compare: https://github.com/jenkinsci/analysis-pom-plugin/compare/fe4fcf2edc92...e95e14519a7a

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java
            src/main/java/hudson/plugins/analysis/graph/DefaultGraphConfigurationView.java
            src/main/java/hudson/plugins/analysis/graph/GraphConfigurationView.java
            src/main/java/hudson/plugins/analysis/graph/TrendDetails.java
            src/main/java/hudson/plugins/analysis/graph/UserGraphConfigurationView.java
            http://jenkins-ci.org/commit/analysis-core-plugin/05d7c5d76514b7d5ddc8270ba12cb4c2fb009130
            Log:
            JENKINS-31202 Replacing occurences of AbstractProject with Job and AbstractBuild with Run.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java src/main/java/hudson/plugins/analysis/graph/DefaultGraphConfigurationView.java src/main/java/hudson/plugins/analysis/graph/GraphConfigurationView.java src/main/java/hudson/plugins/analysis/graph/TrendDetails.java src/main/java/hudson/plugins/analysis/graph/UserGraphConfigurationView.java http://jenkins-ci.org/commit/analysis-core-plugin/05d7c5d76514b7d5ddc8270ba12cb4c2fb009130 Log: JENKINS-31202 Replacing occurences of AbstractProject with Job and AbstractBuild with Run.

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java
            src/main/java/hudson/plugins/analysis/graph/DefaultGraphConfigurationView.java
            src/main/java/hudson/plugins/analysis/graph/GraphConfigurationView.java
            src/main/java/hudson/plugins/analysis/graph/TrendDetails.java
            src/main/java/hudson/plugins/analysis/graph/UserGraphConfigurationView.java
            http://jenkins-ci.org/commit/analysis-core-plugin/e577749e8669fe428bb04f55d96546227d7a2374
            Log:
            JENKINS-31202 To preserve backward compatibility we need to keep all API methods unchanged.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java src/main/java/hudson/plugins/analysis/graph/DefaultGraphConfigurationView.java src/main/java/hudson/plugins/analysis/graph/GraphConfigurationView.java src/main/java/hudson/plugins/analysis/graph/TrendDetails.java src/main/java/hudson/plugins/analysis/graph/UserGraphConfigurationView.java http://jenkins-ci.org/commit/analysis-core-plugin/e577749e8669fe428bb04f55d96546227d7a2374 Log: JENKINS-31202 To preserve backward compatibility we need to keep all API methods unchanged.

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java
            src/main/java/hudson/plugins/analysis/graph/TrendDetails.java
            src/main/resources/hudson/plugins/analysis/graph/TrendDetails/index.jelly
            http://jenkins-ci.org/commit/analysis-core-plugin/b76b62e9a704a8043925d82ce3ba26baf4b7b096
            Log:
            JENKINS-31202 Fixing "enlarge" trend graph bug.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java src/main/java/hudson/plugins/analysis/graph/TrendDetails.java src/main/resources/hudson/plugins/analysis/graph/TrendDetails/index.jelly http://jenkins-ci.org/commit/analysis-core-plugin/b76b62e9a704a8043925d82ce3ba26baf4b7b096 Log: JENKINS-31202 Fixing "enlarge" trend graph bug.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java
            src/main/java/hudson/plugins/analysis/graph/DefaultGraphConfigurationView.java
            src/main/java/hudson/plugins/analysis/graph/GraphConfigurationView.java
            src/main/java/hudson/plugins/analysis/graph/TrendDetails.java
            src/main/java/hudson/plugins/analysis/graph/UserGraphConfigurationView.java
            src/main/resources/hudson/plugins/analysis/graph/TrendDetails/index.jelly
            http://jenkins-ci.org/commit/analysis-core-plugin/573e1671964dea65b012b24a0a146928a1f172ba
            Log:
            Merge branch 'JENKINS-31202' of https://github.com/benjaminfuchs/analysis-core-plugin into benjaminfuchs-JENKINS-31202

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: src/main/java/hudson/plugins/analysis/core/AbstractProjectAction.java src/main/java/hudson/plugins/analysis/graph/DefaultGraphConfigurationView.java src/main/java/hudson/plugins/analysis/graph/GraphConfigurationView.java src/main/java/hudson/plugins/analysis/graph/TrendDetails.java src/main/java/hudson/plugins/analysis/graph/UserGraphConfigurationView.java src/main/resources/hudson/plugins/analysis/graph/TrendDetails/index.jelly http://jenkins-ci.org/commit/analysis-core-plugin/573e1671964dea65b012b24a0a146928a1f172ba Log: Merge branch ' JENKINS-31202 ' of https://github.com/benjaminfuchs/analysis-core-plugin into benjaminfuchs- JENKINS-31202

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            src/main/java/hudson/plugins/warnings/WarningsProjectAction.java
            src/main/java/hudson/plugins/warnings/WarningsPublisher.java
            src/main/java/hudson/plugins/warnings/WarningsResultAction.java
            http://jenkins-ci.org/commit/warnings-plugin/34d169cda9efee4f191cb0d9435200564cf85b4a
            Log:
            JENKINS-31202 Replacing occurences of AbstractProject with Job and AbstractBuild.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: src/main/java/hudson/plugins/warnings/WarningsProjectAction.java src/main/java/hudson/plugins/warnings/WarningsPublisher.java src/main/java/hudson/plugins/warnings/WarningsResultAction.java http://jenkins-ci.org/commit/warnings-plugin/34d169cda9efee4f191cb0d9435200564cf85b4a Log: JENKINS-31202 Replacing occurences of AbstractProject with Job and AbstractBuild.

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            src/main/java/hudson/plugins/warnings/WarningsPublisher.java
            src/test/java/hudson/plugins/warnings/WarningsPublisherTest.java
            http://jenkins-ci.org/commit/warnings-plugin/3b8dd54f362bcca629cea1e8d70ec244445f2f39
            Log:
            JENKINS-31202 Fixing duplicate graph in nonpipeline job, conflicting JENKINS-14615?

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: src/main/java/hudson/plugins/warnings/WarningsPublisher.java src/test/java/hudson/plugins/warnings/WarningsPublisherTest.java http://jenkins-ci.org/commit/warnings-plugin/3b8dd54f362bcca629cea1e8d70ec244445f2f39 Log: JENKINS-31202 Fixing duplicate graph in nonpipeline job, conflicting JENKINS-14615 ?

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            src/main/java/hudson/plugins/warnings/WarningsProjectAction.java
            http://jenkins-ci.org/commit/warnings-plugin/79a299a5ee71479a4b2f21707635064813734085
            Log:
            JENKINS-31202 Using new workflow compatible functions.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: src/main/java/hudson/plugins/warnings/WarningsProjectAction.java http://jenkins-ci.org/commit/warnings-plugin/79a299a5ee71479a4b2f21707635064813734085 Log: JENKINS-31202 Using new workflow compatible functions.

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            pom.xml
            src/test/java/hudson/plugins/warnings/WarningsWorkflowMultiBranchTest.java
            http://jenkins-ci.org/commit/warnings-plugin/43217305eb754f27700afb2db41d556a84a61001
            Log:
            JENKINS-31202 Updating pom for new test.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: pom.xml src/test/java/hudson/plugins/warnings/WarningsWorkflowMultiBranchTest.java http://jenkins-ci.org/commit/warnings-plugin/43217305eb754f27700afb2db41d556a84a61001 Log: JENKINS-31202 Updating pom for new test.

            Code changed in jenkins
            User: Benjamin Fuchs
            Path:
            src/test/java/hudson/plugins/warnings/WarningsMultiBranchTest.java
            src/test/java/hudson/plugins/warnings/WarningsPublisherTest.java
            http://jenkins-ci.org/commit/warnings-plugin/4b0d422b7709f14745a5bfad90bc43eb686e69fe
            Log:
            JENKINS-31202 Updated tests for multibranch.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Benjamin Fuchs Path: src/test/java/hudson/plugins/warnings/WarningsMultiBranchTest.java src/test/java/hudson/plugins/warnings/WarningsPublisherTest.java http://jenkins-ci.org/commit/warnings-plugin/4b0d422b7709f14745a5bfad90bc43eb686e69fe Log: JENKINS-31202 Updated tests for multibranch.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            pom.xml
            src/main/java/hudson/plugins/warnings/WarningsProjectAction.java
            src/main/java/hudson/plugins/warnings/WarningsPublisher.java
            src/main/java/hudson/plugins/warnings/WarningsResultAction.java
            src/test/java/hudson/plugins/warnings/WarningsMultiBranchTest.java
            src/test/java/hudson/plugins/warnings/WarningsPublisherTest.java
            http://jenkins-ci.org/commit/warnings-plugin/87b33c6d768d3fda06045a48579e0826bf8af3e0
            Log:
            Merge branch 'JENKINS-31202' of https://github.com/benjaminfuchs/warnings-plugin into benjaminfuchs-JENKINS-31202

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: pom.xml src/main/java/hudson/plugins/warnings/WarningsProjectAction.java src/main/java/hudson/plugins/warnings/WarningsPublisher.java src/main/java/hudson/plugins/warnings/WarningsResultAction.java src/test/java/hudson/plugins/warnings/WarningsMultiBranchTest.java src/test/java/hudson/plugins/warnings/WarningsPublisherTest.java http://jenkins-ci.org/commit/warnings-plugin/87b33c6d768d3fda06045a48579e0826bf8af3e0 Log: Merge branch ' JENKINS-31202 ' of https://github.com/benjaminfuchs/warnings-plugin into benjaminfuchs- JENKINS-31202
            drulli Ulli Hafner made changes -
            Link This issue is blocked by JENKINS-28479 [ JENKINS-28479 ]
            drulli Ulli Hafner added a comment -

            First step is done: warnings plug-in is supported now. Still missing: a ATH test case.
            What needs to be done before a release: update the other plugins (checkstyle, ...) in the same way.

            drulli Ulli Hafner added a comment - First step is done: warnings plug-in is supported now. Still missing: a ATH test case. What needs to be done before a release: update the other plugins (checkstyle, ...) in the same way.
            drulli Ulli Hafner made changes -
            Status Open [ 1 ] In Progress [ 3 ]

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            analysis-collector.iml
            pom.xml
            src/main/java/hudson/plugins/analysis/collector/AnalysisProjectAction.java
            src/main/java/hudson/plugins/analysis/collector/AnalysisPublisher.java
            src/main/java/hudson/plugins/analysis/collector/AnalysisResultAction.java
            http://jenkins-ci.org/commit/analysis-collector-plugin/c360a01c70cb46bae98140b48799b6da0249e4a4
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: analysis-collector.iml pom.xml src/main/java/hudson/plugins/analysis/collector/AnalysisProjectAction.java src/main/java/hudson/plugins/analysis/collector/AnalysisPublisher.java src/main/java/hudson/plugins/analysis/collector/AnalysisResultAction.java http://jenkins-ci.org/commit/analysis-collector-plugin/c360a01c70cb46bae98140b48799b6da0249e4a4 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            src/test/java/hudson/plugins/warnings/WarningsMultiBranchTest.java
            http://jenkins-ci.org/commit/warnings-plugin/839caad42955bb8e38f532f5fd07379245d23fb5
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: src/test/java/hudson/plugins/warnings/WarningsMultiBranchTest.java http://jenkins-ci.org/commit/warnings-plugin/839caad42955bb8e38f532f5fd07379245d23fb5 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            go.sh
            pom.xml
            src/main/java/hudson/plugins/tasks/TasksProjectAction.java
            src/main/java/hudson/plugins/tasks/TasksPublisher.java
            src/main/java/hudson/plugins/tasks/TasksResultAction.java
            tasks.iml
            http://jenkins-ci.org/commit/tasks-plugin/2467ad34cda280de75837126ed6bcdf86488b8d9
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: go.sh pom.xml src/main/java/hudson/plugins/tasks/TasksProjectAction.java src/main/java/hudson/plugins/tasks/TasksPublisher.java src/main/java/hudson/plugins/tasks/TasksResultAction.java tasks.iml http://jenkins-ci.org/commit/tasks-plugin/2467ad34cda280de75837126ed6bcdf86488b8d9 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            go.sh
            pmd.iml
            pom.xml
            src/main/java/hudson/plugins/pmd/PmdProjectAction.java
            src/main/java/hudson/plugins/pmd/PmdPublisher.java
            src/main/java/hudson/plugins/pmd/PmdResultAction.java
            http://jenkins-ci.org/commit/pmd-plugin/3fda8ed3752bc5404f936c1e65ee9c37e3ea13b0
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: go.sh pmd.iml pom.xml src/main/java/hudson/plugins/pmd/PmdProjectAction.java src/main/java/hudson/plugins/pmd/PmdPublisher.java src/main/java/hudson/plugins/pmd/PmdResultAction.java http://jenkins-ci.org/commit/pmd-plugin/3fda8ed3752bc5404f936c1e65ee9c37e3ea13b0 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            go.sh
            plugin/findbugs.iml
            plugin/pom.xml
            plugin/src/main/java/hudson/plugins/findbugs/FindBugsProjectAction.java
            plugin/src/main/java/hudson/plugins/findbugs/FindBugsPublisher.java
            plugin/src/main/java/hudson/plugins/findbugs/FindBugsResultAction.java
            release.sh
            http://jenkins-ci.org/commit/findbugs-plugin/560aa686e9b4e5010ac059e121d1c9ca27cefa46
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: go.sh plugin/findbugs.iml plugin/pom.xml plugin/src/main/java/hudson/plugins/findbugs/FindBugsProjectAction.java plugin/src/main/java/hudson/plugins/findbugs/FindBugsPublisher.java plugin/src/main/java/hudson/plugins/findbugs/FindBugsResultAction.java release.sh http://jenkins-ci.org/commit/findbugs-plugin/560aa686e9b4e5010ac059e121d1c9ca27cefa46 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            dry.iml
            pom.xml
            src/main/java/hudson/plugins/dry/DryProjectAction.java
            src/main/java/hudson/plugins/dry/DryPublisher.java
            src/main/java/hudson/plugins/dry/DryResultAction.java
            http://jenkins-ci.org/commit/dry-plugin/c060bc5d4fcc9a0d61f8dac99cf56013ffc2e0c0
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: dry.iml pom.xml src/main/java/hudson/plugins/dry/DryProjectAction.java src/main/java/hudson/plugins/dry/DryPublisher.java src/main/java/hudson/plugins/dry/DryResultAction.java http://jenkins-ci.org/commit/dry-plugin/c060bc5d4fcc9a0d61f8dac99cf56013ffc2e0c0 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            analysis-collector
            analysis-pom
            analysis-test
            checkstyle
            dry
            tasks
            warnings
            http://jenkins-ci.org/commit/analysis-suite-plugin/4544575679ff0210a124f0cc7634fb8a55f0dfb4
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Compare: https://github.com/jenkinsci/analysis-suite-plugin/compare/1ab6bdf2ef9d...4544575679ff

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: analysis-collector analysis-pom analysis-test checkstyle dry tasks warnings http://jenkins-ci.org/commit/analysis-suite-plugin/4544575679ff0210a124f0cc7634fb8a55f0dfb4 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector. Compare: https://github.com/jenkinsci/analysis-suite-plugin/compare/1ab6bdf2ef9d...4544575679ff

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            checkstyle.iml
            pom.xml
            src/main/java/hudson/plugins/checkstyle/CheckStyleProjectAction.java
            src/main/java/hudson/plugins/checkstyle/CheckStylePublisher.java
            src/main/java/hudson/plugins/checkstyle/CheckStyleResultAction.java
            src/test/java/hudson/plugins/checkstyle/CheckstyleWorkflowTest.java
            http://jenkins-ci.org/commit/checkstyle-plugin/846fe82e11d61706a6cbd534ee647a3e95e7258e
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: checkstyle.iml pom.xml src/main/java/hudson/plugins/checkstyle/CheckStyleProjectAction.java src/main/java/hudson/plugins/checkstyle/CheckStylePublisher.java src/main/java/hudson/plugins/checkstyle/CheckStyleResultAction.java src/test/java/hudson/plugins/checkstyle/CheckstyleWorkflowTest.java http://jenkins-ci.org/commit/checkstyle-plugin/846fe82e11d61706a6cbd534ee647a3e95e7258e Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            analysis-test.iml
            pom.xml
            http://jenkins-ci.org/commit/analysis-test-plugin/80faac3b6e3566c15c76d8df782828cf62474375
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: analysis-test.iml pom.xml http://jenkins-ci.org/commit/analysis-test-plugin/80faac3b6e3566c15c76d8df782828cf62474375 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            analysis-pom.iml
            http://jenkins-ci.org/commit/analysis-pom-plugin/336e7f81a31f5a3042ecd1f5eb50c9186b6fe470
            Log:
            JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep.

            checkstyle, dry, findbugs, pmd, tasks, analysis-collector.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: analysis-pom.iml http://jenkins-ci.org/commit/analysis-pom-plugin/336e7f81a31f5a3042ecd1f5eb50c9186b6fe470 Log: JENKINS-31202 Make remaining plugins compatible to SimpleBuildStep. checkstyle, dry, findbugs, pmd, tasks, analysis-collector.
            drulli Ulli Hafner made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            szhem Sergey Zhemzhitsky made changes -
            Link This issue is related to JENKINS-39947 [ JENKINS-39947 ]
            drulli Ulli Hafner made changes -
            Link This issue is related to JENKINS-36536 [ JENKINS-36536 ]
            jglick Jesse Glick made changes -
            Labels analysis-core-2.0 analysis-core-2.0 pipeline
            jglick Jesse Glick made changes -
            Link This issue is duplicated by JENKINS-39533 [ JENKINS-39533 ]

            Code changed in jenkins
            User: Ulli Hafner
            Path:
            .idea/codeStyleSettings.xml
            .idea/libraries/Maven__cglib_cglib_nodep_2_1_3.xml
            .idea/libraries/Maven__cglib_cglib_nodep_3_2_4.xml
            .idea/libraries/Maven__net_sourceforge_cssparser_cssparser_0_9_18.xml
            .idea/libraries/Maven__net_sourceforge_cssparser_cssparser_0_9_20.xml
            .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_2_20.xml
            .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_2_23.xml
            .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_core_js_2_17.xml
            .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_core_js_2_23.xml
            .idea/libraries/Maven__net_sourceforge_htmlunit_neko_htmlunit_2_23.xml
            .idea/libraries/Maven__net_sourceforge_nekohtml_nekohtml_1_9_22.xml
            .idea/libraries/Maven__org_apache_httpcomponents_httpclient_4_5_1.xml
            .idea/libraries/Maven__org_apache_httpcomponents_httpclient_4_5_2.xml
            .idea/libraries/Maven__org_apache_httpcomponents_httpcore_4_4_3.xml
            .idea/libraries/Maven__org_apache_httpcomponents_httpcore_4_4_4.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_api_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_api_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_chrome_driver_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_chrome_driver_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_edge_driver_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_edge_driver_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_firefox_driver_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_firefox_driver_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_ie_driver_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_ie_driver_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_java_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_java_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_leg_rc_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_opera_driver_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_remote_driver_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_remote_driver_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_safari_driver_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_safari_driver_3_0_1.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_support_2_53_0.xml
            .idea/libraries/Maven__org_seleniumhq_selenium_selenium_support_3_0_1.xml
            http://jenkins-ci.org/commit/analysis-suite-plugin/61d5d061f7ef34d312dc75271789b3ec0c2286a4
            Log:
            [FIXED JENKINS-31202] Added several new ATH test cases.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Ulli Hafner Path: .idea/codeStyleSettings.xml .idea/libraries/Maven__cglib_cglib_nodep_2_1_3.xml .idea/libraries/Maven__cglib_cglib_nodep_3_2_4.xml .idea/libraries/Maven__net_sourceforge_cssparser_cssparser_0_9_18.xml .idea/libraries/Maven__net_sourceforge_cssparser_cssparser_0_9_20.xml .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_2_20.xml .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_2_23.xml .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_core_js_2_17.xml .idea/libraries/Maven__net_sourceforge_htmlunit_htmlunit_core_js_2_23.xml .idea/libraries/Maven__net_sourceforge_htmlunit_neko_htmlunit_2_23.xml .idea/libraries/Maven__net_sourceforge_nekohtml_nekohtml_1_9_22.xml .idea/libraries/Maven__org_apache_httpcomponents_httpclient_4_5_1.xml .idea/libraries/Maven__org_apache_httpcomponents_httpclient_4_5_2.xml .idea/libraries/Maven__org_apache_httpcomponents_httpcore_4_4_3.xml .idea/libraries/Maven__org_apache_httpcomponents_httpcore_4_4_4.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_api_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_api_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_chrome_driver_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_chrome_driver_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_edge_driver_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_edge_driver_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_firefox_driver_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_firefox_driver_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_ie_driver_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_ie_driver_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_java_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_java_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_leg_rc_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_opera_driver_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_remote_driver_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_remote_driver_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_safari_driver_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_safari_driver_3_0_1.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_support_2_53_0.xml .idea/libraries/Maven__org_seleniumhq_selenium_selenium_support_3_0_1.xml http://jenkins-ci.org/commit/analysis-suite-plugin/61d5d061f7ef34d312dc75271789b3ec0c2286a4 Log: [FIXED JENKINS-31202] Added several new ATH test cases.
            drulli Ulli Hafner made changes -
            Remote Link This issue links to "Wiki Page (Jenkins Wiki)" [ 16927 ]
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal OSS-1378 (Web Link)" [ 18723 ]
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal OSS-501 (Web Link)" [ 18887 ]
            drulli Ulli Hafner made changes -
            Labels analysis-core-2.0 pipeline

            People

              drulli Ulli Hafner
              greg_symons Gregory Symons
              Votes:
              28 Vote for this issue
              Watchers:
              43 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: