Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31859

Jenkins pipeline displaying wrong result

    XMLWordPrintable

Details

    Description

      We have implemented jenkins pipelines. It has several builds chained together. The second to last build triggers three parellel jobs if the build suceeds. Two of these jobs fail but the result of the builds are shown as success.

      I've included two screen shots. One showing the build pipeline as green but the seperate builds are red. The build logs also report the build is failed.

      Attachments

        Activity

          josipj Josip Juric created issue -
          rtyler R. Tyler Croy made changes -
          Field Original Value New Value
          Component/s build-pipeline-plugin [ 15962 ]
          Component/s administrative [ 20861 ]
          Key WEBSITE-45 JENKINS-31859
          Workflow WEBSITE: Software Development Workflow [ 167314 ] JNJira [ 167314 ]
          Project Jenkins Website [ 10401 ] Jenkins [ 10172 ]
          Status To Do [ 10003 ] Open [ 1 ]
          rtyler R. Tyler Croy added a comment -

          I've moved this to the JENKINS project, the WEBSITE project is for tickets pertaining to the jenkins-ci.org website

          rtyler R. Tyler Croy added a comment - I've moved this to the JENKINS project, the WEBSITE project is for tickets pertaining to the jenkins-ci.org website
          rtyler R. Tyler Croy made changes -
          Assignee R. Tyler Croy [ rtyler ]
          rtyler R. Tyler Croy made changes -
          Assignee R. Tyler Croy [ rtyler ]
          orrc Christopher Orr made changes -
          Assignee Christopher Orr [ orrc ]
          orrc Christopher Orr made changes -
          Assignee Christopher Orr [ orrc ] Manuel Jesús Recena Soto [ recena ]
          recena Manuel Recena Soto made changes -
          Labels builds chained jenkins pipeline builds chained

          josipj What version are you using?

          recena Manuel Recena Soto added a comment - josipj What version are you using?
          josipj Josip Juric added a comment -

          We're using jenkins version 1.596.2

          josipj Josip Juric added a comment - We're using jenkins version 1.596.2

          josipj I meant plugin version.

          recena Manuel Recena Soto added a comment - josipj I meant plugin version.
          josipj Josip Juric added a comment -

          The build pipeline plugin version we are using is 1.4.7

          josipj Josip Juric added a comment - The build pipeline plugin version we are using is 1.4.7

          josipj It would be interesting to try if 1.4.9 version solves the problem.

          recena Manuel Recena Soto added a comment - josipj It would be interesting to try if 1.4.9 version solves the problem.
          dalvizu Dan Alvizu added a comment -

          There were issues in upstream/downstream relationship between 1.4.7 and 1.4.9 - please upgrade and re-test.

          I have this exact scenario and cannot reproduce.

          If you are able to reproduce, please include more information about your setup:

          How does the second job trigger the three jobs? If you can include the config.xml that would be great, but barring that:

          1) Are you using 'build other projects', 'manual trigger', 'trigger paramterized projects', and if so what version of the parameterized tirgger plugin are you running?
          2) What are you doing in the jobs which are failing yet show up as success? Can you include the config.xml of those jobs?

          dalvizu Dan Alvizu added a comment - There were issues in upstream/downstream relationship between 1.4.7 and 1.4.9 - please upgrade and re-test. I have this exact scenario and cannot reproduce. If you are able to reproduce, please include more information about your setup: How does the second job trigger the three jobs? If you can include the config.xml that would be great, but barring that: 1) Are you using 'build other projects', 'manual trigger', 'trigger paramterized projects', and if so what version of the parameterized tirgger plugin are you running? 2) What are you doing in the jobs which are failing yet show up as success? Can you include the config.xml of those jobs?
          dalvizu Dan Alvizu made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 167321 ] JNJira + In-Review [ 198158 ]

          People

            recena Manuel Recena Soto
            josipj Josip Juric
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: