Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-31884

Multibranch webhook notifications broken in 2.4.0

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      The implementation of JENKINS-27902 was incompatible for GitStatus.Listener implementations, and did not even update one of the two implementations inside the Git plugin. The result is that in 2.4.0 and later, webhook notifications are not delivered to multibranch projects.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick created issue -
            jglick Jesse Glick made changes -
            Field Original Value New Value
            Link This issue is blocking JENKINS-27902 [ JENKINS-27902 ]
            jglick Jesse Glick made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            jglick Jesse Glick made changes -
            Remote Link This issue links to "workflow PR 262 (integration test) (Web Link)" [ 13575 ]
            jglick Jesse Glick made changes -
            Remote Link This issue links to "PR 371 (Web Link)" [ 13576 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            multibranch/src/test/java/org/jenkinsci/plugins/workflow/multibranch/SCMBinderTest.java
            http://jenkins-ci.org/commit/workflow-plugin/1fd0023a0cfb1f0d0aa0dd069371e58ae24d208d
            Log:
            JENKINS-31884 Integration test for Git webhooks in multibranch projects.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            aggregator/src/test/java/org/jenkinsci/plugins/workflow/steps/scm/GitSampleRepoRule.java
            multibranch/src/test/java/org/jenkinsci/plugins/workflow/multibranch/SCMBinderTest.java
            http://jenkins-ci.org/commit/workflow-plugin/9eb0a8668a509c3f9c27a0eff00b01604ce230ac
            Log:
            Merge pull request #262 from jglick/GitStatus-multibranch-JENKINS-31884

            JENKINS-31884 Integration test for Git webhooks in multibranch projects

            Compare: https://github.com/jenkinsci/workflow-plugin/compare/ba9d22d14f0f...9eb0a8668a50

            abayer Andrew Bayer added a comment -

            I saw some weirdness when I was mucking around with some experiments where it looked like a multibranch project added the hook triggering on PRs but not on pushes - could that be related to this? If not, I'll try to reproduce the strangeness and try to narrow it down.

            jglick Jesse Glick added a comment -

            If you were doing anything with PRs, you were presumably using the CloudBees GitHub Pull Requests plugin, which uses an unrelated webhook (from the GitHub plugin).

            abayer Andrew Bayer added a comment -

            Gotcha - just wanted to check.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            src/main/java/hudson/plugins/git/GitStatus.java
            http://jenkins-ci.org/commit/git-plugin/1502180512ec9a2b2008d2c13b214b9a25cd5eb5
            Log:
            [FIXED JENKINS-31884] Since the newest version of onNotifyCommit is called, newer versions must delegate to older versions that may still have been overridden.

            scm_issue_link SCM/JIRA link daemon made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            src/main/java/jenkins/plugins/git/GitSCMSource.java
            http://jenkins-ci.org/commit/git-plugin/9d1d316e0e95c99b44862daaba349dbe9b870d00
            Log:
            JENKINS-31884 Override the newest version of onNotifyCommit.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Mark Waite
            Path:
            src/main/java/hudson/plugins/git/GitStatus.java
            src/main/java/jenkins/plugins/git/GitSCMSource.java
            http://jenkins-ci.org/commit/git-plugin/a09fcd613e5056e85ca8fea44ea614b62aa9052b
            Log:
            Merge pull request #371 from jglick/GitStatus-multibranch-JENKINS-31884

            JENKINS-31884 Deliver webhooks to all listeners

            Compare: https://github.com/jenkinsci/git-plugin/compare/f00f37972bb3...a09fcd613e50

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            multibranch/src/test/java/org/jenkinsci/plugins/workflow/multibranch/SCMBinderTest.java
            http://jenkins-ci.org/commit/workflow-multibranch-plugin/f00ff182ba2dea3298455db7da99bf7790c7d85f
            Log:
            JENKINS-31884 Integration test for Git webhooks in multibranch projects.
            Originally-Committed-As: 1fd0023a0cfb1f0d0aa0dd069371e58ae24d208d

            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 167351 ] JNJira + In-Review [ 198166 ]
            markewaite Mark Waite made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              Assignee:
              jglick Jesse Glick
              Reporter:
              jglick Jesse Glick
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: