Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32340

Cannot enable disabled dependencies

    XMLWordPrintable

Details

    Description

      It's not possible to enable disabled dependencies that should not have been disabled in the first place.

      Steps to reproduce:

      $ export JAVA_HOME=$HOME/DisabledDependencyHome
      $ java -jar jenkins.war
      ^C
      $ touch $JENKINS_HOME/plugins/{junit,matrix-project,maven-plugin}.jpi.disabled
      $ java -jar jenkins.war
      

      No warnings upon second startup, and JUnit plugin cannot be enabled through the UI

      Attachments

        Issue Links

          Activity

            danielbeck Daniel Beck created issue -
            danielbeck Daniel Beck made changes -
            Field Original Value New Value
            Component/s core [ 15593 ]
            Component/s core [ 21134 ]
            Key INFRA-540 JENKINS-32340
            Workflow classic default workflow [ 167950 ] JNJira [ 167950 ]
            Project Infrastructure [ 10301 ] Jenkins [ 10172 ]
            fbelzunc Félix Belzunce Arcos made changes -
            Assignee Tom FENNELLY [ tfennelly ] Félix Belzunce Arcos [ fbelzunc ]
            fbelzunc Félix Belzunce Arcos made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            fbelzunc Félix Belzunce Arcos made changes -
            URL https://github.com/jenkinsci/jenkins/pull/2002
            Description It's not possible to enable disabled dependencies that should not have been disabled in the first place.

            Steps to reproduce:

            {noformat}
            $ export JAVA_HOME=$HOME/DisabledDependencyHome
            $ java -jar jenkins.war
            ^C
            $ touch $JENKINS_HOME/plugins{junit,matrix-project,maven-plugin}.jpi.disabled
            $ java -jar jenkins.war
            {noformat}

            No warnings upon second startup, and JUnit plugin cannot be enabled through the UI
            It's not possible to enable disabled dependencies that should not have been disabled in the first place.

            Steps to reproduce:

            {noformat}
            $ export JAVA_HOME=$HOME/DisabledDependencyHome
            $ java -jar jenkins.war
            ^C
            $ touch $JENKINS_HOME/plugins/{junit,matrix-project,maven-plugin}.jpi.disabled
            $ java -jar jenkins.war
            {noformat}

            No warnings upon second startup, and JUnit plugin cannot be enabled through the UI
            danielbeck Daniel Beck made changes -
            Link This issue is related to JENKINS-32580 [ JENKINS-32580 ]
            danielbeck Daniel Beck made changes -
            Priority Major [ 3 ] Blocker [ 1 ]
            danielbeck Daniel Beck made changes -
            Labels lts-candidate 2.0-planned lts-candidate
            danielbeck Daniel Beck added a comment -

            Needs to be in 2.0 RC now that JENKINS-21486 will be in it as well.

            danielbeck Daniel Beck added a comment - Needs to be in 2.0 RC now that JENKINS-21486 will be in it as well.

            from fbelzunc See https://github.com/jenkinsci/jenkins/pull/2229 - It looks like the issue got fixed by Vincent PR

            swashbuck1r Spike Washburn added a comment - from fbelzunc See https://github.com/jenkinsci/jenkins/pull/2229 - It looks like the issue got fixed by Vincent PR
            danielbeck Daniel Beck added a comment -

            Not for 2.0, and probably not for 2.1 if 2072 gets reinstated.

            danielbeck Daniel Beck added a comment - Not for 2.0, and probably not for 2.1 if 2072 gets reinstated.
            danielbeck Daniel Beck made changes -
            Labels 2.0-planned lts-candidate lts-candidate
            Priority Blocker [ 1 ] Major [ 3 ]
            danielbeck Daniel Beck made changes -
            Link This issue is related to JENKINS-34494 [ JENKINS-34494 ]

            Code changed in jenkins
            User: Felix Belzunce Arcos
            Path:
            core/src/main/java/hudson/PluginWrapper.java
            core/src/main/resources/hudson/PluginManager/_table.js
            core/src/main/resources/hudson/PluginManager/installed.jelly
            war/src/main/webapp/css/style.css
            http://jenkins-ci.org/commit/jenkins/28335690e0b2535cdd76cc778ffdc45a5c4f67ac
            Log:
            JENKINS-32340 Enable disabled dependencies

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Felix Belzunce Arcos Path: core/src/main/java/hudson/PluginWrapper.java core/src/main/resources/hudson/PluginManager/_table.js core/src/main/resources/hudson/PluginManager/installed.jelly war/src/main/webapp/css/style.css http://jenkins-ci.org/commit/jenkins/28335690e0b2535cdd76cc778ffdc45a5c4f67ac Log: JENKINS-32340 Enable disabled dependencies

            Code changed in jenkins
            User: Daniel Beck
            Path:
            core/src/main/resources/hudson/PluginManager/_table.js
            core/src/main/resources/hudson/PluginManager/installed.jelly
            war/src/main/webapp/css/style.css
            http://jenkins-ci.org/commit/jenkins/59f066462ce16585b0acfa0511e2358306f92805
            Log:
            Merge pull request #2229 from fbelzunc/JENKINS-32340-v2

            JENKINS-32340 Enable disabled dependencies

            Compare: https://github.com/jenkinsci/jenkins/compare/bc1c2cab162f...59f066462ce1

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Daniel Beck Path: core/src/main/resources/hudson/PluginManager/_table.js core/src/main/resources/hudson/PluginManager/installed.jelly war/src/main/webapp/css/style.css http://jenkins-ci.org/commit/jenkins/59f066462ce16585b0acfa0511e2358306f92805 Log: Merge pull request #2229 from fbelzunc/ JENKINS-32340 -v2 JENKINS-32340 Enable disabled dependencies Compare: https://github.com/jenkinsci/jenkins/compare/bc1c2cab162f...59f066462ce1
            danielbeck Daniel Beck made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]
            olivergondza Oliver Gondža made changes -
            Labels lts-candidate 1.651.3-rejected lts-candidate
            olivergondza Oliver Gondža made changes -
            Labels 1.651.3-rejected lts-candidate 1.651.3-fixed

            Code changed in jenkins
            User: Felix Belzunce Arcos
            Path:
            core/src/main/java/hudson/PluginWrapper.java
            core/src/main/resources/hudson/PluginManager/_table.js
            core/src/main/resources/hudson/PluginManager/installed.jelly
            war/src/main/webapp/css/style.css
            http://jenkins-ci.org/commit/jenkins/1c416b89edf733962147b2eb45a4ce8824dc454e
            Log:
            JENKINS-32340 Enable disabled dependencies

            (cherry picked from commit 28335690e0b2535cdd76cc778ffdc45a5c4f67ac)

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Felix Belzunce Arcos Path: core/src/main/java/hudson/PluginWrapper.java core/src/main/resources/hudson/PluginManager/_table.js core/src/main/resources/hudson/PluginManager/installed.jelly war/src/main/webapp/css/style.css http://jenkins-ci.org/commit/jenkins/1c416b89edf733962147b2eb45a4ce8824dc454e Log: JENKINS-32340 Enable disabled dependencies (cherry picked from commit 28335690e0b2535cdd76cc778ffdc45a5c4f67ac)
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 167951 ] JNJira + In-Review [ 198317 ]
            cloudbees CloudBees Inc. made changes -
            Remote Link This issue links to "CloudBees Internal OSS-444 (Web Link)" [ 18891 ]

            People

              fbelzunc Félix Belzunce Arcos
              danielbeck Daniel Beck
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: