Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32434

Upgrading Groovy version to 2.3+ in job-dsl-plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Is there a plan to upgrade the Groovy version to a newer version (e.g. 2.3+) in job-dsl-plugin?

      The current used version 1.8.9 is probably too old and prevent developer to use new features like Traits.

        Attachments

          Issue Links

            Activity

            fayndee Fang Yuan created issue -
            daspilker Daniel Spilker made changes -
            Field Original Value New Value
            Link This issue depends on JENKINS-21249 [ JENKINS-21249 ]
            daspilker Daniel Spilker made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            daspilker Daniel Spilker made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 168064 ] JNJira + In-Review [ 209612 ]

              People

              Assignee:
              daspilker Daniel Spilker
              Reporter:
              fayndee Fang Yuan
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: