Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32589

Groovy postbuild should not mandatory depend on workflow

    XMLWordPrintable

Details

    Description

      Installing groovy-postbuild-2.3 causes installing many dependent plugins:

      • Script Security Plugin
      • Pipeline: Step API
      • MapDB API Plugin
      • SCM API Plugin
      • Subversion Plug-in
      • Pipeline: SCM Step
      • Pipeline: API
      • Durable Task Plugin
      • Pipeline: Execution Support
      • JavaScript GUI Lib: jQuery bundles (jQuery and jQuery UI) plugin
      • JavaScript GUI Lib: ACE Editor bundle plugin
      • Pipeline: Groovy CPS Execution

      This is mainly caused for groovy-potbuild-2.3 starts to depend on workflow-cps to support workflow (JENKINS-26918).
      This is not a mandatory feature, and those dependencies should be optional.

      Note: Script Security plugin is mandatory for its security model.

      Attachments

        Issue Links

          Activity

            People

              ikedam ikedam
              ikedam ikedam
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: