Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32910

Jelly file was not found after update

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • email-ext-plugin
    • None
    • Jenkins Version 1.642.1
      Email Extension Plugin Version 2.41

    Description

      Hallo,

      I use Jenkins Version 1.642.1. After an update by the Email Extension Plugin to Version 2.41, the plugin send me an mail with the following text:
      "Jelly file [html-with-health-and-console] was not found in $JENKINS_HOME/email-templates"

      In Version 2.40.5 is it successful and I don't change something. You can see the settings in the picture. The file exists (/var/lib/jenkins/email-templates/).

      Attachments

        Issue Links

          Activity

            alexander_niemeier Alexander Niemeier created issue -
            slide_o_mix Alex Earl added a comment -

            Can you put $JENKINS_HOME in the subject just to make sure the correct JENKINS_HOME is getting used?

            slide_o_mix Alex Earl added a comment - Can you put $JENKINS_HOME in the subject just to make sure the correct JENKINS_HOME is getting used?

            $JENKINS_HOME = /var/lib/jenkins
            I have the version now reset (2.40.5) and it work. I think there really is an error in the new version 2.41.

            alexander_niemeier Alexander Niemeier added a comment - $JENKINS_HOME = /var/lib/jenkins I have the version now reset (2.40.5) and it work. I think there really is an error in the new version 2.41.
            slide_o_mix Alex Earl added a comment -

            I'm not saying there isn't an issue with 2.41. I am just not able to replicate this issue so I need help from you to determine where the issue is.

            slide_o_mix Alex Earl added a comment - I'm not saying there isn't an issue with 2.41. I am just not able to replicate this issue so I need help from you to determine where the issue is.

            Having same issue (email after succesful build) after upgrade to 2.41:

            Jelly file [html] was not found in $JENKINS_HOME/email-templates.

            Jenkins version: 1.647

            ralfverstappen Ralf Verstappen added a comment - Having same issue (email after succesful build) after upgrade to 2.41: Jelly file [html] was not found in $JENKINS_HOME/email-templates. Jenkins version: 1.647

            Checked the folder, but it does not exist.

            ralfverstappen Ralf Verstappen added a comment - Checked the folder, but it does not exist.

            I downloaded the source of this plugin and copied the content of the templates folder to the folder email-templates (created by hand).
            That solves the issue for us.

            ralfverstappen Ralf Verstappen added a comment - I downloaded the source of this plugin and copied the content of the templates folder to the folder email-templates (created by hand). That solves the issue for us.
            kbrowder Kevin Browder added a comment -

            I suppose it's not that usefull to say "me to", but... I'm also seeing this. Downgrading to 2.40.5 fixes the issue. I'm on the latest jenkins and using the Jenkins docker release (I enabled updates so I wasn't stuck on the LTS).

            kbrowder Kevin Browder added a comment - I suppose it's not that usefull to say "me to", but... I'm also seeing this. Downgrading to 2.40.5 fixes the issue. I'm on the latest jenkins and using the Jenkins docker release (I enabled updates so I wasn't stuck on the LTS).
            slide_o_mix Alex Earl added a comment -

            Ok, I'm pretty sure I know what the issue is. I should have a dot release today or tomorrow.

            slide_o_mix Alex Earl added a comment - Ok, I'm pretty sure I know what the issue is. I should have a dot release today or tomorrow.
            slide_o_mix Alex Earl made changes -
            Field Original Value New Value
            Link This issue is duplicated by JENKINS-32970 [ JENKINS-32970 ]
            slide_o_mix Alex Earl added a comment -

            Fixed class loader to previous behavior. Released as 2.41.2

            slide_o_mix Alex Earl added a comment - Fixed class loader to previous behavior. Released as 2.41.2
            slide_o_mix Alex Earl made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 168622 ] JNJira + In-Review [ 198448 ]

            People

              slide_o_mix Alex Earl
              alexander_niemeier Alexander Niemeier
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: