Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33035

Editable Email Notification Upgrade Breaks Jenkins Boot Up

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • email-ext-plugin
    • None
    • Windows 2012. Jenkins 1.648. JRE 7u80

    Description

      When I update the email-ext-plugin to the 2.41 or 2.41.2 updates, it breaks Jenkins from even starting up with a java.lang.Error: java.lang.reflect.InvocationTargetException error that doesn't even allow the Jenkins UI to be functional. Have to remove the email-ext-plugin from the Plugins directory to get Jenkins back up again.

      Feb 19, 2016 7:57:26 AM hudson.util.BootFailure publish
      SEVERE: Failed to initialize Jenkins
      hudson.util.HudsonFailedToLoad: org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.WebAppMain$3.run(WebAppMain.java:237)
      Caused by: org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:44)
      at jenkins.model.Jenkins.executeReactor(Jenkins.java:935)
      at jenkins.model.Jenkins.<init>(Jenkins.java:816)
      at hudson.model.Hudson.<init>(Hudson.java:83)
      at hudson.model.Hudson.<init>(Hudson.java:79)
      at hudson.WebAppMain$3.run(WebAppMain.java:225)
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:110)
      at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:176)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$8.runTask(Jenkins.java:924)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:106)
      ... 8 more
      Caused by: java.lang.NullPointerException
      at hudson.diagnosis.NullIdDescriptorMonitor.verifyId(NullIdDescriptorMonitor.java:89)
      ... 13 more

      Attachments

        1. error2.txt
          78 kB
        2. jenkins.err.log
          86 kB
        3. junit.png
          junit.png
          134 kB
        4. log.txt
          37 kB

        Issue Links

          Activity

            nbl9999 Nathan Lindshield created issue -
            slide_o_mix Alex Earl added a comment -

            I haven't seen this in my dog fooding. Since there is no exception information about email-ext, I am not sure how to debug this. Is this the only error message in the logs?

            slide_o_mix Alex Earl added a comment - I haven't seen this in my dog fooding. Since there is no exception information about email-ext, I am not sure how to debug this. Is this the only error message in the logs?

            Erorr in description was what is left of Jenkins UI shows. Complete log trail attached.

            nbl9999 Nathan Lindshield added a comment - Erorr in description was what is left of Jenkins UI shows. Complete log trail attached.
            nbl9999 Nathan Lindshield made changes -
            Field Original Value New Value
            Attachment log.txt [ 31914 ]
            slide_o_mix Alex Earl added a comment -

            Ok, that helps a bunch. Looks like you don't have workflow plugin installed and I failed to make the workflow extension point optional. Should hopefully be an easy fix.

            slide_o_mix Alex Earl added a comment - Ok, that helps a bunch. Looks like you don't have workflow plugin installed and I failed to make the workflow extension point optional. Should hopefully be an easy fix.
            slide_o_mix Alex Earl made changes -
            Status Open [ 1 ] In Progress [ 3 ]
            slide_o_mix Alex Earl added a comment -

            Made workflow @Extension optional

            slide_o_mix Alex Earl added a comment - Made workflow @Extension optional
            slide_o_mix Alex Earl made changes -
            Resolution Fixed [ 1 ]
            Status In Progress [ 3 ] Resolved [ 5 ]

            Still occurs with 2.41.3. Log attached.

            nbl9999 Nathan Lindshield added a comment - Still occurs with 2.41.3. Log attached.
            nbl9999 Nathan Lindshield made changes -
            Resolution Fixed [ 1 ]
            Status Resolved [ 5 ] Reopened [ 4 ]
            nbl9999 Nathan Lindshield made changes -
            Attachment error2.txt [ 32034 ]
            slide_o_mix Alex Earl added a comment -

            Those ones don't look like they are caused by email-ext. Did you update Jenkins itself recently?

            slide_o_mix Alex Earl added a comment - Those ones don't look like they are caused by email-ext. Did you update Jenkins itself recently?

            I upgraded 3 other plugins first before trying email-ext. Will look at reverting them and then trying 2.41.3 again in a bit when no projects are running.

            nbl9999 Nathan Lindshield added a comment - I upgraded 3 other plugins first before trying email-ext. Will look at reverting them and then trying 2.41.3 again in a bit when no projects are running.
            slide_o_mix Alex Earl added a comment - - edited

            It looks like you might be missing the cloudbees-folder plugin, the matrix plugin and the junit plugin.

            slide_o_mix Alex Earl added a comment - - edited It looks like you might be missing the cloudbees-folder plugin, the matrix plugin and the junit plugin.

            Still occurs after reverting the other 3 plugins and trying again with 2.41.3. Another log attached.

            nbl9999 Nathan Lindshield added a comment - Still occurs after reverting the other 3 plugins and trying again with 2.41.3. Another log attached.
            nbl9999 Nathan Lindshield made changes -
            Attachment jenkins.err.log [ 32036 ]
            slide_o_mix Alex Earl added a comment -

            Still looks like you are missing the junit plugin which is a required dependency for email-ext

            slide_o_mix Alex Earl added a comment - Still looks like you are missing the junit plugin which is a required dependency for email-ext

            So junit plugin is installed, v1.10, but not the 1.2 version that is listed on the Email-ext plugin page. However the junit link does not show a 1.2 version available. Where/how is 1.2 installed? See attached screenshot.

            nbl9999 Nathan Lindshield added a comment - So junit plugin is installed, v1.10, but not the 1.2 version that is listed on the Email-ext plugin page . However the junit link does not show a 1.2 version available. Where/how is 1.2 installed? See attached screenshot.
            nbl9999 Nathan Lindshield made changes -
            Attachment junit.png [ 32038 ]
            slide_o_mix Alex Earl added a comment - http://updates.jenkins-ci.org/download/plugins/junit/1.2/junit.hpi
            slide_o_mix Alex Earl added a comment -

            v1.10 should be fine though

            slide_o_mix Alex Earl added a comment - v1.10 should be fine though
            slide_o_mix Alex Earl added a comment -

            Your screenshot shows the plugin as disabled.

            slide_o_mix Alex Earl added a comment - Your screenshot shows the plugin as disabled.

            I thought the same thing that it was disabled, but it's not clickable. If you try, then you get the below banner that it can't be disabled because of the dependencies.

            nbl9999 Nathan Lindshield added a comment - I thought the same thing that it was disabled, but it's not clickable. If you try, then you get the below banner that it can't be disabled because of the dependencies.
            slide_o_mix Alex Earl added a comment -

            Check JENKINS_HOME to see if there is a .disabled file for the junit plugin.

            slide_o_mix Alex Earl added a comment - Check JENKINS_HOME to see if there is a .disabled file for the junit plugin.

            Alright, so somehow I managed to get the junit plugin disabled even though it is dependency for a large number of plugins. Tried uploading the junit 1.2 version and still showed as disabled. Had to go into the plugins directory and remove the disabled flag. Then the 1.2 version showed as an update. Updated it, restarted, then updated email-ext. No issues. Thanks for the fix and help.

            nbl9999 Nathan Lindshield added a comment - Alright, so somehow I managed to get the junit plugin disabled even though it is dependency for a large number of plugins. Tried uploading the junit 1.2 version and still showed as disabled. Had to go into the plugins directory and remove the disabled flag. Then the 1.2 version showed as an update. Updated it, restarted, then updated email-ext. No issues. Thanks for the fix and help.
            slide_o_mix Alex Earl made changes -
            Resolution Fixed [ 1 ]
            Status Reopened [ 4 ] Resolved [ 5 ]

            Fixed in 2.41.3!

            nbl9999 Nathan Lindshield added a comment - Fixed in 2.41.3!
            nbl9999 Nathan Lindshield made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            slide_o_mix Alex Earl made changes -
            Link This issue is duplicated by JENKINS-33148 [ JENKINS-33148 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 168864 ] JNJira + In-Review [ 209726 ]

            People

              slide_o_mix Alex Earl
              nbl9999 Nathan Lindshield
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: