Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33086

Successful build notification with multibranch job does not work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: github-plugin
    • Environment:
      Windows 10 x64
      Oracle JRE 1.7.0_79-b15 x64
      Workflow plugin: 1.13
      Github plugin: 1.17.0
      GitHub API plugin: 1.72
      Jenkins running from command line
    • Similar Issues:

      Description

      Minimal reproduction is here: https://github.com/Novakov/jenkins-github-test/pull/1

      I've got Jenkins with multibranch job configured to watch GitHub repository. One of the branches (build) contains Jenkinsfile using GitHub plugin to set commit status at begin of build and at the end.

      After executing build GitHub pull request page shows 'Build successful' but still thinks that build is in progress.

        Attachments

          Activity

          novakov Maciej Nowak created issue -
          lanwen Kirill Merkushev added a comment -

          please provide your config.xml for job

          novakov Maciej Nowak made changes -
          Field Original Value New Value
          Attachment config.xml [ 32033 ]
          novakov Maciej Nowak added a comment - - edited

          Attached. It is simplest possible multibranch project - just Git source

          novakov Maciej Nowak added a comment -

          I wrote simple program that uses the same GitHub API library to update commit status (code:https://gist.github.com/Novakov/f466d8104cbd76d22516) and it worked like a charm, so the problem must lay in Jenkins or one of its plugins.

          danielbeck Daniel Beck added a comment -

          Probably around here:
          https://github.com/jenkinsci/github-plugin/blob/master/src/main/java/com/cloudbees/jenkins/GitHubCommitNotifier.java#L157

          As the plugin appears to not properly handle being called while a build is still running (and supposed to pretend it's finished).

          lanwen Kirill Merkushev added a comment -

          See https://github.com/jenkinsci/github-plugin/pull/102 for the explanation.
          Think its not a bug of github-plugin

          lanwen Kirill Merkushev made changes -
          Summary Successful build notification does not work Successful build notification with multibranch job does not work
          jglick Jesse Glick added a comment -

          Use the github-branch-source plugin, which is designed for multibranch.

          jglick Jesse Glick made changes -
          Resolution Won't Fix [ 2 ]
          Status Open [ 1 ] Resolved [ 5 ]
          lanwen Kirill Merkushev made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 168943 ] JNJira + In-Review [ 209736 ]

            People

            Assignee:
            lanwen Kirill Merkushev
            Reporter:
            novakov Maciej Nowak
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: