Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33678

Docker authentication - malformed HTTP response

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I am setting the docker server URI with tcp and I am adding 'Docker Host Certificate Authentication` and selecting it in the project. When it tries to connect to docker it returns

      malformed HTTP response "\x15\x03\x01\x00\x02\x02\x16".
      * Are you trying to connect to a TLS-enabled daemon without TLS?
      Build step 'Docker Build and Publish' marked build as failure
      

      Looks like the plugin is not using the certificate? Am I doing something wrong or this is a bug?

      The build is run on a slave connected with JSN.

        Attachments

          Activity

          robertdolca Robert Dolca created issue -
          robertdolca Robert Dolca made changes -
          Field Original Value New Value
          Description I am setting the docker server URI with tcp and I am adding 'Docker Host Certificate Authentication` and selecting it in the project. When it tries to connect to docker it returns

          ```
          malformed HTTP response "\x15\x03\x01\x00\x02\x02\x16".
          * Are you trying to connect to a TLS-enabled daemon without TLS?
          Build step 'Docker Build and Publish' marked build as failure
          ```

          Looks like the plugin is not using the certificate? Am I doing something wrong or this is a bug?

          The build is run on a slave connected with JSN.
          I am setting the docker server URI with tcp and I am adding 'Docker Host Certificate Authentication` and selecting it in the project. When it tries to connect to docker it returns

          {code:java}
          malformed HTTP response "\x15\x03\x01\x00\x02\x02\x16".
          * Are you trying to connect to a TLS-enabled daemon without TLS?
          Build step 'Docker Build and Publish' marked build as failure
          {code}

          Looks like the plugin is not using the certificate? Am I doing something wrong or this is a bug?

          The build is run on a slave connected with JSN.
          robertdolca Robert Dolca made changes -
          Priority Minor [ 4 ] Major [ 3 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 169640 ] JNJira + In-Review [ 183585 ]

            People

            Assignee:
            csanchez Carlos Sanchez
            Reporter:
            robertdolca Robert Dolca
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: