Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33742

Missing Specific credentials/Parameter expression option in Bindings definition

    XMLWordPrintable

Details

    Description

      We need to use Parametrized build plugin and let user select appropriate credentials before running a job. We wanted to bind the selected credentials via Credentials binding and expression parameter, but the option is not there to be selected when defining "Use secret text(s) or file(s)".
      All documentation and screenshots we found mention and show this option }should be there since version 1.1 of the plugin), so it is strange it does not appear in current versions.
      We tried both freestyle project and Pipeline job, it is missing in both cases.
      We checked the underlying HTML and the options is not there, i.e. it is not a graphic issue like hidden <div> section.

      Attachments

        Issue Links

          Activity

            mbukovjan Michal Bukovjan created issue -
            elyscape Eli Young added a comment -

            This appears to be a result of this commit.

            elyscape Eli Young added a comment - This appears to be a result of this commit .
            elyscape Eli Young added a comment -

            Yup, that was the problem. I just made a local build with that commit reverted and the problem is gone.

            elyscape Eli Young added a comment - Yup, that was the problem. I just made a local build with that commit reverted and the problem is gone.
            elyscape Eli Young added a comment -

            I think for some reason the variable isn't getting set before MultiBinding/config.jelly is parsed.

            elyscape Eli Young added a comment - I think for some reason the variable isn't getting set before MultiBinding/config.jelly is parsed.
            elyscape Eli Young added a comment -

            jglick, any idea what might be going on? It was your commit that caused this issue, unfortunately.

            elyscape Eli Young added a comment - jglick , any idea what might be going on? It was your commit that caused this issue, unfortunately.
            rtyler R. Tyler Croy made changes -
            Field Original Value New Value
            Workflow JNJira [ 169715 ] JNJira + In-Review [ 183619 ]
            jglick Jesse Glick added a comment -

            Sounds like JENKINS-35490.

            jglick Jesse Glick added a comment - Sounds like JENKINS-35490 .
            jglick Jesse Glick made changes -
            Link This issue duplicates JENKINS-35490 [ JENKINS-35490 ]
            jglick Jesse Glick made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]

            People

              jglick Jesse Glick
              mbukovjan Michal Bukovjan
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: