Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33774

'Create Item' does not support autocompleting the 'Copy from' field

    XMLWordPrintable

Details

    Attachments

      Issue Links

        Activity

          danielbeck Daniel Beck created issue -
          danielbeck Daniel Beck made changes -
          Field Original Value New Value
          Priority Major [ 3 ] Blocker [ 1 ]
          danielbeck Daniel Beck made changes -
          Labels 2.0 2.0-beta 2.0 2.0-beta regression
          danielbeck Daniel Beck added a comment -

          Let's not make the Jenkins 2.0 dialog worse than the 1.x one.

          danielbeck Daniel Beck added a comment - Let's not make the Jenkins 2.0 dialog worse than the 1.x one.
          danielbeck Daniel Beck made changes -
          Epic Link JENKINS-33810 [ 169285 ]
          danielbeck Daniel Beck made changes -
          Rank Ranked higher

          This a step backwards vs the old New Item page, so we should fix it.

          swashbuck1r Spike Washburn added a comment - This a step backwards vs the old New Item page, so we should fix it.
          recena Manuel Recena Soto made changes -
          Assignee Manuel Jesús Recena Soto [ recena ]
          jglick Jesse Glick added a comment -

          Making it harder to test changes associated with JENKINS-33759.

          jglick Jesse Glick added a comment - Making it harder to test changes associated with JENKINS-33759 .
          jglick Jesse Glick made changes -
          Link This issue is blocking JENKINS-33759 [ JENKINS-33759 ]
          danielbeck Daniel Beck made changes -
          Labels 2.0 2.0-beta regression 2.0 2.0-beta 2.0-planned regression
          jglick Jesse Glick added a comment -

          Generally there is no network traffic from either the job name or copy text fields, so it is not just this which is broken: there is also no checking that the job is not being named, for example, \$.

          jglick Jesse Glick added a comment - Generally there is no network traffic from either the job name or copy text fields, so it is not just this which is broken: there is also no checking that the job is not being named, for example, \$ .
          jglick Jesse Glick made changes -
          Link This issue is blocking JENKINS-31162 [ JENKINS-31162 ]
          jglick Jesse Glick made changes -
          Link This issue is related to JENKINS-33755 [ JENKINS-33755 ]
          recena Manuel Recena Soto made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          amuniz Antonio Muñiz made changes -
          Assignee Manuel Jesús Recena Soto [ recena ] Antonio Muñiz [ amuniz ]

          PR sent to be merged into recena/jenkins that will be sent as a compounded PR to jenkinsci/jenkins:2.0

          amuniz Antonio Muñiz added a comment - PR sent to be merged into recena/jenkins that will be sent as a compounded PR to jenkinsci/jenkins:2.0
          jglick Jesse Glick added a comment -

          That change did not make much sense to me, since it seems to be just duplicating a block that was already there (and did not work).

          As written in JENKINS-33755, I suspect these are essentially the same bug, just affecting two fields on the same page.

          jglick Jesse Glick added a comment - That change did not make much sense to me, since it seems to be just duplicating a block that was already there (and did not work). As written in JENKINS-33755 , I suspect these are essentially the same bug, just affecting two fields on the same page.
          amuniz Antonio Muñiz added a comment - - edited

          jglick Yes, you are right, I resolved a conflict and uploaded a wrong version. Anyway it's already fixed later by recena in https://github.com/recena/jenkins/commit/143ccab9f49a628342e17e51342aaa327940a7fd

          (Just note that that was a PR to recena's repository, we will have a full review process once he sends the overall PR to jenkinsci/jenkins).

          amuniz Antonio Muñiz added a comment - - edited jglick Yes, you are right, I resolved a conflict and uploaded a wrong version. Anyway it's already fixed later by recena in https://github.com/recena/jenkins/commit/143ccab9f49a628342e17e51342aaa327940a7fd (Just note that that was a PR to recena's repository, we will have a full review process once he sends the overall PR to jenkinsci/jenkins).
          recena Manuel Recena Soto made changes -
          Remote Link This issue links to "PR (Web Link)" [ 14133 ]
          recena Manuel Recena Soto made changes -
          Remote Link This issue links to "PR (Web Link)" [ 14133 ]
          recena Manuel Recena Soto made changes -
          Remote Link This issue links to "PR (Web Link)" [ 14134 ]
          recena Manuel Recena Soto made changes -
          Link This issue duplicates JENKINS-33583 [ JENKINS-33583 ]
          jglick Jesse Glick made changes -
          Assignee Antonio Muñiz [ amuniz ] Manuel Jesús Recena Soto [ recena ]

          Code changed in jenkins
          User: Antonio Muñiz
          Path:
          core/src/main/resources/hudson/model/View/newJob.jelly
          http://jenkins-ci.org/commit/jenkins/3aae1bbc8f24faa624bfe2cab6a044d03d06167e
          Log:
          JENKINS-33774 Autocomplete on New Item - Copy From

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Antonio Muñiz Path: core/src/main/resources/hudson/model/View/newJob.jelly http://jenkins-ci.org/commit/jenkins/3aae1bbc8f24faa624bfe2cab6a044d03d06167e Log: JENKINS-33774 Autocomplete on New Item - Copy From

          Code changed in jenkins
          User: Jesse Glick
          Path:
          core/src/main/resources/hudson/model/View/newJob.jelly
          core/src/main/resources/hudson/model/View/newJob.properties
          war/src/main/js/add-item.js
          war/src/main/js/add-item.less
          war/src/main/js/widgets/add/addform.less
          http://jenkins-ci.org/commit/jenkins/ef08dc1d7280e2817e59d967b7f0f40fa13252b0
          Log:
          Merge pull request #2191 from recena/newitem-polish

          [FIXED JENKINS-33774] [FIXED JENKINS-33755] New item option

          Compare: https://github.com/jenkinsci/jenkins/compare/360cfcdcc87f...ef08dc1d7280

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: core/src/main/resources/hudson/model/View/newJob.jelly core/src/main/resources/hudson/model/View/newJob.properties war/src/main/js/add-item.js war/src/main/js/add-item.less war/src/main/js/widgets/add/addform.less http://jenkins-ci.org/commit/jenkins/ef08dc1d7280e2817e59d967b7f0f40fa13252b0 Log: Merge pull request #2191 from recena/newitem-polish [FIXED JENKINS-33774] [FIXED JENKINS-33755] New item option Compare: https://github.com/jenkinsci/jenkins/compare/360cfcdcc87f...ef08dc1d7280
          jglick Jesse Glick added a comment -

          stupid JIRA link daemon

          jglick Jesse Glick added a comment - stupid JIRA link daemon
          jglick Jesse Glick made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 169759 ] JNJira + In-Review [ 198675 ]

          People

            recena Manuel Recena Soto
            danielbeck Daniel Beck
            Votes:
            1 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: