Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-337

Unable to checkout aliased modules

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Trivial
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The cvs command generated includes the -d workspace option but this fails with
      our module definitions, which look like this (in the CVSROOT/modules):

      main -a products/main products/buildsystem products/etc

      In this case, you get cvs errors like

      cvs checkout: existing repository /usr/cvs/products/main does not match
      /usr/cvs/products/buildsystem
      ...

      The solution turns out to be adding the -N option. When combined with -d it
      indicates that the directory path should not be shortened to eliminate empty
      parent directories, which in this case would be "products." For some reason
      this also eliminates the error.

      So perhaps you could add that option to the CVS command or otherwise add an
      option to specify it, like a checkbox with "checkout modules without empty
      parent directories".

      Am using cvs version 1.11.17

        Attachments

          Issue Links

            Activity

            bkayser bkayser created issue -
            bkayser bkayser added a comment -

            Well it seems that setting the option to preserve backward compatibility solves
            the problem. This sets an attribute called "flatten" to false.

            I'm surprised the option wasn't labeled better to indicate what it actually
            does.

            Sorry for the noise. Awesome product. I'll close this now.

            bkayser bkayser added a comment -

            Sorry, there is no further action on this (unless you want to improve the
            label) but I can't seem to close it.

            jglick Jesse Glick added a comment -

            I also think this option should be labelled better. The docs imply that the only
            reason you would want to use it is for B/C if you were originally running an old
            Hudson release. This is not true.

            kohsuke Kohsuke Kawaguchi added a comment -

            Any suggestion what the new name of the option should be?

            bkayser bkayser added a comment -

            Note that the backward compatibility option works for the checkout but falls
            over in the changelog. I submitted a separate bug on that, bug 427, and renamed
            the summary to reflect the request to change the label on the legacy option.

            In bug 427 I suggest a slightly different implementation of the legacy option
            which uses the cvs -Nd combination to check out the full path, instead of
            omitting the -d option.

            Anyhow, here are some suggestions for labels:

            "Keep full module path on checkout."

            "Don't shorten module paths on checkout."

            "Don't use -d modulename option on checkout."

            I also recommend changing the help to add additionally: "This option is also
            necessary when using CVS module aliases (the -a option)."

            kohsuke Kohsuke Kawaguchi added a comment -

            Issue #427 is the same issue.

                • This issue has been marked as a duplicate of 427 ***
            kohsuke Kohsuke Kawaguchi made changes -
            Field Original Value New Value
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            kohsuke Kohsuke Kawaguchi made changes -
            Link This issue duplicates JENKINS-427 [ JENKINS-427 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            ircbot Jenkins IRC Bot made changes -
            Component/s core [ 15593 ]
            Component/s www [ 15484 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 130410 ] JNJira + In-Review [ 199787 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              bkayser bkayser
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: