Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-33812

NPE during jenkins restart after plugin upgrade

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Environment:
      Linux (jenkins) + Linux / Windows (slaves)
    • Similar Issues:

      Description

      Since 3 or 4 jenkins release (I use 1.653 today), I meet a little problem while jenkins is restarting after plugins upgrade.
      Jenkins stays on the main update web page forever.
      When I look at the log, I found the following message:

      Avertissement: Failed to restart Jenkins
      java.lang.RuntimeException: Unexpected issues encountered during cleanUp: null
      at jenkins.model.Jenkins.cleanUp(Jenkins.java:2906)
      at hudson.lifecycle.UnixLifecycle.restart(UnixLifecycle.java:70)
      at jenkins.model.Jenkins$27.run(Jenkins.java:3847)
      Caused by: java.lang.UnsupportedOperationException
      at java.util.concurrent.CopyOnWriteArrayList$COWIterator.remove(CopyOnWriteArrayList.java:1040)
      at hudson.util.PluginServletFilter.cleanUp(PluginServletFilter.java:162)
      at jenkins.model.Jenkins._cleanUpPluginServletFilters(Jenkins.java:3238)
      at jenkins.model.Jenkins.cleanUp(Jenkins.java:2891)
      ... 2 more

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Fixed towards 1.654.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ycollette yann collette
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: