Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-34794

Jenkins doesn't start because of NPE

    XMLWordPrintable

Details

    Description

      hudson.util.HudsonFailedToLoad: java.lang.NullPointerException
      at hudson.WebAppMain$3.run(WebAppMain.java:237)
      
      Caused by: java.lang.NullPointerException
      at org.jvnet.hudson.plugins.monitoring.NodesListener.getNodesCollector(NodesListener.java:77)
      at org.jvnet.hudson.plugins.monitoring.NodesListener.onOnline(NodesListener.java:53)
      at jenkins.model.Jenkins.<init>(Jenkins.java:850)
      at hudson.model.Hudson.<init>(Hudson.java:83)
      at hudson.model.Hudson.<init>(Hudson.java:79)
      at hudson.WebAppMain$3.run(WebAppMain.java:225)
      

      Attachments

        Activity

          fbelzunc Félix Belzunce Arcos created issue -
          fbelzunc Félix Belzunce Arcos made changes -
          Field Original Value New Value
          Description
          {code:java}
          hudson.util.HudsonFailedToLoad: java.lang.NullPointerException
          at hudson.WebAppMain$3.run(WebAppMain.java:237)

          Caused by: java.lang.NullPointerException
          at org.jvnet.hudson.plugins.monitoring.NodesListener.getNodesCollector(NodesListener.java:77)
          at org.jvnet.hudson.plugins.monitoring.NodesListener.onOnline(NodesListener.java:53)
          at jenkins.model.Jenkins.<init>(Jenkins.java:850)
          at hudson.model.Hudson.<init>(Hudson.java:83)
          at hudson.model.Hudson.<init>(Hudson.java:79)
          at hudson.WebAppMain$3.run(WebAppMain.java:225)
          {code}
          {code:java}
          hudson.util.HudsonFailedToLoad: java.lang.NullPointerException
          at hudson.WebAppMain$3.run(WebAppMain.java:237)

          Caused by: java.lang.NullPointerException
          at org.jvnet.hudson.plugins.monitoring.NodesListener.getNodesCollector(NodesListener.java:77)
          at org.jvnet.hudson.plugins.monitoring.NodesListener.onOnline(NodesListener.java:53)
          at jenkins.model.Jenkins.<init>(Jenkins.java:850)
          at hudson.model.Hudson.<init>(Hudson.java:83)
          at hudson.model.Hudson.<init>(Hudson.java:79)
          at hudson.WebAppMain$3.run(WebAppMain.java:225)
          {code}
          Priority Minor [ 4 ] Major [ 3 ]
          fbelzunc Félix Belzunce Arcos made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          evernat evernat added a comment -

          It seems that either

          Jenkins.getInstance().getPlugin(org.jvnet.hudson.plugins.monitoring.PluginImpl.class)
          

          returns null or

          PluginImpl.start()
          

          is not called by Jenkins.

          PluginImpl is supposed to be initialized by Jenkins because PluginImpl extends Plugin.

          How to reproduce the issue?
          And what version of Jenkins was used?

          evernat evernat added a comment - It seems that either Jenkins.getInstance().getPlugin(org.jvnet.hudson.plugins.monitoring.PluginImpl.class) returns null or PluginImpl.start() is not called by Jenkins. PluginImpl is supposed to be initialized by Jenkins because PluginImpl extends Plugin. How to reproduce the issue? And what version of Jenkins was used?

          Unfortunately, it looks like it is a transient issue - so I don't know how to re-produce it.

          You are right. I am updating the PR right now.

          Thanks for your feedback!

          fbelzunc Félix Belzunce Arcos added a comment - Unfortunately, it looks like it is a transient issue - so I don't know how to re-produce it. You are right. I am updating the PR right now. Thanks for your feedback!

          Code changed in jenkins
          User: Felix Belzunce Arcos
          Path:
          src/main/java/org/jvnet/hudson/plugins/monitoring/NodesListener.java
          http://jenkins-ci.org/commit/monitoring-plugin/9630aaacd285e91b0de87b590dd76ac6d751c54f
          Log:
          [fixed JENKINS-34794] Jenkins sometimes doesn't start because of transient NPE (#5)

          [fixed JENKINS-34794] Jenkins sometimes doesn't start because of transient NPE

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Felix Belzunce Arcos Path: src/main/java/org/jvnet/hudson/plugins/monitoring/NodesListener.java http://jenkins-ci.org/commit/monitoring-plugin/9630aaacd285e91b0de87b590dd76ac6d751c54f Log: [fixed JENKINS-34794] Jenkins sometimes doesn't start because of transient NPE (#5) [fixed JENKINS-34794] Jenkins sometimes doesn't start because of transient NPE
          scm_issue_link SCM/JIRA link daemon made changes -
          Resolution Fixed [ 1 ]
          Status In Progress [ 3 ] Resolved [ 5 ]
          bcoveny Bruce Coveny added a comment -

          Last night we updated to Jenkins 2.9 from 2.8 and also the monitoring plugin was updated from 1.57 to 1.59. We are no experiencing this issue and had to downgrade the plugin. When will this be released as it is marked as resolved.

          bcoveny Bruce Coveny added a comment - Last night we updated to Jenkins 2.9 from 2.8 and also the monitoring plugin was updated from 1.57 to 1.59. We are no experiencing this issue and had to downgrade the plugin. When will this be released as it is marked as resolved.
          evernat evernat added a comment -

          Hi Bruce,

          In fact, it was released just 2 hours before you ask.
          The plugin should be available in your update center now or in 24h.

          evernat evernat added a comment - Hi Bruce, In fact, it was released just 2 hours before you ask. The plugin should be available in your update center now or in 24h.
          rtyler R. Tyler Croy made changes -
          Workflow JNJira [ 170985 ] JNJira + In-Review [ 198997 ]

          People

            fbelzunc Félix Belzunce Arcos
            fbelzunc Félix Belzunce Arcos
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: