Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3483

ERROR: Failed to parse svn info for external

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Error occurs when the following conditions are met:
      -"Source Code Management" Subversion
      -"Local module directory" has been specified
      -Build runs on a Linux node (probably with all *nix's)
      -"Remote FS root" of node has a symbolic link in it.

      In this case the path is malformed; the full path, w/o symlinks, is appended to
      the local module directory.

        Attachments

          Issue Links

            Activity

            maartenvandewaarsenburg maartenvandewaarsenburg created issue -
            mdonohue mdonohue added a comment -

            How does your experience compare to issue 1330 issue 3013 issue 2422 or issue 2756 ?

            Also, could you include the console output or logging output with the malformed
            path, and indicate what you think it should really be.

            maartenvandewaarsenburg maartenvandewaarsenburg added a comment -

            The node I'm building the project on is an Intel 64 bits machine, therefore it
            compares to 3013. I cannot see further similarities.

            This is what I did.

            In the project specification, the 'Local module directory' is set to 'trunk'.

            In the node specification, the 'Remote FS root' is set to
            /home/buildmaster/build/.hudson.

            On the node the build directory of the above path symlinks to
            /lotsofspace/build/buildmaster.

            As you can see below, the path where it tries to find the external is
            constructed the wrong way.
            It says
            'trunk/lotsofspace/build/buildmaster/.hudson/workspace/Server/trunk/product/code
            /DesignStudio/code/Shared//ExpressionParser' where it either should say

            '/lotsofspace/build/buildmaster/.hudson/workspace/Server/trunk/product/code/Desi
            gnStudio/code/Shared/ExpressionParser' (absolute path without symlinks)

            or

            'trunk/product/code/DesignStudio/code/Shared/ExpressionParser' (path relative to
            ${WORKSPACE})

            or

            '/home/buildmaster/build/.hudson/workspace/Server/trunk/product/code/DesignStudi
            o/code/Shared/ExpressionParser' (absolute path with symlink).

            I worked around the problem by setting the 'Remote FS root' to /lotsofspace/build/buildmaster/.hudson, so avoiding the symlink.

            Updating svn+ssh://svn.verum.local/home/svn/new_repository/Projects/Verum
            Internal Projects/ASD Product Development/trunk
            Fetching
            'svn+ssh://svn.verum.local/home/svn/new_repository/Projects/Verum%20Internal%20P
            rojects/ASD%20Product%20Development/trunk/product/code/Shared/ExpressionParser'
            at -1 into
            '/lotsofspace/build/buildmaster/.hudson/workspace/Server/trunk/product/code/Desi
            gnStudio/code/Shared/ExpressionParser'
            At revision 18432
            Fetching
            'svn+ssh://svn.verum.local/home/svn/new_repository/Projects/Verum%20Internal%20P
            rojects/ASD%20Product%20Development/trunk/product/code/Shared/ipc' at -1 into
            '/lotsofspace/build/buildmaster/.hudson/workspace/Server/trunk/product/code/Desi
            gnStudio/code/Shared/ipc'
            At revision 18432
            At revision 18432
            Updating svn+ssh://svn.verum.local/home/svn/partslib/verum/server/current
            At revision 36
            ERROR: Failed to parse svn info for external
            svn+ssh://svn.verum.local/home/svn/new_repository/Projects/Verum Internal
            Projects/ASD Product Development/trunk/product/code/Shared/ExpressionParser at
            trunk/lotsofspace/build/buildmaster/.hudson/workspace/Server/trunk/product/code/
            DesignStudio/code/Shared//ExpressionParser
            org.tmatesoft.svn.core.SVNException: svn:
            '/home/buildmaster/build/.hudson/workspace/Server/trunk/lotsofspace/build/buildm
            aster/.hudson/workspace/Server/trunk/product/code/DesignStudio/code/Shared' is
            not a working copy
            at
            org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64
            )
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNAdminAreaFactory.open(SVNAdminAreaFa
            ctory.java:149)
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.doOpen(SVNWCAccess.java:355
            )
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.open(SVNWCAccess.java:263)
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.probeOpen(SVNWCAccess.java:
            290)
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.probeOpen(SVNWCAccess.java:
            275)
            at
            org.tmatesoft.svn.core.wc.SVNWCClient.crawlEntries(SVNWCClient.java:3027)
            at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2271)
            at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2647)
            at
            hudson.scm.SubversionSCM$BuildRevisionMapTask.invoke(SubversionSCM.java:780)
            at
            hudson.scm.SubversionSCM$BuildRevisionMapTask.invoke(SubversionSCM.java:750)
            at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1517)
            at hudson.remoting.UserRequest.perform(UserRequest.java:92)
            at hudson.remoting.UserRequest.perform(UserRequest.java:46)
            at hudson.remoting.Request$2.run(Request.java:236)
            at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
            at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
            at java.util.concurrent.FutureTask.run(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
            Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
            ERROR: Failed to parse svn info for external
            svn+ssh://svn.verum.local/home/svn/new_repository/Projects/Verum Internal
            Projects/ASD Product Development/trunk/product/code/Shared/ipc at
            trunk/lotsofspace/build/buildmaster/.hudson/workspace/Server/trunk/product/code/
            DesignStudio/code/Shared//ipc
            org.tmatesoft.svn.core.SVNException: svn:
            '/home/buildmaster/build/.hudson/workspace/Server/trunk/lotsofspace/build/buildm
            aster/.hudson/workspace/Server/trunk/product/code/DesignStudio/code/Shared' is
            not a working copy
            at
            org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64
            )
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNAdminAreaFactory.open(SVNAdminAreaFa
            ctory.java:149)
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.doOpen(SVNWCAccess.java:355
            )
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.open(SVNWCAccess.java:263)
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.probeOpen(SVNWCAccess.java:
            290)
            at
            org.tmatesoft.svn.core.internal.wc.admin.SVNWCAccess.probeOpen(SVNWCAccess.java:
            275)
            at
            org.tmatesoft.svn.core.wc.SVNWCClient.crawlEntries(SVNWCClient.java:3027)
            at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2271)
            at org.tmatesoft.svn.core.wc.SVNWCClient.doInfo(SVNWCClient.java:2647)
            at
            hudson.scm.SubversionSCM$BuildRevisionMapTask.invoke(SubversionSCM.java:780)
            at
            hudson.scm.SubversionSCM$BuildRevisionMapTask.invoke(SubversionSCM.java:750)
            at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1517)
            at hudson.remoting.UserRequest.perform(UserRequest.java:92)
            at hudson.remoting.UserRequest.perform(UserRequest.java:46)
            at hudson.remoting.Request$2.run(Request.java:236)
            at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
            at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
            at java.util.concurrent.FutureTask.run(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown
            Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)

            mdonohue mdonohue added a comment -

            Duplicate

                • This issue has been marked as a duplicate of 3013 ***
            mdonohue mdonohue made changes -
            Field Original Value New Value
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Resolved [ 5 ]
            mdonohue mdonohue made changes -
            Link This issue duplicates JENKINS-3013 [ JENKINS-3013 ]
            abayer Andrew Bayer made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            rtyler R. Tyler Croy made changes -
            Workflow JNJira [ 133556 ] JNJira + In-Review [ 202248 ]

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              maartenvandewaarsenburg maartenvandewaarsenburg
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: