XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Fails to parse the Emma-Input-File:

      hudson.util.IOException2: Failed to parse
      /home/tascheb/.hudson/jobs/Info-Manager/builds/2007-03-08_09-33-29/emma.xml
      at hudson.plugins.emma.EmmaBuildAction.load(EmmaBuildAction.java:115)
      at hudson.plugins.emma.EmmaPublisher.perform(EmmaPublisher.java:33)
      at hudson.model.Build$RunnerImpl.post(Build.java:135)
      at hudson.model.Run.run(Run.java:562)
      at hudson.model.Build.run(Build.java:99)
      at hudson.model.Executor.run(Executor.java:61)
      Caused by: org.xmlpull.v1.XmlPullParserException: expected event START_TAG with
      name 'coverage' and with namespace '' but got name 'package' (postion: START_TAG
      seen ...ue="8% (9943/118717)"/>\n\n <package name="de.lexis.lexdiff">...
      @15:40)
      at org.xmlpull.mxp1.MXParser.require(MXParser.java:973)
      at hudson.plugins.emma.EmmaBuildAction.load(EmmaBuildAction.java:138)
      at hudson.plugins.emma.EmmaBuildAction.load(EmmaBuildAction.java:113)
      ... 5 more
      finished: FAILURE

      I am using the latest Hudson and Emma-Release

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          This seems like a well-formedness error in the emma.xml file.

          troggan troggan added a comment -

          I tried to reproduce it this morning, but I failed . You're free to close this
          bug.

          kohsuke Kohsuke Kawaguchi added a comment -

          This seems like a totally different error, though. The
          /home/tascheb/.hudson/jobs/Info-Manager/builds/2007-03-15_09-28-00/emma.xml file
          is probably not well-formed. Can you check?

          troggan troggan added a comment -

          Sorry, this is not fixed in v1.87 :

          Recording Emma reports trunk/release/emma/coverage.emma
          FATAL: failed
          hudson.util.IOException2: Failed to parse
          /home/tascheb/.hudson/jobs/Info-Manager/builds/2007-03-15_09-28-00/emma.xml
          at hudson.plugins.emma.EmmaBuildAction.load(EmmaBuildAction.java:115)
          at hudson.plugins.emma.EmmaPublisher.perform(EmmaPublisher.java:33)
          at hudson.model.Build$RunnerImpl.post(Build.java:135)
          at hudson.model.Run.run(Run.java:557)
          at hudson.model.Build.run(Build.java:99)
          at hudson.model.Executor.run(Executor.java:61)
          Caused by: org.xmlpull.v1.XmlPullParserException: only whitespace content
          allowed before start tag and not E (position: START_DOCUMENT seen E... @1:1)
          at org.xmlpull.mxp1.MXParser.parseProlog(MXParser.java:1475)
          at org.xmlpull.mxp1.MXParser.nextImpl(MXParser.java:1351)
          at org.xmlpull.mxp1.MXParser.next(MXParser.java:1061)
          at org.xmlpull.mxp1.MXParser.nextTag(MXParser.java:1046)
          at hudson.plugins.emma.EmmaBuildAction.load(EmmaBuildAction.java:128)
          at hudson.plugins.emma.EmmaBuildAction.load(EmmaBuildAction.java:113)
          ... 5 more
          finished: FAILURE

          kohsuke Kohsuke Kawaguchi added a comment -

          Fixed in 1.6.

          I didn't realize that line coverage can be disabled, and that was causing a
          parse error.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            troggan troggan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: