Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-351

Maven 2 Projects URL-Problem

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      The URLs for artefacts in the webinterface are not working. The URLs are build
      this way:

      http://localhost:8080/hudson/job/PROJECTNAME/groupID:artefactId/

      If I click on that link, I get this error:

      HTTP Status 400 - There are some problems in the request: invalid URLPatternSpec

      type Status report

      message There are some problems in the request: invalid URLPatternSpec

      description The request sent by the client was syntactically incorrect (There
      are some problems in the request: invalid URLPatternSpec).

        Attachments

          Activity

          kohsuke Kohsuke Kawaguchi added a comment -

          What container do you use, and what browser do you use?

          Maybe I should avoid using ':' if some containers or browsers get confused.

          troggan troggan added a comment -

          I use Glassfish under Fedora Core 6.

          Yes, you should avoid ":".

          I haven't tested it, but if you create Directories with ":" in Windows, like
          Hudson did on my linux machine, you will have serious problems.

          kohsuke Kohsuke Kawaguchi added a comment -

          On file systems Hudson don't use ':'.

          What browser do you use?

          troggan troggan added a comment -

          Are you sure? I am not 100% sure atm, but I think I saw a Directory with
          groupid:artefactid in my Hudson-Directory. I will check that tomorrow.

          I tried using IE 6.0, Firefox 2.0, Konqueror from KDE 3.5 and Opera 9. I even
          tried to manipulate the ":" in the URL and replace it with the encoded Version
          of ":", but it failed.

          kohsuke Kohsuke Kawaguchi added a comment -

          Yeah, I'm fairly positive. I develop Hudson on Windows, so if I used ':', it
          would have been failed right away.

          Given that you tried so many browsers, I guess it must be Glassfish. I'll see if
          I can reproduce the problem, and if it's indeed Glassfish problem, I think it's
          best to just stop using ':' in URL altogether.

          Maybe I should just replace it by slash.

          http://localhost:8080/hudson/job/PROJECTNAME/groupID/artefactId/

          it's a bit more involved change but probably worthwhile.

          kohsuke Kohsuke Kawaguchi added a comment -

          http://localhost:8080/hudson/job/PROJECTNAME/groupID/artefactId/ doesn't work
          because 'groupID' portion may collide with other reserved views.

          So I reverted back to groupId$artifactId, which is not visually pleasing, but
          it's at least consistent with file system names.

          troggan troggan added a comment -

          Ok, but theres another Problem.

          I was wrong with ":" in the FileSystem, but the "$" is not a good for directory
          names either. Under Windows Java has some serious Problems with special chars
          like $ or similar in Names of Directories/Files. Sometimes it can't open Files
          in such a Directory.

          kohsuke Kohsuke Kawaguchi added a comment -

          Again, I'm developing this on Windows, and already deployed it on Solaris. Some
          people have clearly been using this feature, and I've never heard such a problem.

          '$' is not a special character in all the file systems that I know of.

          troggan troggan added a comment -

          I didn't say that $ is a special character in the Windows-File-System, but that
          Java has some problems dealing with directories with $ in the Name.

          Many Users of TVBrowser.org (a digital program guide with over 100.000 Users)
          report that problem, when they try to install it in a directory with "$" in the
          Name. E.g. "D:/$tuff/TVBrowser" will fail because of a internal Java-Error.

          troggan troggan added a comment -

          Ps.: I am one of the coders of tvbrowser.

          kohsuke Kohsuke Kawaguchi added a comment -

          Do you have pointers to more details about those issues?

          Personally, I've never heard of such an issue in JRE.


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            troggan troggan
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: