Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36138

No msbuild section in configuration or global tools after install

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Not A Defect
    • Component/s: msbuild-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.10 and msbuild plugin 1.25
    • Similar Issues:

      Description

      I have installed latest version but i cant set the path for msbuild.exe in configuration

        Attachments

        1. 1.JPG
          1.JPG
          109 kB
        2. 2.JPG
          2.JPG
          59 kB

          Issue Links

            Activity

            govendhan Govendhan Chandrasekar created issue -
            Hide
            marshall777 Lionel Cabasson added a comment -

            Hello,

            Could you please retry with msbuild-plugin 1.26 ?

            Thanks

            Show
            marshall777 Lionel Cabasson added a comment - Hello, Could you please retry with msbuild-plugin 1.26 ? Thanks
            rtyler R. Tyler Croy made changes -
            Field Original Value New Value
            Workflow JNJira [ 172793 ] JNJira + In-Review [ 184781 ]
            Hide
            comsiro Sahyun Kim added a comment -

            Same error...

            Show
            comsiro Sahyun Kim added a comment - Same error...
            Hide
            agciber Antonio Guglielmo added a comment -

            Also do not see this on a Mac Mini fresh jenkins install on version 1.26

            Show
            agciber Antonio Guglielmo added a comment - Also do not see this on a Mac Mini fresh jenkins install on version 1.26
            Hide
            agciber Antonio Guglielmo added a comment -

            I recommend combining this report with JENKINS-34577 since the details seems to indicate the same behavior

            Show
            agciber Antonio Guglielmo added a comment - I recommend combining this report with JENKINS-34577 since the details seems to indicate the same behavior
            Hide
            agciber Antonio Guglielmo added a comment -

            Rolled Jenkins Back to 1.651.3 and can now see the admin configuration at a global level. Seems to be a version mismatch in some config / and or the missing global.jelly that I can see some other plugins that are working successfully. Its a issue with the jenkins version, not the plugin specifically but should be enhanced to support the new versions of jenkins.

            Show
            agciber Antonio Guglielmo added a comment - Rolled Jenkins Back to 1.651.3 and can now see the admin configuration at a global level. Seems to be a version mismatch in some config / and or the missing global.jelly that I can see some other plugins that are working successfully. Its a issue with the jenkins version, not the plugin specifically but should be enhanced to support the new versions of jenkins.
            marshall777 Lionel Cabasson made changes -
            Link This issue is duplicated by JENKINS-34577 [ JENKINS-34577 ]
            Hide
            marshall777 Lionel Cabasson added a comment -

            Antonio Guglielmo Thanks for your feedback, I may try to investigate this matter when I can find some time.

            Show
            marshall777 Lionel Cabasson added a comment - Antonio Guglielmo Thanks for your feedback, I may try to investigate this matter when I can find some time.
            marshall777 Lionel Cabasson made changes -
            Attachment 1.JPG [ 33488 ]
            Attachment 2.JPG [ 33489 ]
            Hide
            marshall777 Lionel Cabasson added a comment -

            Hello,

            I tested it on Jenkins 2.7.1 and I can see the msbuild configuration section. However the configuration of tools is not anymore in the "Configure System" but in the "Global Tool Configuration" (see linked screenshots). I guess you're simply looking at the wrong place (as I did for quite some time).

            Show
            marshall777 Lionel Cabasson added a comment - Hello, I tested it on Jenkins 2.7.1 and I can see the msbuild configuration section. However the configuration of tools is not anymore in the "Configure System" but in the "Global Tool Configuration" (see linked screenshots). I guess you're simply looking at the wrong place (as I did for quite some time).
            marshall777 Lionel Cabasson made changes -
            Assignee kdsweeney [ kdsweeney ] Lionel Cabasson [ marshall777 ]
            marshall777 Lionel Cabasson made changes -
            Resolution Not A Defect [ 7 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              marshall777 Lionel Cabasson
              Reporter:
              govendhan Govendhan Chandrasekar
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: