Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36631

Exception when publishing, exception message [null]

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Incomplete
    • Jenkins 1.625.16.1 (CloudBees Jenkins Enterprise 15.11) running on Windows Server 2012
      Publish Over SSH version 1.14

    Description

      We're running into an error, but there are no logs or error message to help with the toubleshooting:

      {{SSH: Connecting from host [xxxxxxxx]
      SSH: Connecting with configuration [test_p805] ...
      SSH: Creating session: username [p805s1], hostname [xxxxxxxx], port [22]
      SSH: Connecting session ...
      SSH: Connected
      SSH: Opening SFTP channel ...
      SSH: SFTP channel open
      SSH: Connecting SFTP channel ...
      SSH: Connected
      SSH: cd [/]
      SSH: OK
      SSH: cd [/]
      SSH: OK
      SSH: cd [correct/destination/path]
      SSH: OK
      SSH: Disconnecting configuration [test_p805] ...
      ERROR: Exception when publishing, exception message [null]
      Build step 'Send build artifacts over SSH' changed build result to UNSTABLE}}

      We have a number of successful jobs working with this same configuration (test_p805). For this particular step, the configuration looks like this:

      <jenkins.plugins.publish_over_ssh.BapSshTransfer>
      <remoteDirectory>/correct/destination/path</remoteDirectory>
      <sourceFiles>${source_files}</sourceFiles>
      <excludes></excludes>
      <removePrefix></removePrefix>
      <remoteDirectorySDF>false</remoteDirectorySDF>
      <flatten>true</flatten>
      <cleanRemote>true</cleanRemote>
      <noDefaultExcludes>false</noDefaultExcludes>
      <makeEmptyDirs>false</makeEmptyDirs>
      <patternSeparator>[, ]+</patternSeparator>
      <execCommand></execCommand>
      <execTimeout>600000</execTimeout>
      <usePty>false</usePty>
      </jenkins.plugins.publish_over_ssh.BapSshTransfer>

      where ${source_files} is a pattern that should pick up a jar file: target\scala-2.10*.jar, and I've confirmed that a jar is in that location in the workspace.

      Attachments

        Activity

          For your information, all publish-over-ssh component type JENKINS issues related to the Publish Over SSH plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues

          Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues/134
          And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-ssh-plugin/issues?q=%22JENKINS-36631%22

          (Note: this is an automated bulk comment)

          gmcdonald Gavin McDonald added a comment - For your information, all publish-over-ssh component type JENKINS issues related to the Publish Over SSH plugin have been transferred to Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues Here is the direct link to this issue in Github: https://github.com/jenkinsci/publish-over-ssh-plugin/issues/134 And here is the link to a search for related issues: https://github.com/jenkinsci/publish-over-ssh-plugin/issues?q=%22JENKINS-36631%22 (Note: this is an automated bulk comment)
          slide_o_mix Alex Earl added a comment -

          Is there anything in the Jenkins logs?

          slide_o_mix Alex Earl added a comment - Is there anything in the Jenkins logs?
          rachel Rachel M. added a comment -

          Maybe it's because of:

          /correct/destination/path
          

          It's not a valid path in Windows Server.

          rachel Rachel M. added a comment - Maybe it's because of: /correct/destination/path It's not a valid path in Windows Server.

          People

            slide_o_mix Alex Earl
            finleysg Stuart Finley
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: