Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-36866

Pipeline is started after Jenkins restart

    XMLWordPrintable

Details

    Description

      I used a simple pipeline with two stages like this:

      node {
          def mvnHome = tool 'Maven-3.3.9'
          stage 'Checkout'
          svn '****/trunk/'
      
          stage 'Build'
          sh "${mvnHome}/bin/mvn clean package"
          step([$class: 'JUnitResultArchiver', testResults: '**/target/surefire-reports/TEST-*.xml'])
         
          stage 'Analysis'
          def sonarProperties='***'
          sh "${mvnHome}/bin/mvn $sonarProperties test sonar:sonar"
      }
      

      As Build Trigger I use Poll SCM for every minute (* * * * *). However each time I update a plugin and restart Jenkins via the web gui the Job is started even no changes are committed. However the polling log will say "Changes found" and has the same revision as the last build (which was triggered correctly because of a change).

      All non Pipeline jobs with same polling setup did not rerun after a restart.

      Attachments

        Activity

          mszalbach mszalbach created issue -
          rtyler R. Tyler Croy made changes -
          Field Original Value New Value
          Workflow JNJira [ 173613 ] JNJira + In-Review [ 185232 ]
          mszalbach mszalbach added a comment -

          Updates some of the Pipeline plugins to newest version (Pipeline: Job 2.4, Pipeline: Nodes and Processes 2.4, Pipeline Groovy 2.10) and after restart the jobs where not triggered again.

          mszalbach mszalbach added a comment - Updates some of the Pipeline plugins to newest version (Pipeline: Job 2.4, Pipeline: Nodes and Processes 2.4, Pipeline Groovy 2.10) and after restart the jobs where not triggered again.
          mszalbach mszalbach made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]

          People

            Unassigned Unassigned
            mszalbach mszalbach
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: