• Icon: Improvement Improvement
    • Resolution: Unresolved
    • Icon: Minor Minor
    • gradle-plugin
    • None

      The Gradle buildstep provides a string parameter named "Switches". The term is a bit misleading as the value you put in there is actually a Gradle commandline option.

      I would prefer to change the used term "Switches" to "Options" to conform to the standard.

      To be done: Change parameter name and description (by the way: the description could link to the Gradle commandline documentation).

          [JENKINS-37058] change term "switches" to "options"

          Stephan Krull created issue -
          Stephan Krull made changes -
          Remote Link New: This issue links to "Gradle Commandline documentation (Web Link)" [ 14686 ]
          Stephan Krull made changes -
          Attachment New: Screenshot from 2016-07-29 10-56-09.png [ 33483 ]
          Stephan Krull made changes -
          Description Original: The Gradle buildstep provides a string parameter named "Switches". The term is a bit misleading as the value you put in there is actually a Gradle commandline *option*.

          I would prefer to change the used term "Switches" to "Options" to conform to the standard.
          New: The Gradle buildstep provides a string parameter named "Switches". The term is a bit misleading as the value you put in there is actually a Gradle commandline *option*.

          I would prefer to change the used term "Switches" to "Options" to conform to the standard.

          To be done: Change parameter name and description.
          Stephan Krull made changes -
          Description Original: The Gradle buildstep provides a string parameter named "Switches". The term is a bit misleading as the value you put in there is actually a Gradle commandline *option*.

          I would prefer to change the used term "Switches" to "Options" to conform to the standard.

          To be done: Change parameter name and description.
          New: The Gradle buildstep provides a string parameter named "Switches". The term is a bit misleading as the value you put in there is actually a Gradle commandline *option*.

          I would prefer to change the used term "Switches" to "Options" to conform to the standard.

          To be done: Change parameter name and description (by the way: the description could link to the [Gradle commandline documentation|https://docs.gradle.org/current/userguide/gradle_command_line.html]).

            wolfs Stefan Wolf
            krulls Stephan Krull
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated: