Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37080

PluginManager must warn minimal java version

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      We have this issue all time when plugins starting using newer java versions. Plugin may need newer java version then core java version. In this case plugin manager must warn or even block ability to install the plugin.

      1. check/add information into update-center.json
      2. support PluginManager with UI

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              integer Kanstantsin Shautsou
              Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: