Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37382

Failed Loading plugin Change Log History v1.4 (changelog-history)

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Getting error after upgrading Jenkins from 2.13 to 2.16:
      In jenkins.log

      SCHWERWIEGEND: Failed Loading plugin Change Log History v1.4 (changelog-history)
      java.io.IOException: Change Log History v1.4 failed to load.
       - Jenkins Subversion Plug-in v2.6 is older than required. To fix, install v2.6-20160601.015946-1 or later.
              at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:621)
              at hudson.PluginManager$2$1$1.run(PluginManager.java:511)
              at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
              at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
              at jenkins.model.Jenkins$7.runTask(Jenkins.java:1026)
              at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
              at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
              at java.lang.Thread.run(Thread.java:745)
      

      On Jenkins manage screen:

      There are dependency errors loading some plugins:
      
          Change Log History v1.4
              Jenkins Subversion Plug-in v2.6 is older than required. To fix, install v2.6-20160601.015946-1 or later.
      

      Jenkins 2.16 and 2.17 have the same error. Downgrade back to 2.15 solves the problem.

        Attachments

          Issue Links

            Activity

            zhh205 zhh205 created issue -
            zhh205 zhh205 made changes -
            Field Original Value New Value
            Description Getting error after upgrading Jenkins from 2.13 to 2.16:
            In jenkins.log
            {code}
            SCHWERWIEGEND: Failed Loading plugin Change Log History v1.4 (changelog-history)
            java.io.IOException: Change Log History v1.4 failed to load.
             - Jenkins Subversion Plug-in v2.6 is older than required. To fix, install v2.6-20160601.015946-1 or later.
                    at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:621)
                    at hudson.PluginManager$2$1$1.run(PluginManager.java:511)
                    at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
                    at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
                    at jenkins.model.Jenkins$7.runTask(Jenkins.java:1026)
                    at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
                    at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
                    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
                    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
                    at java.lang.Thread.run(Thread.java:745)
            {code}
            On Jenkins manage screen:
            {code}
            There are dependency errors loading some plugins:

                Change Log History v1.4
                    Jenkins Subversion Plug-in v2.6 is older than required. To fix, install v2.6-20160601.015946-1 or later.
            {code}

            Jenkins 2.16 and 2.17 have the same error. 2.15 doesnt have problem.
            Getting error after upgrading Jenkins from 2.13 to 2.16:
            In jenkins.log
            {code}
            SCHWERWIEGEND: Failed Loading plugin Change Log History v1.4 (changelog-history)
            java.io.IOException: Change Log History v1.4 failed to load.
             - Jenkins Subversion Plug-in v2.6 is older than required. To fix, install v2.6-20160601.015946-1 or later.
                    at hudson.PluginWrapper.resolvePluginDependencies(PluginWrapper.java:621)
                    at hudson.PluginManager$2$1$1.run(PluginManager.java:511)
                    at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
                    at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
                    at jenkins.model.Jenkins$7.runTask(Jenkins.java:1026)
                    at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
                    at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
                    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
                    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
                    at java.lang.Thread.run(Thread.java:745)
            {code}
            On Jenkins manage screen:
            {code}
            There are dependency errors loading some plugins:

                Change Log History v1.4
                    Jenkins Subversion Plug-in v2.6 is older than required. To fix, install v2.6-20160601.015946-1 or later.
            {code}

            Jenkins 2.16 and 2.17 have the same error. Downgrade back to 2.15 solves the problem.
            escoem Emilio Escobar made changes -
            Link This issue duplicates JENKINS-37131 [ JENKINS-37131 ]
            escoem Emilio Escobar made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              escoem Emilio Escobar
              Reporter:
              zhh205 zhh205
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: