Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-37413

Custom tools plugin is not compatiable with new pipeline plugin

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I am running Jenkins 2. I am trying to build from a Jenkinsfile

      The existing custom tools plugin is not compatiable with pipeline

      https://github.com/jenkinsci/pipeline-plugin/blob/master/COMPATIBILITY.md

      https://github.com/jenkinsci/pipeline-plugin/blob/master/TUTORIAL.md

      https://github.com/tonymurphy/sbt-pipeline

      from freenode
      tony_murphy: fixing Custom Tools plugin looks feasible, though not trivial: https://github.com/jenkinsci/pipeline-plugin/blob/master/DEVGUIDE.md

      #build-wrappers would need to make the `LauncherDecorator` be safely `Serializable`

      #!groovy
      
      node {
      
          wrap([$class: 'AnsiColorBuildWrapper', colorMapName: 'xterm']) {
              stage 'compile'
      
              def activatorHome  = tool "activator-1.3.x"
      
              stage name: 'package', concurrency: 1
              sh "${activatorHome}/activator debian:package-bin"
          }
      }
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              oleg_nenashev Oleg Nenashev
              Reporter:
              tony_murphy Tony Murphy
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: