Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38272

The credentials section of the SCM section does not get populated

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      In the Global preferences, the drop-down menu for the credentials does not get populated. Credentials are indeed configured and available and work fine while used to configure jobs.

        Attachments

          Issue Links

            Activity

            emanuelez emanuelez created issue -
            marcus_phi Marcus Philip made changes -
            Field Original Value New Value
            Priority Major [ 3 ] Critical [ 2 ]
            marcus_phi Marcus Philip added a comment -

            Just updated this plugin to get the new functionality but cannot because of this bug.

            I try to use the 'Legacy SCM' because with the 'Modern SCM' option I see nothing. What is it? Can I use it somehow?

            I have
            git-client (version:1.19.7)
            git-server (version:1.7)
            scm-api (version:1.3)

            marcus_phi Marcus Philip made changes -
            marcus_phi Marcus Philip added a comment -

            I reproduced the problem today on a plain vanilla docker image jenkinsci/jenkins:latest (Jenkins 2.22)

            marcus_phi Marcus Philip added a comment -

            FYI: Both Folder and Global credentials seems to be available on the folder level.

            marcus_phi Marcus Philip added a comment - - edited

            FYI: I have now upgraded to the latest git plugins and still the 'Modern SCM' option is unusable (and the original issue is till there as well).

            marcus_phi Marcus Philip made changes -
            Link This issue is duplicated by JENKINS-38048 [ JENKINS-38048 ]
            recampbell Ryan Campbell added a comment -

            Dupe as linked

            recampbell Ryan Campbell made changes -
            Resolution Duplicate [ 3 ]
            Status Open [ 1 ] Closed [ 6 ]

              People

              Assignee:
              jglick Jesse Glick
              Reporter:
              emanuelez emanuelez
              Votes:
              5 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: